Abstürze beim Encodieren

Unterstütze das Forum mit einem kleinen Beitrag und sichere Fortbestand und Weiterentwicklung: Jetzt Unterstützer werden!
  • Hi,

    ich nutze aktuell Tmpgenc zum Encodieren. Als Settings nutze ich die von Drexel und Demon in anderen Threads vorgeschlagenen Settings (RE: TMPGEnc Video Mastering Works 7 - Sammelthread). Das Problem habe ich jedoch auch in anderen Encodern wie Adobe Premiere beobachten können. Ich wollte daher mal in die Runde fragen, ob Ihr auch solch ein Problem mal hattet und das irgendwie lösen konntet.


    Mein Problem zeigt sich wie folgt. Ich starte einen encodier Vorgang mit NVENC. Manchmal klappt alles wunderbar, manchmal hört der Rechner einfach auf zu encodieren. Er friert nicht ein, der Timer läuft beispielsweise in Tmgenc einfach weiter. Das Problem hatte ich wie gesagt auch schon genau so in Adobe Premiere. Das Programm lässt sich dann nur noch über den Task-Manager abschießen, der PC lässt sich aber normal bedienen.


    Mein System:
    AMD Ryzen 3600

    32GB RAM

    RTX 2600 (KFA2)


    Ich habe heute nochmal alles geupdatet, von Bios bis hin zum Grafikkartentreiber, das Problem ist beim erst besten Encodiervorgang wieder aufgetreten. Ich monitore heute den ganzen Tag das System und schaue vor allem ob es überhitzt, da es zugegebenermaßen in einem Jonsbo v4 Gehäuse sitzt, welches nicht viel Platz bietet. In dem Gehäuse habe ich aber einen sauberen Luftstrom und die Temperaturen schauen beim encodieren auch okay aus (CPU, max 80 Grad, Grafikkarte: max 65 Grad). Der Rechner wird auch nicht auffallend laut und die Lüfter haben noch Headroom nach oben.


    Vielleicht kennt jemand solch ein Problem und konnte es bereits lösen?

    Grüße

    Fapf

  • Hi,

    ein BeQuiet Straight Powwer 11 650W, sollte eigentlich locker dafür reichen. Ich habe jetzt gesehen, dass der CPU nach ein paar Stunden enconding zeit gerne auch mal über 90 Grad geht max. 92. Ggf. liegt doch ein Temperaturproblem vor. Ich werde das auch nochmal weiter beobachten.


    Grüße
    Fapf

  • Hi,

    ein BeQuiet Straight Powwer 11 650W, sollte eigentlich locker dafür reichen. Ich habe jetzt gesehen, dass der CPU nach ein paar Stunden enconding zeit gerne auch mal über 90 Grad geht max. 92. Ggf. liegt doch ein Temperaturproblem vor. Ich werde das auch nochmal weiter beobachten.


    Grüße
    Fapf

    Ja das ist okay.

    Bzgl. der CPU kann ich dir nur folgendes empfehlen:

    Energiesparplan Zen2 (Ryzen 3000) | ComputerBase Forum

  • Hi,

    besten Dank für den Link. Ich habe mal diesen Energiesparplan installiert und die entsprechenden Bios-Settings gesetzt. Ich bin mal echt gespannt, wie sich das auswirken wird .


    Grüße

    Fapf

  • Hi, bin gerade wieder am encodieren. Habe das Gehäuse etwas aus dem Kalax gezogen, damit es von unten besser Luft ziehen kann. Die Temperatur ist relativ entspannt, siehe Screenshot. Ich rendere immer zwei Videos gleichzeitig. Das erste hat sich nach knapp 15 min aufgehangen (Uhr tickt noch weiter), das zweite encodiert munter weiter. Ich habe das erste Video mal gecanceled, in der Hoffnung, dass gleich wieder zwei Videos encodiert werden. Das Problem tritt aber auch auf, wenn ich nur ein Video gleichzeitig encodiere.

    Auf menem 3600x sitzt allerdings nur ein Noctua nh-l9a, da kann man keine Wunder erwarten, aber ich denke mittlerweile auch nicht mehr dass es daran liegt. Als das erste Video abgebrochen ist, waren die Temperaturen unter 80 Grad. Ich vermute aktuell das die KFA2 RTX 2600 das Problem irgendwie verursacht. Werde mal schauen, ob ich irgendwo Error-Logs finden kann.



    Edit:
    Okay Pustekuchen, das gecancelte File blockiert den zweiten Encoding-Stream. Daher abbrechen und neu starten.


    Grüße

    Fapf

  • Hi,

    drei habe nicht probiert, da meines Wissens nach bei den GeForce-Karten nur zwei Nvenc encoding streams bereit stehen. Ich habe eben nochmal auf einen runtergestellt dort ist der Fehler auch bei ersten Video direkt aufgetreten.

    Grüße

    Fapf

  • Danke für den Hinweis, Tmpgenc war tatsächlich nicht auf dem aktuellen Stand, habe dies mal nachgezogen und die Leistungsoptimierung nochmal laufen lassen. Zudem bin ich heute von Trial auf Vollversion umgestiegen, bin mal beim nächsten Encoding gespannt.


    Grüße

    Fapf

  • Ich wollte hier nochmal berichten, nach allen Updates hat sich an der o.g. Situation leider nichts geändert. Ich habe jedoch gemerkt, dass ich das Problem mit einem Enconding Stream bisher nicht reproduzieren konnte. Bei zwei Encoding Streams tritt es nahezu immer auf. Dabei habe ich beobachten können dass die CPU-Temperatur bei einem Encoding Stream bei zwischen 68 -70 Grad liegt und bei zwei bei 82-90 Grad. Ich denke momentan, sollte es nicht an der komischen Grafikkarte von mir liegen, dann könnte es ein Hitzeproblem sein. Sollte Hardware irgendwann mal bezahlbar und lieferbar sein, werde ich da ggf. auf einen 5800x und eine 3070 in einem Größeren Gehäuse und besserer Kühlung umsteigen. Mit wie vielen Streams Encodiert ihr den so?


    Grüße

    Fapf

  • Ich verstehe immer noch nicht, warum du zwei Encodes gleichzeitig laufen lassen möchtest, aber seis drum. Die 90 Grad verkraftet der 3600x schon, ab 95 geht er aber hin und taktet sich runter. Gut sind die Temps so oder so nicht, sollten aber nicht die Ursache für die Abstürze sein - eigentlich. Mich wundert es aber, dass du trotz Energiesparplan in diese Bereiche kommst. Ist der Airflow in deinem Gehäuse so brutal schlecht?


    Mit wie vielen Streams Encodiert ihr den so?

    Mit einem halt...und du hast dir die Frage woran es bei dir liegt ja schon selber beantwortet ;)

  • Hi,

    Die Hardware ist in einem Jonsbo v4 Gehäuse verbaut. Auf dem CPU sitzt ein Noctua nh-l9a. Hat zwar keinen oc headroom, aber reicht sonst aus. Im Gehäuse zieht noch ein kleiner Noctua Lüfter frische Luft ein und ein zweiter bläst raus. Die genaue Größe der beiden weiß ich gerade nicht mehr. Aber generell ist dort durch das kleine Gehäuse alles recht eng, ich habe darin alle Kabel sehr sauber verlegt damit die Luft sich besser bewegen kann, aber naja.


    Ich wollte mit zwei Streams encodieren da dadurch weniger Zeit benötigt wird. Ich habe vorhin nochmal getestet. Ein Beispielvideo in einem Stream brauchte ca. 35 Min nehme ich ein zweites dazu welches zeitgleich encodiert wird brauchen beide ca. 47 Min.


    Da ich momentan immer mehrer Videos hintereinander encodiere potenziert sich das halt nach oben. Aber sollte es halt daran liegen, dann muss ich darauf verzichten. Daher hatte es mich interessiert wie ihr das so macht 😉


    Grüße

    Fapf

  • Das heißt nix, das bezieht sich nur auf die Verteilung der Rechenlast für die Bildkomposition, Zusammensetzung des Bilds, Tonspuren Effekte etc. Das ergibt zusammen immer 100%. Der Encode des Video Streams erfolgt erst danach, die Auslastung der Encode Einheiten der Grafikkarte siehst Du im Taskmanager unter Leistung->GPU->Video Encode.

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!