Bugs und Malheurs

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Bugs und Malheurs

      Anzeige
      Hallo ihr Lieben!

      Es gibt Probleme? Ihr versteht die Welt nicht mehr? Ich habe schlecht gearbeitet? Einfach mal schimpfen und beschweren? All das ist in diesem Thread Willkommen! Hier versuchen wir eure Probleme mit batch zu beseitigen!

      Lieben Gruß
      Vincent
      Du findest mich auf YouTube! Beim Hochladen deiner Video hilft die Uploading Software batch. Wir sehen uns - bis dahin: Alles Liebe Vincent
    • ...diesmal hatte ich ein neues Problem mit der Warteschlange:

      Ich habe über Nacht ein Video hochladen wollen, die Leitung ist aber scheinbar in der Nacht weggebrochen. Der Blick in Batch zeigte mir das aber ein Großteil schon hochgeladen war.
      Ich habe mich darum gekümmert, dass die Leitung wieder geht, mußte den Rechner noch wegen einem Update neu starten...

      Nach dem Neustart habe ich Batch angeschmissen und: Warteschlange leer...

      Quellcode

      1. ERROR
      2. 3.8.2019, 10:12:58 - TypeError
      3. Cannot read property 'tokens' of undefined
      4. TypeError: Cannot read property 'tokens' of undefined
      5. at t.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1035524)
      6. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1040891
      7. at new Promise (<anonymous>)
      8. at new t (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:114771)
      9. at t.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1040760)
      10. at t.<anonymous> (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1036670)
      11. at i (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:242854)
      12. at Generator._invoke (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243911)
      13. at Generator.e.(anonymous function) [as next] (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243033)
      14. at n (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:10911)
      15. ==================================================================================
      Alles anzeigen
      -> Screenshooters -> nicht nur Screenshots sondern auch Bewegtbilder (youtube)
    • Guten Morgen @Emwe

      Wenn die Warteschleife leer ist, wurde der Upload schon vorher abgebrochen.

      Die Wiederaufnahme eines Uploads funktioniert über ein paar Stunden hinweg - danach sieht Youtube den Upload als gescheitert an.

      Wenn die Leitung einbricht, pausiert Batch den Vorgang. Danach versucht es das Video weiter hoch zu laden und überprüft dafür zunächst den Status auf YouTube. Im schlimmsten Fall sagt YouTube: Nope.

      Das, wie du richtig fest stellst zu erwartende Verhalten wäre, daß Batch von vorn beginnt und nicht den Vorgang abbricht. Das werde ich dahin gehend ändern.

      Es tut mir leid, wenn ich dir in diesem speziellen Fall nicht weiter helfen konnte :/

      Liebe Grüße
      Vincent
      Du findest mich auf YouTube! Beim Hochladen deiner Video hilft die Uploading Software batch. Wir sehen uns - bis dahin: Alles Liebe Vincent
    • Hmmm... das waren maximal 5 Stunden - manchmal lasse ich einen Tag einen Upload pausieren.

      Egal... ich habe schon das nächste Problem - ich wollte nun zwei weitere Videos hochladen, sie sind in der Warteschlange und ich habe die Warteschlange auch gestartet, aber es passiert... nichts.

      Log sagt:

      Quellcode

      1. ERROR
      2. 3.8.2019, 18:23:25 - Error
      3. No account given
      4. Error: No account given
      5. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:38770
      6. at new Promise (<anonymous>)
      7. at new t (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:114771)
      8. at e.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:38732)
      9. at t.<anonymous> (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1036577)
      10. at i (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:242854)
      11. at Generator._invoke (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243911)
      12. at Generator.e.(anonymous function) [as next] (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243033)
      13. at n (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:10911)
      14. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:11013
      15. ==================================================================================
      16. ERROR
      17. 3.8.2019, 18:23:25 - TypeError
      18. Cannot read property 'tokens' of undefined
      19. TypeError: Cannot read property 'tokens' of undefined
      20. at t.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1035524)
      21. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1040891
      22. at new Promise (<anonymous>)
      23. at new t (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:114771)
      24. at t.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1040760)
      25. at t.<anonymous> (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1036670)
      26. at i (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:242854)
      27. at Generator._invoke (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243911)
      28. at Generator.e.(anonymous function) [as next] (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243033)
      29. at n (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:10911)
      30. ==================================================================================
      Alles anzeigen
      EDIT:
      Wenn ich bei einem einzelnen Video auf "Upload starten" klicke wird es hochgeladen... ich schaue jetzt mal ob das zweite auch direkt hinterher hochgeladen wird.
      -> Screenshooters -> nicht nur Screenshots sondern auch Bewegtbilder (youtube)
    • Anzeige
      Danke für deine Mühe! Und vor allem für die Geduld!!

      Das Beschriebene schaue ich mir morgen an. Das ist sehr merkwürdig und sollte nicht passieren. Ich bin irritiert. Und offenbar gibt es Zusammenhänge bei deinen Problemen. Ich forsche da, wie gesagt morgen nach - versprochen.

      Mein letzter Post klang ein bisschen, als läge das Problem bei dir - so könnte man das zumindest lesen und so war das natürlich nicht gemeint.

      Deine Leitung ist langsam oder schnell? Ich hege nämlich einen Verdacht.

      Lieben Gruß
      Vincent
      Du findest mich auf YouTube! Beim Hochladen deiner Video hilft die Uploading Software batch. Wir sehen uns - bis dahin: Alles Liebe Vincent
    • Och, so habe ich das aber gar nicht verstanden :)

      Meine Leitung ist eine "gehoben" typische Leitung vom deutschen Hinterland: mit angelegten Ohren, rasiertem Kopf und mit Rückenwind erreicht mein Upload sagenhafte 250 KB/s, aber das ist die Ausnahme und der Regelfall liegt bei 150KB/s.

      Ich bin direkt bei der nächsten Situation wieder:
      Die Warteschlange wurde _nicht_ weiter abgearbeitet, nachdem das im vorigen Post von mir manuell gestartete Video fertig war wurde nicht das nächste hochgeladen. Dieses Video habe ich gerade eben manuell zum Upload angestoßen und... danach hatte ich etliche Einträge in Youtube mit "new"...

      Das Log wirft aus:


      Quellcode

      1. ERROR
      2. 4.8.2019, 10:29:05 - Error
      3. No account given
      4. Error: No account given
      5. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:38770
      6. at new Promise (<anonymous>)
      7. at new t (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:114771)
      8. at e.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:38732)
      9. at t.<anonymous> (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1036577)
      10. at i (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:242854)
      11. at Generator._invoke (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243911)
      12. at Generator.e.(anonymous function) [as next] (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243033)
      13. at n (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:10911)
      14. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:11013
      15. ==================================================================================
      16. ERROR
      17. 4.8.2019, 10:29:05 - TypeError
      18. Cannot read property 'tokens' of undefined
      19. TypeError: Cannot read property 'tokens' of undefined
      20. at t.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1035524)
      21. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1040891
      22. at new Promise (<anonymous>)
      23. at new t (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:114771)
      24. at t.value (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1040760)
      25. at t.<anonymous> (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1036670)
      26. at i (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:242854)
      27. at Generator._invoke (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243911)
      28. at Generator.e.(anonymous function) [as next] (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243033)
      29. at n (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:10911)
      30. ==================================================================================
      31. ERROR
      32. 4.8.2019, 10:29:05 - RangeError
      33. The value of "start" is out of range. It must be <= "end" (here: 2935657642). Received 2935657643
      34. RangeError [ERR_OUT_OF_RANGE]: The value of "start" is out of range. It must be <= "end" (here: 2935657642). Received 2935657643
      35. at new ReadStream (internal/fs/streams.js:91:13)
      36. at Object.createReadStream (fs.js:1791:10)
      37. at t.<anonymous> (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:1027559)
      38. at i (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:242854)
      39. at Generator._invoke (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243911)
      40. at Generator.e.(anonymous function) [as next] (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:101:243033)
      41. at n (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:10911)
      42. at file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:1:11053
      43. at new Promise (<anonymous>)
      44. at new t (file:///F:/Steam/Steamapps/common/YouTube%20Center/resources/app.asar/dist/electron/renderer.js:13:114771)
      45. ==================================================================================
      Alles anzeigen
      (Ist ein anderes Video als das was ich zuvor mit dem "ERR_OUT_OF_RANGE" hatte)

      EDIT: auch nachdem ich alle Videos aus der Warteschlange gelöscht und neu hinzugefügt habe konnte ich nicht die Warteschlange starten, keins der Videos wurde hochgeladen.
      Ich habe mir dann die queue-Datei angeschaut und da scheint es als ob noch "Fragmente" von einem anderen Upload drin waren der aber schon erledigt war, nachdem ich die Queue umbenannt (falls du sie haben willst) hatte und alles nochmal neu hinzufügte geht es nun: ich konnte die Warteschlange starten und es wird das erste Video aus der Warteschlange hochgeladen.
      -> Screenshooters -> nicht nur Screenshots sondern auch Bewegtbilder (youtube)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Emwe ()

    • Hallo @Emwe,

      Ich werde dir per PN eine Version von batch zum testen zukommen lassen. Ich habe versucht die von dir beschriebenen Fehler zu beseitigen. Das ganze ist ein super schweres Unterfangen, weil ich nicht ganz sicher bin, wo der Fehler einsetzt.Ich habe aber ein paar Routinen geschrieben, die diese Fehler auffangen sollten. Jetzt müssen wir nur noch testen, ob das auch funktioniert. :D Du bekommst die Version in wenigen Minuten.

      Liebe Grüße
      Vincent
      Du findest mich auf YouTube! Beim Hochladen deiner Video hilft die Uploading Software batch. Wir sehen uns - bis dahin: Alles Liebe Vincent
    • Hey Vincent,

      mein derzeitiges Problem ist kein wirklicher Bug, aber vielleicht ein fehlendes "Feature".
      Ich habe gerade auf meinem kleinen Zweitmonitor den RDP Client zu meinem Fileserver offen und dort batch geöffnet. Dadurch das der kleine Monitor keine FullHD Auflösung hat, sondern ich über RDP nur mit 1300irgendwas in der Breite und noch weniger in der Höhe Arbeitet, sehe ich die Texteingabefelder für Videobeschreibung etc. nicht. Ich habs auch mit scrolen versucht, aber da kommt leider nichts. Kurzum: Könntest du Scrolbalken einbauen die auftauchen, sobald batch nicht mehr komplett angezeigt werden kann?
    • Jetzt ist doch noch irgendwas schief gelaufen. batch hat sich aufgehängt und auch den Server gecrashed, aktuell startet er neu. Ich habe ein Video hinzugefügt, angekommen ist bei YouTube folgendes:

      abload.de/img/kaputtvaj6p.png

      Das geht über drei Seiten. Wenn in der Log was steht, reiche ich es gleich nach.

      EDIT:
      Log ist erfreulicherweise sehr voll:
      pastebin.com/U27KT2s3

      EDIT2:
      Die Uploadgeschwindigkeit stellt sich random immer noch auf 10 mBit um. Nach einem Neustart gerade schon wieder.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Game8 ()

    • Game8 schrieb:

      Jetzt ist doch noch irgendwas schief gelaufen. batch hat sich aufgehängt und auch den Server gecrashed, aktuell startet er neu. Ich habe ein Video hinzugefügt, angekommen ist bei YouTube folgendes:

      abload.de/img/kaputtvaj6p.png

      Das geht über drei Seiten. Wenn in der Log was steht, reiche ich es gleich nach.

      EDIT:
      Log ist erfreulicherweise sehr voll:
      pastebin.com/U27KT2s3

      EDIT2:
      Die Uploadgeschwindigkeit stellt sich random immer noch auf 10 mBit um. Nach einem Neustart gerade schon wieder.
      Ich habe in den letzten Tagen vorallem durch die freundliche Hilfe von Emwe die Warteschleife bei Extremfällen stabilisieren können. Ein solches Bild, dass sich dir bot wird es nicht mehr geben. Nach max. 5 Versuchen ist Schluss.

      Dazu könnte es in extremen Einzelfällen zu Authentifizierungsproblemen kommen.

      Diesen "List-Error" untersuchen ich noch.

      Für den Lösch-Error werde ich auch noch etwas tippen. Der hat dann das Programm wohl zum Absturz gebracht.

      Was die Upload Geschwindigkeit angeht, ist mir zwar schleierhaft, wie es dazu kommt, aber das versuche ich zu fixen.

      Das Problem in den Templates ist mir bekannt, aber es ist wirklich kompliziert zu fixen. Wenn hier HTML und Css Experten unterwegs sind - ihr seid Willkommen!

      Danke für die Nachricht ihr beiden. Ich versuche das aktuelle Update bis zum Wochenende fertig zu bekommen. Und es gibt für die Betas dann auch eine pre alpha preview concept study für Analytics. :D

      Liebe Grüße
      Vincent
      Du findest mich auf YouTube! Beim Hochladen deiner Video hilft die Uploading Software batch. Wir sehen uns - bis dahin: Alles Liebe Vincent
    • Emwe schrieb:

      Es läuft soweit ja alles wieder prima und doch bin ich über was neues-altes gestolpert:
      - ich habe eine Warteschlange die bereits abgearbeitet wird
      - füge dann noch ein weiteres Video hinzu
      - das Video wird nicht hochgeladen, nur alle Videos die in der Liste waren als ich "Start" gedrückt habe
      Da werde ich mich drum kümmern. Ich werde das wahrscheinlich so einstellen, dass die Warteschlange bereinigt wird bevor neue Videos hoch geladen werden. Das sollte das Problem fixen. Danke für die Meldung! :)

      Liebe Grüße
      Vincent
      Du findest mich auf YouTube! Beim Hochladen deiner Video hilft die Uploading Software batch. Wir sehen uns - bis dahin: Alles Liebe Vincent