MeGUI [2015] -- x264 - bester Encoder, beste Videoqualität auf Youtube ;-)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Hallo,

      ich weiß nicht ob es an einem Update liegt oder ich was ausversehen verstellt habe.

      Wenn ich in Megui im Input die AVS Datei und dann die Adio Datei einfüge und auf "AutoEncode" -> "Queue" klicke,
      beginnt er sofort den Job zu encoden.

      Ich will aber alle Aufnahmen einzeln zur Warteschlange hinzufügen ohne, dass er immer gleich mit dem encoden beginnt.
      Weiß jemand wo ich die Einstellung finde?
      Ich habe schon gesucht aber kann nichts finden.

      Also er soll die jobs erst Starten wenn ich unter Queue selber auf Start klicke.

      Danke im voraus :)

      EDIT:

      Hab die Einstellung gefunden und es wurde wohl durch ein Update geändert.
      In der Menüleiste bei "Workers" auf "Settings" gehen.
      Unten rechts den Haken bei "auto-start new jobs" herausnehmen.

      Grüße
      Danger
      Ich zocke :thumbsup:

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Danger Zockt ()

    • Nope. Den Haken gab's schon immer und ist standardmäßig aktiv.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • Hallo Leute,
      verzeiht mir meine Abstinenz. Doch ich brauche mal eure Hilfe zwecks MeGui.
      Keine Ahnung warum das Programm mittlerweile mehr Probleme als Freude macht aber egal. Deshalb frage ich ja um es wieder zum laufen zu kriegen.

      Ich habe nun gefühlt sämtliche Einstellungen in Megui vorgenommen wie im Thread beschrieben, sämtliche PlugIns / Codecs installiert. Mal 32 bit, mal 64 bit probiert doch es tut sich nichts. Megui liest das AviSynth Script ein, startet den encoding Vorgang und dann bricht er jenen Vorgang ab. Mal wegen malloc of size trotz 64 Bit was vorher ging, oder aber auch wegen x264_encoder_encode failed oder dem anderen Fehler wegen dem Farbprofil wo man sich entscheiden kann, ob Megui das in YPB (oder wie das Ding auch immer heißt 4:2:0 )umändert.
      [IMG:https://www.file-upload.net/download-13368711/meguineu.JPG.html]
      (file-upload.net/download-13368711/meguineu.JPG.html)

      oder

      file-upload.net/download-13368732/Megui2.JPG.html


      Aktuell habe ich folgende Codecs installiert:
      -Lagarith Lossless Codec
      X264vfw
      Ut Video Codec Suite
      -Shark007 Advanced Codec
      -Haali Media Splitter

      und natürlich meine regulären Tools wie
      Lucky's AVS Script Generator und auch MKVToolNix.

      Langsam gehen mir die Ideen aus.

      Eingelesen werden fertige .avi Dateien von Magic Video Deluxe Plus.

      Selbst Fraps Aufnahmen funktionieren nicht mehr richtig.

      Evtl. kann mir einer von euch seine Konfig nennen bzw. mit nem Bild zeigen und dem installierten Codec und ich stelle das nochmals nach. Was mir auch wichtig wäre bei der Funktion Updates kann man ja diverse Dinge aktivieren bzw. deaktivieren (was muss ich aktivieren bzw. deaktivieren)

      Über Unterstützung würde ich mich sehr freuen :)

      Aktuell nutze ich nach wie vor den Developer-Server für die schnellsten Updates.

      Wie würdet ihr vorgehen, um das Programm wieder zum laufen zu bekommen?
      Signatur 4.0:

      folgt demnächst.

    • Gib uns ein paar zusätzliche Informationen
      • Den Log, incl. Versions und den fehlgeschlagenen Jobs. Dort befinden sich Informationen wie die exakte Fehlermeldung, die verwendete AVISynth-Version, den Command Line etc. Den Log müsstest du als Textdatei speichern können.
      • Das AVS-Skript.
      Ich tippe mal drauf, dass es ggf. mit der Installation von AVISynth MT behoben werden könnte, aber ohne die Informationen kann ich auch nur raten.

      Fragensteller12 schrieb:

      Eingelesen werden fertige .avi Dateien von Magic Video Deluxe Plus.
      Details?

      Fragensteller12 schrieb:

      Aktuell nutze ich nach wie vor den Developer-Server für die schnellsten Updates.
      Wenn du wieder eine stabile Version hast: Aktualisiere sie nicht mehr.
      Java is to JavaScript what Fun is to Funeral
    • Hey RealLiVe,

      sorry für die fehlenden Infos.
      Also ich produziere das Video in Magix in .avi mit dem Lagarith Looseless Codec
      Es handelt sich hierbei um 4K Material was ich zu Testzwecken auf 8K hochbringen will. Es hat mit Megui sogar schon 2-3 x geklappt aber jetzt wieder nicht mehr.

      Anschließend habe ich das fertige File und generiere das besagte Script.
      meguineuneuneu.JPG

      So sieht der Log bei MeGui aus
      meguineuneu.JPG

      Habe hierfür nochmals eine neue MeGui Version geladen in nem anderen Ordner damit diese unverändert ist.
      Stettings bleiben bei Audio FLAC - das funktioniert
      Video: MKV als Endergebnis, doch das will nicht.

      Scriptdatei für die Ausgabe:
      In 7680x4320p mit 30FPS. oder 29,97 FPS aber daran sollte es nicht liegen. Ging ja bisher auch mit meinen 30 FPS.

      Zu den Scripts:
      file-upload.net/download-13368…esAvisynthscript.264.html
      file-upload.net/download-13368…esAvisynthscript.avs.html

      Das eine ist mit Luckys Generator gemacht
      und das andere mit diesem AVS+

      Solltest du weitere Infos benötigen, stehe ich dir gerne zur Verfügung.

      PS: Dieser Malloc Fehler liegt an der Größe doch bisher ging es eigentlich auch und auch in der 64 Bit Variante spuckt er die Meldung aus :/

      PPS: Codecs habe ich mehrere in Magix zur Auswahl. Evtl. wähle ich auch den falschen aus und der Lagarith ist nicht der richtige?
      file-upload.net/download-13368869/1.JPG.html
      file-upload.net/download-13368867/2.JPG.html
      file-upload.net/download-13368868/3.JPG.html

      ---
      LOG:
      [Error] Log
      -[Information] Versions
      --[Information] MeGUI: 2888 x86
      --[Information] MeGUI Debug Data: available
      --[Information] Update Check: Disabled
      --[Information] System Information
      ---[Information] Operating System: Windows 10 Pro 1803 x64 (10.0.17134.285)
      ---[Information] .NET Framework: 4.0 (4.0.0.0)
      ---[Information] .NET Framework: 4.7 (4.7.03056)
      ---[Information] Redistributables
      ----[Information] Microsoft Visual C++ 2008 x64: 9.0.30729
      ----[Information] Microsoft Visual C++ 2008 x86: 9.0.30729
      ----[Information] Microsoft Visual C++ 2010 x64: 10.0.40219
      ----[Information] Microsoft Visual C++ 2010 x86: 10.0.40219
      ----[Information] Microsoft Visual C++ 2012 x64: 11.0.61030
      ----[Information] Microsoft Visual C++ 2012 x86: 11.0.61030
      ----[Information] Microsoft Visual C++ 2013 x64: 12.0.30501
      ----[Information] Microsoft Visual C++ 2013 x86: 12.0.30501
      ----[Information] Microsoft Visual C++ 2017 x64: 14.11.25325
      ----[Information] Microsoft Visual C++ 2017 x86: 14.11.25325
      ---[Information] DPI: 150% (144/144)
      ---[Information] Monitor 1
      ----[Information] Resolution: 3840x2160
      ----[Information] Primary Screen: True
      --[Information] Component Information
      ---[Information] Haali Media Splitter: 1.13.138.14 (15-04-2013)
      ---[Information] Haali DSS2: not installed
      ---[Information] ICSharpCode.SharpZipLib: 0.85.5.452 (07-08-2008)
      ---[Information] MediaInfo: 18.05.0.0 (08-05-2018)
      ---[Information] SevenZipSharp: 0.64.3890.29348 (02-01-2011)
      ---[Information] 7z: 9.20 (18-11-2010)
      --[Information] AviSynth Information
      ---[Information] AviSynth Wrapper
      ----[Information] Version: 1.0.2847.0
      ----[Information] Date: 06-05-2018
      ----[Information] Interface: 3
      ---[Information] AviSynth
      ----[Information] AviSynth Status: ignored as portable build is forced
      ---[Information] AviSynth portable
      ----[Information] File Version: 0.1
      ----[Information] File Date: 02-07-2018
      ----[Information] File Name: AviSynth+ 0.1 (r2728, MT, i386)
      ----[Information] File Path: c:\users\chris.chris-pc\desktop\megui\megui-2876-32\avisynth.dll
      ----[Information] AviSynth Version: AviSynth+ 0.1 (r2728, MT, i386)
      ----[Information] AviSynth+: true
      ----[Information] AviSynth MT: true
      ----[Information] AviSynth Status: active
      -[Information] Update detection
      --[Information] [29.10.2018 19:29:38] Automatic update is disabled
      --[Information] [29.10.2018 19:29:38] Using cached update config and server: megui.org/auto/
      --[Information] [29.10.2018 19:29:38] No package requires an update
      -[Error] Log for job7 (video, Mein erstes Avisynthscript.avs -> Mein erstes Avisynthscript.264)
      --[Information] [29.10.2018 19:29:51] Started handling job
      --[Information] [29.10.2018 19:29:51] Preprocessing
      --[Information] [29.10.2018 19:29:51] AviSynth input script
      ---[NoImage] Video = AVISource("E:\Youtube\Reviews & Unboxing\Hi-Shock VR Unboxing\Megui test\2018-10-29_neu.avi", audio=true).AssumeFPS(30).Lanczos4Resize(7680,4320)
      ---[NoImage] Video
      --[Information] [29.10.2018 19:29:52] resolution: 7680x4320
      --[Information] [29.10.2018 19:29:52] frame rate: 30/1
      --[Information] [29.10.2018 19:29:52] frames: 6091
      --[Information] [29.10.2018 19:29:52] length: 00:03:23.033
      --[Information] [29.10.2018 19:29:52] aspect ratio: 16:9 (1.778)
      --[Information] [29.10.2018 19:29:52] color space: YV24
      --[Information] [29.10.2018 19:29:53] Job command line: "cmd.exe" /c ""C:\Users\Chris.CHRIS-PC\Desktop\Megui\MeGUI-2876-32\tools\ffmpeg\ffmpeg.exe" -loglevel level+error -i "E:\Youtube\Reviews & Unboxing\Hi-Shock VR Unboxing\Megui test\Mein erstes Avisynthscript.avs" -strict -1 -f yuv4mpegpipe - | "C:\Users\Chris.CHRIS-PC\Desktop\Megui\MeGUI-2876-32\tools\x264\x264.exe" --keyint 300 --sar 1:1 --frames 6091 --output "E:\Youtube\Reviews & Unboxing\Hi-Shock VR Unboxing\Megui test\Mein erstes Avisynthscript.264" --stdin y4m -"
      --[Information] [29.10.2018 19:29:53] Process started
      --[Information] [29.10.2018 19:29:53] Standard output stream
      --[Error] [29.10.2018 19:29:53] Standard error stream
      ---[Information] [29.10.2018 19:30:14] y4m [info]: 7680x4320p 1:1 @ 30/1 fps (cfr)
      ---[Warning] [29.10.2018 19:30:14] resize [warning]: converting from yuv444p to yuv420p
      ---[Information] [29.10.2018 19:30:14] x264 [info]: using SAR=1/1
      ---[Information] [29.10.2018 19:30:14] x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
      ---[Information] [29.10.2018 19:30:14] x264 [info]: profile High, level 6.0, 4:2:0, 8-bit
      ---[Error] [29.10.2018 19:30:15] x264 [error]: malloc of size 171207872 failed
      ---[Error] [29.10.2018 19:30:15] x264 [error]: x264_encoder_encode failed
      ---[Information] [29.10.2018 19:30:17] x264 [info]: frame I:1 Avg QP:10.00 size: 6856
      ---[Information] [29.10.2018 19:30:17] x264 [info]: frame P:1 Avg QP:10.00 size: 914
      ---[Information] [29.10.2018 19:30:17] x264 [info]: mb I I16..4: 100.0% 0.0% 0.0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: mb P I16..4: 0.0% 0.0% 0.0% P16..4: 0.0% 0.0% 0.0% 0.0% 0.0% skip:100.0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: 8x8 transform intra:0.0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: coded y,uvDC,uvAC intra: 0.0% 0.0% 0.0% inter: 0.0% 0.0% 0.0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: i16 v,h,dc,p: 100% 0% 0% 0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: i8c dc,h,v,p: 100% 0% 0% 0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: Weighted P-Frames: Y:0.0% UV:0.0%
      ---[Information] [29.10.2018 19:30:17] x264 [info]: kb/s:932.40
      ---[Information] [29.10.2018 19:30:17] aborted at input frame 58, output frame 2
      ---[Information] [29.10.2018 19:30:17] encoded 2 frames, 0.09 fps, 1864.80 kb/s
      ---[Information] [29.10.2018 19:30:17] [error] av_interleaved_write_frame(): Broken pipe
      ---[Information] [29.10.2018 19:30:17] [error] Error writing trailer of pipe:: Broken pipe
      --[Error] [29.10.2018 19:30:17] Process exits with error: 0xFFFFFFFF (-1)
      --[Information] [29.10.2018 19:30:17] Job completed
      Signatur 4.0:

      folgt demnächst.

    • Du hast also eine 32 Bit Build von AVISynth+, eine 32 Bit Build von FFmpeg und eine 64 Bit Build von x264 und willst damit 8K verarbeiten, richtig? Ich tippe mal darauf, dass du die Probleme erst hast, seitdem du dich mit 8K spielst, oder?

      Ich hab das nie probiert und weiß nicht, wie viel das alles an Speicher vernichtet. Ich glaube nicht, dass AVISynth oder FFmpeg hier die Grenzen von 32 Bit sprengen und würde darauf tippen, dass der Encodingprozess mehr säuft als ich. Kannst du in MeGUI in den x264 - Einstellungen unter Rate Control die Nb of Frames for Lookahead testweise massiv runtersetzen, auf beispielsweise 5 oder 0? Die Einstellung dreht am rc-lookahead - Wert von x264.
      Java is to JavaScript what Fun is to Funeral
    • Also erstmal bitte für Auflösungsverdopplung einfach nearest neighbor nehmen und nicht 'nen Interpolierer.
      Das ist dann nicht nur lossless, sondern spart auch immens cpu ein.

      Fragensteller12 schrieb:

      ---[Warning] [29.10.2018 19:30:14] resize [warning]: converting from yuv444p to yuv420p
      Auch das zerrt an encodeleistung.
      wenn die Quelle in 444 vorliegen sollte, belasse sie in 444. Der saubere Chroma verbessert normalerweise die Komprimierbarkeit derart, das es mehr bringt als die Chromaauflösung zu reduzieren.

      Fragensteller12 schrieb:

      ----[Information] AviSynth MT: true
      Wenn das MT ist und falls Multithreading auch verwendet wird (ich kenne avisynth+ jetzt nicht, kenne nur das übliche), dann tut MT den RAM Verbrauch enorm in die Höhe treiben.
      Du darfst bei 32bit aber nicht mehr als 4 GB RAM verbrauchen.
      Das halt ich bei 8k selbst bei einem singlethreaded encode bereits aber absolut für realistisch das die 4GB überlaufen.





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • De-M-oN schrieb:

      Wenn das MT ist und falls Multithreading auch verwendet wird (ich kenne avisynth+ jetzt nicht, kenne nur das übliche), dann tut MT den RAM Verbrauch enorm in die Höhe treiben.
      Normalerweise muss man das auch bei AVISynth+ manuell einschalten. Sonst sollte es im ST laufen, wie bei SEt auch.

      De-M-oN schrieb:

      Du darfst bei 32bit aber nicht mehr als 4 GB RAM verbrauchen. Das halt ich bei 8k selbst bei einem singlethreaded encode bereits aber absolut für realistisch das die 4GB überlaufen.
      Hätte da ne Rückfrage: Das da läuft ja über AVISynth+ 32 Bit über eine FFmpeg-Pipe (32 Bit) zu x264 (x64). Braucht das, was AVISynth+ da macht, wirklich so viel RAM?
      Java is to JavaScript what Fun is to Funeral
    • RealLiVe schrieb:

      Hätte da ne Rückfrage: Das da läuft ja über AVISynth+ 32 Bit über eine FFmpeg-Pipe (32 Bit) zu x264 (x64). Braucht das, was AVISynth+ da macht, wirklich so viel RAM?
      Eigentlich wird das AVS Skript soviel ich aus der Log rauslesen kann über FFmpeg eingelesen und über die FFmpeg auch der Stream an x264 64Bit gepipet.

      Diese Pipe von FFmpeg funktioniert gegenüber der avs4x264 Pipe schon ganz anders was den Farbraum angeht. So wird z.B. die Pipe so wie sie jetzt in MeGUI genutzt wird alles in YV12 umwandeln. Weil das '-f yuv4mpegpipe' von FFmepg sorgt dafür das es in YV12 mit BT601 durchgeschleust wird. Vor allem da kein Pixel Format präzise angegeben wird für die Pipe.

      Also ist das AVISynth was verwendet wird total uninteressant, solange es von FFmpeg unterstützt wird und genommen wird.

      Der Kern des Problems hier liegt bei der Pipeline. Die zerschießt sich selbst bei der Größe der Frames. Das kann die Pipeline gar nicht anständig übertragen. Lösung wäre schon in AVISynth das Video in ein YV12 Farbraum zu konvertieren. Dann muss das nicht FFmpeg tun und die Pipeline wäre damit auch entlastet.


      Ich finde die neue Vorgehensweise bei MeGUI nicht mehr so gut mit ihren FFmpeg dazwischen für x264. Man hat so über die GUI selbst nicht mehr so viel Kontrolle über das was da abgeht. Ich hoffe die Entwickler machen was draus, wenn sie FFmpeg schon so behaart in den Vordergrund stellen. Weil momentan hat diese Vorgehensweise viele kleine Kinderkrankheiten. Kein Einfluss mehr darauf was FFmpeg an x264 einen Farbraum übergibt, geschweige welche Farbmatrix. Da wird zurzeit mehr konvertiert als alles andere. Und ob das Endergebnis stimmt, ist auch Fraglich.
    • hmm ist ja ziemlich ärgerlich dann :(





      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
    • Hallo zusammen,
      bitte entschuldigt die verspätete Antwort.

      RealLiVe: Ich habe beide Versionen, MeGui in 32 Bit und MeGui in 64 bit. Bei beiden gibt es in der Hinsicht Probleme. Die Plug-Ins haben natürlich auch verschiedene Modis bzw. installieren beides mit ggf. installiere ich 64 bit mit wenn es fehlt. Logisch, habe ja auch ein 64 Bit System.

      Bis vor einiger Zeit hat aber auch alles mit den normalen 32 Bit Komponenten funktioniert, weshalb ich mich nie um die 64 Bit Version gekümmert habe.
      Aber ich habe das Tool schon länger nicht mehr genutzt und mein erstes Video war ein 8K Versuch, aber auch die regulären Fraps Aufnahmen in einer geringeren Auflösungen spucken mir Fehler aus, Sprich hier ist ein Encodiervorgang ebenfalls nicht mehr erfolgreich.
      Zwecks der Einstellungen - das werde ich mal testen und Rückmeldung geben :)

      De_M-oN: nearest neighbor - was genau meinst du damit? Die nächst höhere Auflösung oder welche Einstellung muss ich da vornehmen? Bin etwas aus der Materie raus :(.

      Zwecks 444 - also einfach wenn MeGui die Meldung wieder ausspuckt um es zu verändern, nein klicken und meine Settings beibehalten, richtig?
      Aber früher ging es ja auch vor einiger Zeit wo ich noch nicht mal von AviSynth+ gehört habe. Demnach verwundert es mich. Kann natürlich auch sein, dass MeGui seither wieder viel geupdated hat und es nun nicht mehr klappt.

      Ggf habt ihr ja ein anderes Tool welches man für das 8K Projekt nutzen kann. Handbrake kann zwar die Auflösung verändern, aber aus einer 9GB Datei wird dann eine knapp 600MB Datei, selbst bei der Einstellung 0 für looseless, das ist eben auch nicht das wahre. Und FinalCutProX möchte ich jetzt nicht für nen Testdurchlauf kaufen bzw. nur 30 Tage testen.
      Signatur 4.0:

      folgt demnächst.