Aufnahme Stockt manchmal

Ich brauche deine Hilfe, um den Fortbestand des LetsPlayForums zu sichern: Mehr Informationen findest du hier!
  • Hallo zusammen,


    hier erst einmal meine PC Konfiguration:


    CPU: i7-9700k
    Grafik: RTX2070, 8GB
    RAM: 16GB
    HDD: 512GB SSD Samsung Pro


    Caputre Card: Elgato HD60S


    Mein Problem:
    Immer wieder kommt es mal vor, dass meine Aufnahmen für so 1-2 Sekunden stocken. Das Spiel läuft ganz normal, da habe ich keine Lags oder der gleichen. Ich merke das nur, wenn ich dann mal das Video ansehe. Es kommt eigentlich sehr regelmäßig vor. Man kann sagen, fast in jedem Video.


    Ich nehmen in [email protected] mit OBS auf (gleiche Probleme bei OBS Streamlabs).


    Die Capture Card ist an einer separaten PCx USB 3.0 Karte verbunden. Ansonsten hängen an der USB Karte keine Geräte mehr dran.


    Treiber sind alle aktuell - bin da was hilflos momentan

    :-)


    Vielleicht hat da ja jemand noch eine Idee oder eine Anregung, was ich noch probieren könnte.


    Beispiel: https://www.youtube.com/watch?v=BLs_a7b6C10 bei 3:33 Min.


    Das komische ist, ich hatte vor ca. einem Monat einen deutlich schlechteren PC mit den gleichen OBS Einstellungen und da hatte ich das Problem nicht - das macht mich dann noch stutziger.

    ?(
  • Es kommt bei allen Spielen vor. Das oben verlinkte Spiel ist von Steam - also PC. Aber auch wenn ich über die Konsole aufnehme, aktuell vorwiegend die Switch, habe ich das selbe Problem.


    /edit: So langsam werde ich das Gefühl nicht los, dass die Elgato einen Schlag weg hat.

  • Nimmst du auch mit der Elgato Steam-Games auf oder wie kommst du zu diesem Schluss? Eigentlich benötigst du ja für PC-Games keine Capture Card.

    Stimmt, da hast du absolut recht. Daran habe ich gestern Abend gar nicht gedacht.


    Hier mal ein OBS Log


    In Zeile 7 steht etwas von encoding lag. Ich gehe mal davon aus, dass das die Ruckler sind - oder?

  • Encoding Lag bedeutet, dass der PC beim Encodieren der Aufnahme nicht Schritt halten kann, folglich muss er Frames auslassen. Normalerweise ist dies auf langsame Hardware zurückzuführen, allerdings müsste es mit den genannten Specs reibungslos funktionieren. Daher hau ich mal meine Standardantwort raus: Wenn du Windows 10 benutzt, schau mal, ob der Spielemodus aktiviert ist. Falls ja, unbedingt ausmachen.
    Der Spielemodus sorgt dafür, dass Spielen genug Leistung zur Verfügung steht, limitiert dafür aber andere Prozesse (wie OBS).

  • @Rayxin


    Hier das Protokoll der letzten Aufnahme


    @BanzaiChuck


    Game Mode war auf On und ich habe es abgestellt - im Protokoll habe ich aber immer noch encoding lags stehen


  • So, ich habe scheinbar das Problem behoben. Mein Video Footage aus OBS habe ich immer auf meine 4TB SATA3 Platte geschrieben. Ich habe jetzt mal den Speicherort auf die SSD geändert und keine encoding Lags mehr - zu mindestens in der letzten Aufnahme jetzt nicht. Entweder hat die SATA-Platte einen hau, oder OBS wollte schneller schreiben als die Platte kann - werde die Platte mal testen.

  • 18:06:18.432: Game DVR: On

    Unbedingt ausmachen



    Warum nutzt du nur 480p und 30fps? Dafür brauchst du keine 930e. Das könnte eine 10€ Webcam vom Trödel. Stell um auf 720p/60





    Ganz falsche Settings
    Nimm die hier. Der CQP ist anpassbar. Höhere Zahl = Schlechteres Ergebnis. Niedrige Zahl = Bessere Quali. Zwischen 16 und 12 hat man die beste Option zwischen Quali und Speicherplatz verbrauch. AUdiospur nach deinen Bedürfnissen anpassen.
    P.s. nutz UNBEDINGT den Nvenc new da du eine RTX hast. Deine Grafikkarte wird es dir danken.
    https://s18.directupload.net/images/190717/yaegsley.png

  • Danke - Game DVR habe ich jetzt ausgeschaltet.


    Bei der Webcam hast du recht, da hatte ich den Gerätestandard eingestellt. Aber [email protected] geht das überhaupt? Die Cam hat ja nur 30fps.


    Ich hatte halt mit den Qualiätseinstellungen getestet. Ich hatte vorher immer CBR bei 30.000 und jetzt mal auf VBR umgestellt. Als Kodierer nutze ich den Nvenc new. Ich werde die Settings von dir mal probiere - vielen Dank!

  • Die Elgato USB Boxen haben doch alle keinen reinen Passthrough (nicht wie die Avermedias), soweit ich weiß wird das Signal On-the-Fly komprimiert und da wohl auch nur mit max. 40 Mbit?! Bei den Avermedias übernimmt die CPU die kompression.

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!