OBS-Aufnahme von Doom (2016) laggt, aber das Spiel nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS-Aufnahme von Doom (2016) laggt, aber das Spiel nicht

    Anzeige
    Moin zusammen,

    ich wollte gestern Doom (2016) aufnehmen und das erste Tutorial Level funktionierte auch einwandfrei, aber alles danach laggt wie die Hölle. Wobei es im Spiel selbst nicht laggt und durchgängig mit stabilen 60fps läuft. Ich habe auch nur bei Doom das Problem, alle anderen Games, die ich so aufnehme (Phoenix Point, Ni No Kuni 2, AC Origins) laufen einwandfrei und ruckeln nicht.

    An den Auslastungen von CPU/GPU kann es eigentlich nicht liegen, denn die liegen auch bei ordentlich Action nur bei 50-65% (CPU) und 45-60% (GPU). Trotzdem habe ich bei Doom-Aufnahmen ca. 30-60% lagged frames laut Log. An der Schreibgeschwindigkeit der Platte kann es auch nicht liegen, denn das Tutorial Level hat er ohne Ruckler und nur 0,1% lagged frames mit ca. 140MBit (CQ18) geschrieben. Die anderen Aufnahmen haben weniger, habe auch schon mit CQ 20 und 22 probiert, aber gleiches Ergebnis.

    Meine OBS-Settings sind:
    - NVENC h.264 (new)
    - mp4 mit 2 Tracks (Game Audio und Mic, wobei das zur Aufnahme nicht angeschlossen war)
    - CQP mit CQ18/20/22
    - Keyframe 0
    - Preset "Max Performance"
    - Profile "Main"
    - Max B-Frames 2
    -Psycho Visual Tuning an

    Wie gesagt: Bei allen anderen Games läuft das ohne Probleme - und aus welchen Gründen auch immer, beim Doom Tutorial Level. Google sagt mir, dass viele Leute mit Doom und OBS Probleme haben, aber die Lösungen haben bei mir nicht funktioniert (z.B. Windows Game Mode und Game DVR abschalten, was keinen Unterschied macht bei mir).

    Heute Abend kann ich noch einmal versuchen, ob es etwas bringt, die Priority von OBS zu erhöhen oder das Preset zu wechseln. Und ein Vorschlag aus dem Netz ist es, die Quelle bei OBS von Game Capture auf Display Capture umzustellen, aber das ist ja eigentlich nicht so sinnvoll, da OBS sich ja dann nicht direkt in den Game Prozess reinklinken kann. Probieren werde ich das heute Abend aber auch noch einmal. Wenn sonst noch wer Ideen dazu hat, bitte her damit :)
  • Game Mode und DVR macht keinen Unterschied, aber beides ist jetzt erstmal aus.

    Hardware:
    i5-4570 (4 Cores, 4 Threads @ 3,2GHz - nicht übertaktet, alles out of the box)
    GTX 1060 6GB
    8GB RAM (ist während der Aufnahme nur zu 70-80% voll)
    Win 10
    Aufnahme entweder auf eine 1TB 7200rpm SATA Platte oder eine 256GB SSD - macht ebenfalls keinen Unterschied.

    Die Recommended Specs von Doom packe ich damit also locker.
  • Game8 schrieb:

    Klar, aber wenn du nebenbei aufnimmst braucht das halt mehr Leistung.
    Ist mir bewusst, aber die Auslastungen von CPU und GPU haben ja noch Luft nach oben...

    Habe noch ein wenig mehr rumprobiert. Egal, was ich tue, es ändert sich nichts.
    NVENC h.264 alt oder new, OBS Priority habe ich auf auf above normal und high probiert, Profile auf high, Preset auf Performance und Max Quality, auch mal als mkv und nicht als mp4. Alles total egal.

    Ich habe auch mal alle Details in Doom selbst runtergestellt, aber das brachte auch nix. Ich bin gerade ein wenig am Ende mit meinem Latein.

    Edit: V-Sync on/off/adaptable bringt auch nichts. Borderless Window auch nicht.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von stbehre ()

  • Ich hatte das Problem auch (mit Kenshi), als ich zu OBS gewechselt bin und konnte durch ein bisschen rumschrauben an der Bitrate das Ruckeln eliminieren (Habe die Videos als mkv aufgenommen, 15000er bitrate, edit: mit CBR allerdings, vielleicht liegts ja auch daran) Mit 1080p das ist für mich persönlich z.B. ein guter Wert - hängt natürlich auch immer stark vom spiel ab, also einfach mal ausprobieren..)

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Jacki ()

  • Jacki schrieb:

    Wie hoch ist denn deine Bitrate eingestellt? (edit:auch wenn es vielleicht oben steht -- aber ich bin mit den Technikkürzeln nicht so gut) Ich hatte das Problem auch (mit Kenshi), als ich zu OBS gewechselt bin und konnte durch ein bisschen rumschrauben an dem Wert das Ruckeln eliminieren (Habe die Videos als mkv aufgenommen, 15000er bitrate (edit: mit CBR allerdings, vielleicht liegts ja auch daran) für 1080p ist für mich persönlich z.B. ein guter Wert - hängt natürlich auch immer stark vom spiel ab, also einfach mal ausprobieren..)
    Ich nehme mit CQP auf, d.h. die Bitrate wird je nach Komplexität des Materials über einen Quantisierungswert verteilt (bei mir testweise 18, 20 und 22). Ich habe spaßeshalber auch mal CBR von 4000 eingestellt. Sah absolut mies aus, lief aber auch nicht flüssig, aber besser als die mit CQP.

    Habe auch mal die Auflösung auf 720p reduziert und danach nur noch 20% skipped frames gehabt. Aber es kann ja irgendwie nicht angehen, dass Doom so rumzickt und AC Origins, welches ja ähnliche Anforderungen hat, läuft ohne Probleme und mit höheren Auslastungen von CPU/GPU ohne skipped frames.
  • Das Problem scheint sich erledigt zu haben. Nachdem ich so wirklich ALLES probiert habe und nichts funktioniert hat, habe ich noch mal auf meine SSD aufgenommen... und jetzt funktioniert es ohne Probleme. Das letzte Mal war das nicht der Fall. Vielleicht hat irgendwas die SSD-Leistung gedrosselt oder so. Jedenfalls läuft es jetzt endlich!