16 von 32 GB RAM verfügbar

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • 16 von 32 GB RAM verfügbar

    Anzeige
    Guten Tag,

    ich habe ein Problem mit meinem Mainboard und meinem RAM. Ich habe das 2x 16 GB Kit von Corsair Dominator mit 2400 mhz (DDR3).
    Wenn ich ins Bios gehe, werden mir aber nur 16 GB angezeigt und im Taskmanager steht, diese 16 GB takten auf 1600 mhz. Wenn ich einen Riegel rausnehme, werden nur noch 8 GB angezeigt, also jeder Riegel wird nur zur Hälfte benutzt.

    Wo liegt das Problem, dass mich nicht meine vollen 32 GB nutzen lässt? Es hat definitiv schon einmal funktioniert und beide Riegel sind okay.
    Natürlich habe ich die Riegel auch schon hin und her getauscht, keine Veränderung.

    RAM: Corsair Dominator 32 GB 2400 MHZ (2x 16GB)
    Mainboard: MSI Z97M Gaming 7 (Bios auf dem neusten Stand)
    CPU: i7 4770

    Danke im Voraus
    Liebe Grüße
  • Anzeige
    Was für ein OS nutzt du? 32GB gibts bei Windows 7 z.B. erst ab der Pro Version.
    Mein Kanal: youtube.com/user/HEEROCKSS

    User der Du bist auf meinem Channel.
    Dein Abo komme.
    Dein Like geschehe, wie auf Youtube, so auf Google+.
    Eure täglich`Klicks gebt mir Heute. Und vergebt mir meine Versprecher, wie auch ich vergebe Euren Dislike`s.
    Und Google, führe mich nicht in Versuchung, sondern erlöse mich von Copyrights.
    Denn Youtube ist das Reich und die Kraft der Uploadigkeit, in Ewigkeit.
    Let`s Play!
  • Game8 schrieb:

    Das wichtigste fehlt bislang: Ram in Slot 2 und 4? Mit XMP Profil im Bios mal versucht?
    Die Belegung macht aus ob man den RAM im Single oder Dual Channel mode betreibt. Wenn das OS es zulässt und der RAM nicht defekt ist macht die Belegung selber keinen Unterschied wie viel RAM addressierbar ist.

    Game8 schrieb:

    Dann würden aber nur 4 GB angezeigt werden ;)
    @Archimondro hat nicht gefragt ob eine 32bit Version vorliegt, sondern welche Version im allgemeinen. Das liegt daran das selbst die 64bit Version von Win7 Home Basic und Home Premium keine 32GB addressieren kann (künstlich von MS limitiert). Siehe hier

    @RaZiiandStuff
    Auf den Riegeln sollte eine Seriennummer sein (oft auf einem Sticker). Guck mal welche SN du hast und google welches kit du da hast. Hast du die von jmd. gebraucht gekauft oder bis du erstkäufer ? Die "(2x 16GB)" deuten halt eigentlich auf je einen 16er Stick, jedoch sind die Corsair Dominator halt häufig in 32er Kits aus 4x 8GB vertreten ....
  • MaxxPuzzles schrieb:

    Die Belegung macht aus ob man den RAM im Single oder Dual Channel mode betreibt.
    Und bei einigen Boards und Bios Versionen wie viel angezeigt wird. Glaubs mir, ich mache das täglich.


    MaxxPuzzles schrieb:

    @Archimondro hat nicht gefragt ob eine 32bit Version vorliegt, sondern welche Version im allgemeinen. Das liegt daran das selbst die 64bit Version von Win7 Home Basic und Home Premium keine 32GB addressieren kann (künstlich von MS limitiert). Siehe hier
    Trifft aber alles nicht zu, da 8 GB angezeigt werden wenn ich das jetzt richtig verstehe ;)

    EDIT:
    Nochmal kurz Google bemüht. Das Problem gibt es mit dem Board öfter, stutzig macht folgender Satz:

    Due to chipset resource usage, the system will only detect up to 31+ GB of memory (not full 32 GB) when all DIMM slots have 8GB memory modules installed.
    Lässt Interpretationsspielraum...entweder 32 GB gehen nur dann richtig (und werden als max. 31 GB erkannt), wenn alle Slots mit 8er Modulen bestückt sind, oder der Hinweis ist als allgemeiner Hinweis zu verstehen das bei Verwendung von vier 8er Modulen nur 31 GB erkannt werden und das mehr oder weniger normal sei. Eine Lösung konnte ich für das Problem nicht finden, wohl aber Leute bei denen es erst auch einwandfrei lief und sich dann exakt wie bei dir verhielt, Beispiel:
    hackintosh-forum.de/forum/thre…-von-32-gb-ram-verfügbar/
    (Da steht der Satz von MSI sogar mit drin)

    Sofern machbar würde ich vielleicht mal eine BIOS-Version zurückspringen und schauen wie es sich verhält. Dadurch das es Plattformübergreifend ist, wie man anhand des Beispiels sieht, würde ich das OS schon fast als Fehlerquelle ausschließen wollen.

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Game8 ()

  • Game8 schrieb:

    Und bei einigen Boards und Bios Versionen wie viel angezeigt wird. Glaubs mir, ich mache das täglich
    Welche Platform soll das denn dann sein ? Das würde bedeuten das ein board unterschiedlich große Memory Channel Bus hat, oder einen geteilten Channel Bus ? Das sollte dann bei Intel keiner Spezifikation mehr entsprechen wo der IMC mit je einem vollen Channel pro DIMM angesprochen wird und einem einzigen Memorzý Adress Bus der über alle DIMMS geht, letzter ist dafür da um eben den physikalischen Speicher zu identifizieren und zu belegen (also die Kapazität) wo dann pro DIMM der Channel Bus für die Bandbreite sorgt.

    Wie gesagt, bei der Bandbreite ist mir klar das es Unterschiede pro Belegung gibt - Unterschiedliche Addressierung der Kapazität pro DIMM musst du mir aber erstmal erklären bei welchen Boards das vorkommt.

    Game8 schrieb:

    Lässt Interpretationsspielraum
    Eher weniger, es kommt nur dann vor wenn alle DIMMS mit 8GB Modulen belegt sind: "...when all DIMM slots have 8GB memory modules installed".


    @RaZiiandStuff
    Zurück zum Thema: Habe gerade nochmal nach geguckt und es ist einfach eine Beschränkung seitens der Haswell Platform (lel - schon etwas her das ich die laufen hatte). Bei Haswell (also deinem Z97er Board) scheint es nicht möglich zu sein mehr als 8GB pro DIMM anzusprechen - also, eine Limitierung seitens der CPU/MB Architektur. Das erklärt auch warum nur 8GB pro Riegel bei dir benutzt werden, die DIMMS können nicht mehr ;(

    Siehe Spezifikation unten von Intel und Max. DIMM Capacity. Gleiches sieht man übrigends auch wenn man bei MSI für die kompatiblen RAM Riegel für dein Board sucht - Hier. Auf compatbility und dann memory gehen.

    [Blockierte Grafik: http://abload.de/image.php?img=haswellmemoryspecs5ejpy.png]
  • Erklären muss ich nichts, ich mache den Kram seit bald 20 Jahren, davon nun schon viele mit eigener Firma, wir hatten schon Boards die z. B. mit der ersten Generation der Ryzen Prozessoren Probleme hatten alles an RAM zu erkennen wenn diese nicht nach Vorgabe gesteckt wurden. Von Servern fange ich jetzt mal nicht an, die sind da noch empfindlicher. Daher immer nach Anleitung vorgehen und die RAMs richtig stecken, nicht nur der Performance wegen. Das zu kontrollieren dauert ne Minute und sollte jetzt hier auch keine Diskussion auslösen bei der ich mich rechtfertigen muss.

    Nur verwunderlich bleibt das es ja wohl hier mal lief (vermutlich jedenfalls) und in anderen Beispielen die ich gefunden habe auch. Entweder gucken alle falsch oder irgendwas anderes passt nicht.
  • Game8 schrieb:

    Das zu kontrollieren dauert ne Minute und sollte jetzt hier auch keine Diskussion auslösen bei der ich mich rechtfertigen muss.
    Wenn du die Behauptung aufstellst das die RAM Kapazität Addresierung vom DIMM abhängig sein kann (Sprich, ein kit in DIMM A2 +B2 ließt die vollen 16GB, während DIMM A1+A2 nur 8GB der Kapazität lesen würde) dann ist das etwas was meiner Erfahrung widerspricht und viel wichtiger, der Trennung vom Memory Adress Bus und dem Memory (Data) Bus welches eben Kapazität addressierung und Bandbreite trennt.

    Ich rufe dich dazu auf das zu erklären / zu belegen das dies auf modernen consumer Platformen möglich ist weil es in einem Forum darum geht Wissen auszutauschen - bisher bleibt es bei einer Legende da du nicht erklärst wie dieses von dir beobachtete Verhalten mit dem Aufbau vom System Bus vereinbar ist oder da du nicht auf andere Erfahrungsberichte dieses Verhaltens zeigst (/zeigen kannst?).



    Geht es hierbei um einen Defekt der Riegel / CPU / MB ? Handelt es sich um was anderes als DDR 3 oder DDR 4 ? Sind das MBs außerhalb der spezifikation ?


    Alles was du bisher gemacht hast ist zu sagen: 'Ich habe die Erharung, vertrau mir, mehr brauchst du nicht um es als Tatsache zu akzeptieren' - Sowas ist kein Wissensaustausch und auch keine Diskussionsführung sondern ein klassisches "Ich sage das" (Adenauer 1962) - daher mein Misstraue, welches ich gerne anhand von belastbaren Bereichten verlieren würde.


    Game8 schrieb:

    Entweder gucken alle falsch
    Würde ich anhand der Haswell Limitierung mal schätzen - ansonsten hätte hätte die X99 Platform noch einen weiteren Vorzug verloren ;)
  • Habe dir doch ein Beispiel gegeben, glaubst du ich führe Buch darüber bei welcher Board/CPU/RAM Konfig das Problem bislang aufgetaucht ist? Ich habe mehrere hundert Systeme gebaut, da habe ich andere Sorgen als mir sowas ins Detail zu merken. Du musst mir das nicht glauben, es war aber so - und ich glaube auch das es wieder vorkommen könnte. Rufe auf zu was du magst, ich bin weiterhin keine Rechenschaft schuldig. Wie gesagt, man hat das innerhalb von einer Minute kontrolliert und kann sicher gehen diese Ursache auszuschließen. No big deal.

    EDIT:
    Hast sogar Glück, der Kollege der für mich teils die Server aufbaut wusste sofort bei welchem Chipsatz das z. B. so war als ich ihn gefragt habe: C236 in Verbindung mit einem Xeon 1230 V6 und 32GB RAM von Samsung. Weil der 24 Pin Anschluss da so Kacke sitzt hatte er den RAM in die weiter weg liegenden schwarzen Slots gesteckt. Das führte dazu das der RAM gar nicht erkannt wurde. Dann hat er einen Riegel in den ersten blauen Slot neben der CPU gepackt und hatte 16GB RAM trotz 32GB gestecktem RAM (abgesehen davon das es performancetechnisch Mist war). Erst als er den anderen Riegel in den vorgeschriebenen Slot quetschte hatten wir 32GB RAM wie es sein sollte. Überzeugt dich vermutlich ohnehin nicht. Und wie gesagt, ich selber hatte es bei der ersten Generation der neuen Ryzen Prozessoren. Die waren ohnehin extrem anfällig was RAM betrifft, sind sie ja zum Teil heute noch.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Game8 ()

  • Game8 schrieb:

    C236 in Verbindung mit einem Xeon 1230 V6
    ECC RAM ?

    Game8 schrieb:

    Überzeugt dich vermutlich ohnehin nicht
    Doch - viel besser! Jetzt sind wir wenigstens bei einem spezifischen Beispiel und es scheint eher in Richtung Workstation/Server Platformen zu gehen (im Gegensatz zu einer Consumer/Gaming Platform wie dem Z97...). Vlt. verstehst du dann auch langsam das es mir eben genau darum geht: Belastbare Beispiele anstatt ein simples "Ich sage das" welches einem keine Möglichkeit bietet sich kritisch mit etwas auseinandersetzen. Du bist sicher auch für kritisches Denken ?
  • MaxxPuzzles schrieb:

    und es scheint eher in Richtung Workstation/Server Platformen zu gehen
    Weshalb ich jetzt jedes Mal die erste Ryzen-Generation betont habe als Beispiel? Du wolltest ein konkretes, und der Kollege wusste noch direkt bei welchem Kunden wir das Problem hatten, da war es nun mal ein Server. Ich sage das auch weiterhin, es muss dir nicht gefallen oder passen, aber in dem Kontext hier tut diese Diskussion einfach nichts zur Sache. Ich wollte damit lediglich eine potentielle Fehlerquelle ausschließen und keine Grundsatzdiskussion darüber starten, wer schon was erlebt hat. Deshalb sollten wir das an dieser Stelle auch nicht weiter fortführen sondern mal abwarten, was uns @RaZiiandStuff nun erzählen wird.
  • @Game8 Bei mir verstaubt seit 7 Jahren ein RAM Riegel, weil wenn ich alle 4 Bänke aktiviert habe, spinnt das Board rum - Grafikkarte in Gerätemanager = Gelbes Ausrufezeichen :(
    Das Board mag anscheinend mein RAM nicht o.o
    Die RAMs funktionieren alle. Ich kann lediglich nicht alle Bänke aktivieren. Nur 3 und hab damit nur 12 GB statt 16 GB und dadurch erlaubt mir Quake Champions sogar nur medium texturen :(

    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7