OBS Studio speichert beschädigte Dateien

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS Studio speichert beschädigte Dateien

    Anzeige
    Hey

    ich hab vollgendes Problem. Wenn ich eine Aufnahme mit OBS Studio starte ist alles in Ordnung. Ich spiele mein Game und produzier meiner Meinung nach gute Vids.
    Aber ab und zu kommt es vor das OBS die Datei einfach beschädigt speichert. Ich hab 30 Minuten Aufnahmen bei denen geht alles usw. Aber jetzt hab ich vorhin eine ca. 45 Minuten lange Aufnahme gemacht und wollte mir das entstandene Video anschauen aber die Datei ist "beschädigt". Ich frage mich nur warum ist das so. Anfangs hatte ich das Problem auch aber das ließ sich beheben indem ich die Bitrate auf 15000 minimiert habe. Seitdem hab ich 3 Aufnahmen gemacht die alle nicht so gut waren also von meinen Kommentaren her. Jetzt beim 4ten Versuch ist es PERFEKT gewesen aber OBS speichert die Datei fehlerhaft ab. ich würde mich sehr über Hilfe freuen, da ich einen neuen Kanal hab und das mein erstes Video werden sollte...
    Danke schomal

    (Video Format ist MP4 da mein Schnittprogram nur MP4 bearbeiten kann)
  • Das sollte der LOG des beschädigten Videos sein

    14:15:24.243: CPU Name: AMD Ryzen 5 1600X Six-Core Processor
    14:15:24.243: CPU Speed: 3893MHz
    14:15:24.243: Physical Cores: 6, Logical Cores: 12
    14:15:24.243: Physical Memory: 16319MB Total, 9350MB Free
    14:15:24.243: Windows Version: 10.0 Build 17134 (revision: 523; 64-bit)
    14:15:24.243: Running as administrator: false
    14:15:24.243: Aero is Enabled (Aero is always on for windows 8 and above)
    14:15:24.243: Windows 10 Gaming Features:
    14:15:24.243: Game DVR: On
    14:15:24.245: Sec. Software Status:
    14:15:24.246: Windows Defender Antivirus: disabled (AV)
    14:15:24.246: AVG Antivirus: enabled (AV)
    14:15:24.247: Windows-Firewall: enabled (FW)
    14:15:24.247: Windows Defender Antivirus: disabled (ASW)
    14:15:24.247: AVG Antivirus: enabled (ASW)
    14:15:24.247: Browser Hardware Acceleration: true
    14:15:24.247: Portable mode: false
    14:15:24.357: OBS 22.0.2 (64-bit, windows)
    14:15:24.357: ---------------------------------
    14:15:24.357: ---------------------------------
    14:15:24.357: audio settings reset:
    14:15:24.357: samples per sec: 44100
    14:15:24.357: speakers: 2
    14:15:24.359: ---------------------------------
    14:15:24.359: Initializing D3D11...
    14:15:24.359: Available Video Adapters:
    14:15:24.361: Adapter 1: NVIDIA GeForce GTX 1050 Ti
    14:15:24.361: Dedicated VRAM: 4224712704
    14:15:24.361: Shared VRAM: 4261019648
    14:15:24.361: output 1: pos={0, 0}, size={1920, 1080}, attached=true
    14:15:24.361: output 2: pos={1920, 0}, size={1680, 1050}, attached=true
    14:15:24.363: Loading up D3D11 on adapter NVIDIA GeForce GTX 1050 Ti (0)
    14:15:24.425: D3D11 loaded successfully, feature level used: 45056
    14:15:25.139: ---------------------------------
    14:15:25.139: video settings reset:
    14:15:25.139: base resolution: 1920x1080
    14:15:25.139: output resolution: 1920x1080
    14:15:25.139: downscale filter: Lanczos
    14:15:25.139: fps: 60/1
    14:15:25.139: format: NV12
    14:15:25.139: YUV mode: 601/Partial
    14:15:25.141: Audio monitoring device:
    14:15:25.141: name: Standard
    14:15:25.141: id: default
    14:15:25.141: ---------------------------------
    14:15:25.143: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
    14:15:25.152: [CoreAudio encoder]: Adding CoreAudio AAC encoder
    14:15:25.202: [AMF] AMF Test failed due to one or more errors.
    14:15:25.202: Failed to initialize module 'enc-amf.dll'
    14:15:25.218: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
    14:15:25.219: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': (null) (127)
    14:15:25.219: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
    14:15:25.220: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
    14:15:25.221: [obs-browser]: Version 2.1.5
    14:15:25.224: NVENC supported
    14:15:25.357: Couldn't find VLC installation, VLC video source disabled
    14:15:25.364: No blackmagic support
    14:15:25.371: ---------------------------------
    14:15:25.371: Loaded Modules:
    14:15:25.371: win-wasapi.dll
    14:15:25.371: win-mf.dll
    14:15:25.371: win-dshow.dll
    14:15:25.371: win-decklink.dll
    14:15:25.371: win-capture.dll
    14:15:25.371: vlc-video.dll
    14:15:25.371: text-freetype2.dll
    14:15:25.371: rtmp-services.dll
    14:15:25.371: obs-x264.dll
    14:15:25.371: obs-vst.dll
    14:15:25.371: obs-transitions.dll
    14:15:25.371: obs-text.dll
    14:15:25.371: obs-qsv11.dll
    14:15:25.371: obs-outputs.dll
    14:15:25.371: obs-filters.dll
    14:15:25.371: obs-ffmpeg.dll
    14:15:25.371: obs-browser.dll
    14:15:25.371: image-source.dll
    14:15:25.371: frontend-tools.dll
    14:15:25.371: enc-amf.dll
    14:15:25.371: coreaudio-encoder.dll
    14:15:25.371: ---------------------------------
    14:15:25.371: ==== Startup complete ===============================================
    14:15:25.379: Service '' not found
    14:15:25.381: All scene data cleared
    14:15:25.381: ------------------------------------------------
    14:15:25.413: WASAPI: Device 'Lautsprecher (Turtle Beach PLa Headset)' initialized
    14:15:25.431: WASAPI: Device 'Lautsprecher (Turtle Beach PLa Headset)' initialized
    14:15:25.434: Switched to scene 'Rainbow Six Siege'
    14:15:25.434: ------------------------------------------------
    14:15:25.434: Loaded scenes:
    14:15:25.434: - scene 'Rainbow Six Siege':
    14:15:25.434: - source: 'Bildschirmaufnahme' (monitor_capture)
    14:15:25.434: ------------------------------------------------
    14:15:25.484: adding 23 milliseconds of audio buffering, total audio buffering is now 23 milliseconds
    14:15:25.500: CalculateFileHash: Failed to open file 'C:\Users\Daniel der Boss\AppData\Roaming\obs-studio\updates\whatsnew.json':
    14:17:03.577: adding 23 milliseconds of audio buffering, total audio buffering is now 46 milliseconds
    14:20:05.342: adding 23 milliseconds of audio buffering, total audio buffering is now 69 milliseconds
    14:23:08.385: adding 23 milliseconds of audio buffering, total audio buffering is now 92 milliseconds
    14:33:35.546: ==== Shutting down ==================================================
    14:33:35.551: Switched to scene '(null)'
    14:33:35.552: WASAPI: Device 'Lautsprecher (Turtle Beach PLa Headset)' Terminated
    14:33:35.556: WASAPI: Device 'Lautsprecher (Turtle Beach PLa Headset)' Terminated
    14:33:35.559: All scene data cleared
    14:33:35.559: ------------------------------------------------
    14:33:35.637: Freeing OBS context data
    14:33:35.658: [Scripting] Total detached callbacks: 0
    14:33:35.682: == Profiler Results =============================
    14:33:35.683: run_program_init: 1747.86 ms
    14:33:35.683: ┣OBSApp::AppInit: 21.074 ms
    14:33:35.683: ┃ ┗OBSApp::InitLocale: 3.585 ms
    14:33:35.683: ┗OBSApp::OBSInit: 1651.76 ms
    14:33:35.683: ┣obs_startup: 4.176 ms
    14:33:35.683: ┗OBSBasic::OBSInit: 1142.34 ms
    14:33:35.683: ┣OBSBasic::InitBasicConfig: 0.513 ms
    14:33:35.683: ┣OBSBasic::ResetAudio: 0.149 ms
    14:33:35.683: ┣OBSBasic::ResetVideo: 783.605 ms
    14:33:35.683: ┣OBSBasic::InitOBSCallbacks: 0.006 ms
    14:33:35.683: ┣OBSBasic::InitHotkeys: 0.049 ms
    14:33:35.683: ┣obs_load_all_modules: 229.659 ms
    14:33:35.683: ┃ ┣obs_init_module(coreaudio-encoder.dll): 8.593 ms
    14:33:35.683: ┃ ┣obs_init_module(enc-amf.dll): 47.716 ms
    14:33:35.683: ┃ ┣obs_init_module(frontend-tools.dll): 4.486 ms
    14:33:35.683: ┃ ┣obs_init_module(image-source.dll): 0.004 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-browser.dll): 0.182 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-ffmpeg.dll): 0.631 ms
    14:33:35.683: ┃ ┃ ┗nvenc_check: 0.596 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-filters.dll): 0.027 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-outputs.dll): 0.007 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-qsv11.dll): 117.28 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-text.dll): 0.194 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-transitions.dll): 0.005 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-vst.dll): 0.002 ms
    14:33:35.683: ┃ ┣obs_init_module(obs-x264.dll): 0.002 ms
    14:33:35.683: ┃ ┣obs_init_module(rtmp-services.dll): 0.604 ms
    14:33:35.683: ┃ ┣obs_init_module(text-freetype2.dll): 0.093 ms
    14:33:35.683: ┃ ┣obs_init_module(vlc-video.dll): 0.046 ms
    14:33:35.683: ┃ ┣obs_init_module(win-capture.dll): 0.142 ms
    14:33:35.683: ┃ ┣obs_init_module(win-decklink.dll): 4.116 ms
    14:33:35.683: ┃ ┣obs_init_module(win-dshow.dll): 1.534 ms
    14:33:35.683: ┃ ┣obs_init_module(win-mf.dll): 0 ms
    14:33:35.683: ┃ ┣obs_init_module(win-wasapi.dll): 0.006 ms
    14:33:35.683: ┃ ┗reset_win32_symbol_paths: 0.069 ms
    14:33:35.683: ┣OBSBasic::ResetOutputs: 7.75 ms
    14:33:35.683: ┣OBSBasic::CreateHotkeys: 0.224 ms
    14:33:35.683: ┣OBSBasic::InitService: 1.432 ms
    14:33:35.683: ┣OBSBasic::InitPrimitives: 0.248 ms
    14:33:35.683: ┗OBSBasic::Load: 55.25 ms
    14:33:35.683: obs_hotkey_thread(25 ms): min=0.002 ms, median=0.006 ms, max=2.908 ms, 99th percentile=1.051 ms, 100% below 25 ms
    14:33:35.683: audio_thread(Audio): min=0 ms, median=0.04 ms, max=2.2 ms, 99th percentile=0.096 ms
    14:33:35.683: obs_graphics_thread(16.6667 ms): min=0.081 ms, median=0.343 ms, max=54.963 ms, 99th percentile=1.67 ms, 99.9985% below 16.667 ms
    14:33:35.683: ┣tick_sources: min=0.001 ms, median=0.12 ms, max=5.741 ms, 99th percentile=1.236 ms
    14:33:35.683: ┣output_frame: min=0.055 ms, median=0.107 ms, max=54.954 ms, 99th percentile=0.234 ms
    14:33:35.683: ┃ ┗gs_context(video->graphics): min=0.055 ms, median=0.106 ms, max=54.954 ms, 99th percentile=0.234 ms
    14:33:35.683: ┃ ┣render_video: min=0.008 ms, median=0.036 ms, max=4.002 ms, 99th percentile=0.081 ms
    14:33:35.683: ┃ ┃ ┗render_main_texture: min=0.005 ms, median=0.033 ms, max=3.997 ms, 99th percentile=0.075 ms
    14:33:35.683: ┃ ┗gs_flush: min=0.025 ms, median=0.068 ms, max=54.942 ms, 99th percentile=0.175 ms
    14:33:35.683: ┗render_displays: min=0 ms, median=0.097 ms, max=9.056 ms, 99th percentile=1.209 ms
    14:33:35.683: =================================================
    14:33:35.683: == Profiler Time Between Calls ==================
    14:33:35.683: obs_hotkey_thread(25 ms): min=24.02 ms, median=25.01 ms, max=32.91 ms, 79.8407% within ±2% of 25 ms (0.413299% lower, 19.746% higher)
    14:33:35.683: obs_graphics_thread(16.6667 ms): min=9.662 ms, median=16.667 ms, max=54.969 ms, 98.363% within ±2% of 16.667 ms (0.817718% lower, 0.819246% higher)
    14:33:35.683: =================================================
    14:33:35.729: Number of memory leaks: 0
  • Es liegt daran, dass du MP4 benutzt. Dieses Containerformat ist sehr anfällig und der kleinste Schluckauf macht die Aufnahme unbrauchbar. Ich würde dir raten, in einem weniger anfälligen Format aufzunehmen (z.B. .flv oder .mkv) und die Datei anschließend zu remuxen. Dazu gehst du nach der Aufnahme in OBS auf Datei > Remuxe Aufnahme, wählst die entsprechende Datei aus und speicherst sie als .mp4 ab. Das ist auch völlig verlustfrei und hat keine Konsequenzen.
  • Nochmal ein paar zusätzliche Beobachtungen:

    pd.Codein schrieb:

    Bitrate auf 15000 minimiert habe
    Für den Fall das deine Platte den Platz hat - und ebenfalls das die 1050 TI die Kraft hat, wäre evtl. das Aufnehmen mit NVENC un CQP interressant. Siehe mehr hier - dabei geht darum die Qualität vom quellmaterial schon so hoch wie nur möglich zu halten. Ansonsten ist es absehbar das hier bald noch ein neues "Video sieht auf Youtube verpixelt aus" Thema aufgeht :D 8o :rolleyes:

    pd.Codein schrieb:

    14:15:25.139: YUV mode: 601/Partial
    Bin nicht mehr 100% Sicher ob das bei OBS Aufnahmen am Ende auch in die Aufnahme rein geht, aber mach die YUV-Farbmatrix mal auf 709.

    pd.Codein schrieb:

    14:15:25.434: Loaded scenes:
    14:15:25.434: - scene 'Rainbow Six Siege':
    14:15:25.434: - source: 'Bildschirmaufnahme' (monitor_capture)
    Funktioniert gamecapture für die Scene bei dir nicht ? Bei mir ist das kein Problem bei RSS. GameCapture ist im normal Fall performanter als eine Bildschirmaufnahme.