OBS-Aufnahme nach Import asynchron

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Anzeige

    Game8 schrieb:

    In der Testversion von Vegas 16 mit, soweit unterstützt, gleichen Einstellungen wie bei TMPGEnc
    Nuff said. Du kannst jetzt rumzetern so lang du möchtest, diese ganzen wahnsinnigen Vorteile die ich angeblich mit TMPGEnc hätte, waren in der Form nie da. Gleichzeitig war Vegas nie so scheiße wie du es ständig machst. Aber die Diskussion mit dir ist diese Punkte betreffend ohnehin sinnlos. Deshalb hast du einfach Recht, und ich bleibe glücklich mit Vegas.

    @Heisenberch zockt!
    Du siehst worauf es hinausläuft: Kauf dir TMPEGnc, danach ist alles perfekt - automatisch.
  • @Game8 Jetzt sag ich auch mal was dazu, und ich finde das selbe. Vegas kann es nicht gut und man sieht es an deinem Video. Schwarz und Grau mit riesen Pixeln und Haare total unscharf, das passiert mit TMPEGnc nicht, mit den richtigen Einstellungen. Da Vegas noch schlechter einzustellen ist als Magix Video und die Encoder die selben sind wie bei Magix, sind deine Argumente absolut falsch. Aber das liegt bei dir warscheinlich an, Never change a running System. Und ach ja, 10GB hochladen ist mir ja zu viel. Meine Folgen haben Teilweise 15-20 GB jeh nach länge. Ich lade die nachts hoch wenn ich penne, mir ist das so egal wie groß die sind. Hauptsache die Quallität stimmt und das tut sie bei dir nicht, dank Vegas. Du kannst mich eh nicht leiden also rede ich jetzt auch mal gegen dich.

    Szene 1: Pixel über Pixel und unscharfe Haare
    [Blockierte Grafik: https://ibb.co/5TbWGmY]

    Pixel über Pixel:
    [Blockierte Grafik: https://ibb.co/JqZyJnt]


    Aber wie du sagtest bleib bei Vegas und werde damit glücklich.

    <3 Mein Kanal KLICK ich freu mich auf dich :) <3
  • AdvocatusDei schrieb:

    @Game8 Jetzt sag ich auch mal was dazu, und ich finde das selbe. Vegas kann es nicht gut und man sieht es an deinem Video. Schwarz und Grau mit riesen Pixeln und Haare total unscharf, das passiert mit TMPEGnc nicht, mit den richtigen Einstellungen.
    Doch, es sah da auch so aus. Ich habe mir doch die Mühe gemacht und es extra verglichen. Wieso kommst du jetzt daher, und behauptest hier einfach irgendwas blaues in den Wald rein?
    Der Rest ist einfach blabla, tut mir leid. Für mich stimmt die Qualität die ich mit meinen Settings von Vegas erhalte. Die sind für mich ein guter Kompromiss zwischen Dateigröße, Ton und Bild. Was genau an den beiden Screenshots nun großartig falsch sein soll, bleibt mir ein Rätsel.


    AdvocatusDei schrieb:

    Du kannst mich eh nicht leiden also rede ich jetzt auch mal gegen dich.
    ?( "Ich glaube, du findest mich doof, also sag ich jetzt mal was gegen dich einfach nur deshalb!"
    Auf was für einem Niveau sind wir hier eigentlich mittlerweile? Kindergarten, oder schon Titanic?
  • Ist ja auch egal, wir wollen dem Jung doch helfen das alles wieder Synchron wird und uns nicht um Programme streiten. Eins bleibt jedoch. Der fehler liegt an Magix.

    Gibts den von Vegas ne 30Tage test Version, dann kann er für sich aus den zwei besten Proggis auswählen. den von TMPEGnc gibt es ja ne 30 Tage Version.

    Du hast immer schon so scharf auf mich ragiert drum habe ich das angesprochen. Also ich befinde mich zur Zeit auf der Titanic.

    Aber wie dem auch sei, vll ist dein Bildschirm anders eingestellt als meiner. Ich seh da Quallitätsverlust auf beiden Bildern. Aber du bist damit zu frieden dann solls auch so sein. Ich schaue für meinen Teil auch deine Videos wie immer weiter. Denn es macht Spaß sie zu schaun, mit oder ohne Pixel und unschärfen!

    <3 Mein Kanal KLICK ich freu mich auf dich :) <3
  • Anzeige

    AdvocatusDei schrieb:

    Du hast immer schon so scharf auf mich ragiert
    Ja, weil du in deinem Thema wo es um deine Videos ging nie auf Fragen eingegangen bist. Da mussten dich erst zig Leute dazu überreden, endlich mal mit Infos usw. rauszurücken ehe du dir helfen lassen wolltest. Und es war bei dir auch nicht einfach nur Vegas, sondern deine Fehlerkette fing schon bei der Aufnahme an.


    AdvocatusDei schrieb:

    Aber wie dem auch sei, vll ist dein Bildschirm anders eingestellt als meiner. Ich seh da Quallitätsverlust auf beiden Bildern.
    Ich sehe da nichts, habe auch die wenigsten Spiele auf höchsten Einstellungen, und wenn man all diese Umstände nimmt, ist das was rauskommt absolut in Ordnung. Um das zu prüfen habe ich mir von Daemon ja extra die Settings für Vegas mal geben lassen, ist ja nicht so als wäre ich breatungsresistent und würde nicht Sachen ausprobieren wollen. Das ist ein reiner Hobbykanal, ich habe null Anspruch dort perfektes Bildmaterial abzuliefern, ist mit meiner Hardware ohnehin ein Ding der Unmöglichkeit.

    AdvocatusDei schrieb:

    Gibts den von Vegas ne 30Tage test Version
    Ja, direkt auf der Homepage kann man das 16ner testen.


    AdvocatusDei schrieb:

    wir wollen dem Jung doch helfen das alles wieder Synchron wird
    Eure Lösung zusammengefasst: TMPGEnc :)
  • Game8 schrieb:

    Nuff said
    Eben nicht. Denn der Knackpunkt ist "Soweit unterstützt". Und da Vegas eben nichts unterstützt, öhm ja ^^ sind die Einstellungen eben sehr deutlich abweichend^^

    Und das die Encoder und Decoder erheblich besser sind bei TMPGEnc, MeGUI als auch ffmpeg, als Magix/vegas, dadrüber braucht man jetzt nich zu diskutieren eigentlich. Das ist eig. fakt ^^

    So und wenn sein Video im Videoplayer synchron ist und erst in Magix nicht mehr, liegt auch das an Magix. Ist doch offensichtlich. Genauso offensichtlich das TMPGEnc wenn du es in so schwachen Settings wie bei Vegas möglich codiert hättest, TMPGEnc nochmal deutlich schneller gewesen wär als ohnehin schon.
    Du sparst dir Klicks mitm Audio? Ich spar dafür Encodierzeit ohne Ende ^^





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Naja wenn ein Entwickler nichtmal anderes als Bitratenencoding kennt, cqp dann einbaut und man es nicht nutzen kann, weil die Techniker zu inkompetent hier bereits schon sind, da ist dann auch das vertrauen sowas an mein video zu lassen eh schonmal geschmälert
    weil cqp mit bitratenfeld und ohne angebbaren cqp wert ist schon echt mehr als peinlich.

    Guck doch die Encoder von Vegas mal an. Fast keine Einstellungen zum Encoder. Und Decoder kann kaum Formate einlesen. Bereits mit MKV Container am versagen.

    Aber Vegas ist ja zumindest nicht das schlechteste Produkt. Das absolut schlechteste was mir je unter gekommen ist, ist mit Abstand Camtasia. Vor allem Version 7. Das war schon echt brutal scheiße und dazu noch extrem verbugt xD

    Aber was die Encoder betrifft, irgendwie scheint man da Programmierer einzustellen, aber eben nur Programmierer und nicht Programmierer die sich auch im Videoencoder Bereich auskennen.
    Anders kann man sich doch solche Zustände nicht erklären





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • Hallo zusammen,

    ich hab mir hier im Schnelldurchlauf die Diskussion angesehen und die scheint mir etwas abgedriftet zu sein. Wenn ich nicht doch noch übersehen habe, dann hat auch noch keiner die Lösung für das eigentliche Problem mit dem asynchronen Video und Ton in Magix. Ich hatte bei mir exakt das gleiche Problem. Am Anfang war alles gut, am Ende des Films lief es in Magix immer mehr auseinander. Beim normalen Abspielen in irgendeinem Player ist das nie aufgefallen.
    Folgendes fällt mir dazu ein.

    1. In Magix gibt es Vorlagen beim Erstellen eines neuen Projekts, bei denen man auch die Frames für die Filme einstellen kann. Da tauchen dann nur "komische krumme Zahlen" auf die für uns Zocker nix bringen. Zum Beispiel 25 FPS oder 59,94 FPS, aber keine 60. Diese Werte können von Hand überschrieben werden und so sinniger Weise die 60 eingetragen werden. So passte es dann schon mal zu meinen Aufnahmen. Zeichnest du z. B. mit 30 FPS auf musst du in das passende Feld in Magix die 30 eintragen. Solltest du mit 60 FPS aufnehmen und dann in Magix aus Versehen die 59,94 FPS gewählt haben, läuft dir der Spaß komplett auseinander.
    2. In OBS ist mir früher schon mal das Ausgangsmaterial auseinandergedriftet. Das konnte ich mit folgender Einstellung in den Griff kriegen:
      Im Mixer-Bereich gibt es hinter jeder Tonspur ein Zahnrad für die Einstellungen. Draufklicken und die Eigenschaften der Tonspur aufrufen. Unter dem Auswahlfeld für "Gerät" hatte ich den Haken bei "Gerät Timestamps verwenden" gesetzt. Das war mein großer Fehler. Die sind scheinbar anders als bei der GraKa, als bei den Lautsprechern, als beim Mikrofon. Bei sämtlichen Tonspuren habe ich diesen Haken entfernt. Seitdem passt das Ausgangsmaterial sauber zusammen. Seit ich ohne den Haken aufnehme funktioniert die Bearbeitung in Magix auch perfekt.
    Vielleicht hilft dir das ja um deine Asynchronität in den Griff zu bekommen.

    Liebe Grüße

    Captain Andre
    Ich segle auf den Meeren der PC-Games. Schaut auf meinem Kanal vorbei: CaptainAndre 1977
  • Danke, hab den Haken beim Desktop-Audio drin gehabt. Hab ihn mal weggenommen, auch wenn ja der Mic-Sound eigentlich asynchron war.
    Bin gespannt ob es hilft.
    Das mit den 60fps hab ich schon früher geändert, daran kann es also nicht liegen.

    Danke nochmal für den Tipp, am Montag weiss ich ob es was bringt (nehme erst dann wieder mit OBS auf).
    Let's Plays für Geniesser. ^^
    Heisenberch zockt
  • Aber dann müsste es ja im Videoplayer auch asynchron sein und nicht nur in Magix.
    Und du sagtest ja eig. das es im Videoplayer synchron ist.





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • Das ist klar, das Magix bei einer völlig anderen Container & Codeckombination anders reagiert^^
    Noch hinzukommend, das dann der z.B: MagicYUV Decoder decodiert und nicht der H.264 Decoder von Magix.

    Wenn es in deinem Videoplayer von Anfang bis Ende synchron ist & lediglich in Magix asynchron ist, dann ist doch völlig logisch wo auch das Problem liegt.





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • "Wenn es in deinem Videoplayer von Anfang bis Ende synchron ist & lediglich in Magix asynchron ist, dann ist doch völlig logisch wo auch das Problem liegt."

    Jo, bei Magix, sehe ich auch so. ^^
    Aber da Magix eben bei anderen Aufnahmeprogrammen keine Probleme macht (zumindest bei mir nicht), ist ja dann eben doch auch OBS irgendwie schuld. Bzw. der Verursacher.
    Let's Plays für Geniesser. ^^
    Heisenberch zockt
  • Heisenberch zockt! schrieb:

    Aber da Magix eben bei anderen Aufnahmeprogrammen keine Probleme macht (zumindest bei mir nicht), ist ja dann eben doch auch OBS irgendwie schuld. Bzw. der Verursacher.
    Was kann OBS dafür, wenn Magix nicht richtig H.264 Video decodieren kann? Da kann doch das Aufnahmeprogramm nichts für ^^
    Mit dem anderen Aufnahmeprogramm benutzt du wie gesagt auch eine komplett andere Codec und Containerkombo. Und in dem Fall ja so, das auch'n externer VfW Decoder ran muss wie zb MagicYUV's sein eigener Decoder.
    Wenn OBS es verbockt hätte, wäre das Video überall asynchron und nicht nur in einem einzigen Programm.





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • De-M-oN schrieb:

    Tut es eben halt nicht.
    Nur mit verschwendeter Encodierzeit, oder verschwendeter Uploadzeit.
    Ich bin nicht die Person die zu faul ist 3 klicks mehr zu tätigen um an's Audio zu kommen :D Also daran liegts gewiss nicht XD

    Schlechte Encoder kann man immer mit viel Datenrate retten. Ich kann auch MPEG 2 nehmen und 800 mbit drauf geben. Klar dann siehts gut aus, aber ist das effizient? xD

    Dann nimmt man die NVEnc Implementation von den sehr inkompetenten Menschen bei Magix.
    Anscheinend kennt diese inkompetente Firma nicht mal anderes als Bitratenencoding. Anders kann man sich nicht erklären wieso man nur alle modis einbaut, aber dann bei Wahl von CQP immer noch nur das Bitratenfeld hat und kein CQP Faktor angebbar ist und somit der Default Wert von 23 genommen wird (der nicht gut ist) + bitratenlimit xD
    Generell finde ich etwas sinnfrei, wenn man nur "Magix" schreibt. Magix hat 3 verschiedene Schnittprogramme im Angebot.

    - Fastcut
    - Video Deluxe / Pro X
    - Movie Studio / Vegas

    Ich stimme dir aber zu das Magix generell nix taugt. Vegas ist zum arbeiten jedoch einigermaßen OK, soweit ich das als Anfänger beurteilen kann. Aber als Firma/Entwickler taugen sie nix. Dazu später mehr.

    Die Decoder sind absolut langsam und die Encoder lasten CPUs äußerst schlecht aus, außer das liegt an der optimierung von Intel mit h264 Enkodierung, dass unterstützt die CPU ja. (wobei ich nicht sicher bin, ob sich auf die iGPU bezieht und man dafür QSV benutzen muss, oder ob die CPU das auch ohne QSV beherrscht, aber ich denke eher, dass der Encoder grottenschlecht programmiert wurde)

    Manche schwören bei Video Deluxe auf den Intel Encoder, der ja sooo schnell sein soll. Als ich Video Deluxe probiert habe, habe ich davon nicht wirklich viel gemerkt. Eine CPU Auslastung on 60-70% bezeichne ich als Fail.

    Soweit ich weiß gibt es (oder gab?) bei Video Deluxe optional den Encoder von Mainconcept gegen eine Gebühr von 5€ oder so. Der soll wohl performanter sein und bietet/bot mehr Optionen. Magix hat angeblich den Source lizenziert, da Mainconcept den Encoder nicht mehr weiterentwickelt.

    Zumindest hat Magix bei Vegas den Mainconcept überarbeit und ihm die Unterstützung für modernere Grafikkarten beigebracht. Ich empfinde es jedoch als absolutes Armutszeugnis, wenn Vegas 14 kein Update disbzgl. dem Encoder erhält. Es ist schon extrem lächerlich wenn 2016 eine Software (= Vegas 14) auf den Markt kommt, die lediglich veraltete Grafikkarten für GPU Rendering unterstützt... vermutlich erhoffen sie sich, dass manche Vegas 14 Nutzer wegen dem Encoder auf Vegas 15 (bzw. jetzt eher 16) upgraden, auch wenn manche diverse Neuerungen von 15/16 nicht benötigen. (die sogesehen dann eher als nice-to-have einzustufen sind)

    Wenn dann auch noch Programmierer wie Vouk Encoder Plugins entwickeln, die sämtliche H264 Encoder von allen Schnittprogrammen qualitativ in den Schatten stellen, ist es für Magix eine äußerst ungelegene Situation das File IO SDK freizugeben. So würden sie von einem externen Programmierer schlicht deklassiert werden.

    Auch wenn es rein Wirtschaftlich verständlich sein mag, empfinde ich es aus technischer Sicht einfach lächerlich. Und dann liest man häufig von Software as a Service. LOL!

    Allerdings finde ich den überarbeiteten Mainconcept von Vegas 15 gar nicht mal soo schlecht. Nur Performancetechnisch finde ich ihn trotzdem schlecht - trotz GPU Support.