Urgent: OBS Aufnahme stoppt nicht, keine Datei vorhanden

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Achtung! Am 01.01.2019 werden inaktive Benutzerkonten gelöscht. Mehr Informationen findest du hier!

  • Urgent: OBS Aufnahme stoppt nicht, keine Datei vorhanden

    Anzeige
    Moin zusammen
    Da es gerade noch läuft. ich habe gerade mit meinem Mac ein PS4 Lets Play aufgenommen, nach der Aufnahme auf "stoppe Aufnahme" geklickt und nun steht da die ganze Zeit "aufnahme stoppt", aber der Zähler rennt weiter. Ich habe mkv als Ausgabe gewählt, heisst ich könnte die File wiederherstellen, aber dort, wohin ich aufnehme, ist keine Videofile vorhanden....
    Die Zeit und damit die Aufnahme läuft irgendwie weiter, die CPU Auslastung liegt bei 40%... bitte um schnelle Hilfe.
  • Jupp... kann ich bestätigen... und das als totaler Anfänger der die letzten 2 Tage damit verbracht hat alles fein und ordentlich einzurichten und dann blieb auch ein paar mal bei Aufnahme beenden der Button sozusagen hängen und meinte "Aufnahme wird beendet..." oder so... Aufnahme kam nie im data folder an... musste den Prozess nach langem warten auch abschießen, dann war erst recht keine Aufnahme da, danke mp4 Format XDDD

    Das waren zum Glück immer nur Testaufnahmen... aber das ist auch gleich ein Warnschuss für mich und war der Grund sofort auf mkv-Format umzusteigen, da ich sowieso nach der Aufnahme nochmal mit nem nvec/h264 in shotcut drüber will... zumindest SO mein Wissensstand jetzt.

    Welche OBS Version hast du eigentlich?
    Ich hab die neue direkt von der Homepage v 22.0.2

    Die 0.2. hinten lässt ja auch drauf schließen, dass es ne recht frühe version der 22 ist... ich bin bei sowas IMMER sehr misstrauisch ehrlich gesagt XD Ist wahrscheinlich dann ein Bug bei denen.
  • Anzeige
    Moin Taurus

    Ja, aber genau da liegt ja mein problem. Ich nutze mkv, aber es blieb keine Datei zurück, die ich hätte reparieren können. Obwohl die Aufnahme augenscheinlich aufgenommen wurde.
    Meine Lösung war nun das Keyframe Intervall von 0 auf 2 zu setzen. Selbst bei einem Video über 30 Minuten, gab es gestern Abend keine Probleme.
  • Ich glaub für zeitnahe oder "schnelle Hilfe" wäre unser Discord-Channel besser, oder?

    Zum Thema:
    * Bin kein Technik-Experte und kann dazu auch nur sagen, dass mir sowas mit OBS noch nie passiert ist.
    Nutze selbst seit ~April Version 21.1.0 (Win10 64bit), weil die stabil läuft und werde die auch weiter nutzen, bis eine neuere Version etwas hat, was ich ganz furchtbar dringend auch nutzen/haben will. (wonach es aktuell nicht aussieht)

    Würde mich hierbei @Taurus84 anschließen und es generell auf die "krumme" Version schieben.

    * Soweit ich weiß, erstellt OBS keine "temporäre" Datei, während der Aufnahme. (Ob und was das OS eventuell zwischenlagert1t, sei mal dahin gestellt)
    Habe parallel immer meinen "Aufnahme"-Ordner offen und da sehe ich, dass OBS, sofort nach Aufnahme-Beginn die Video-Datei platziert.
    Könntest du vielleicht auch so machen. Um zumindest von Anfang an zu wissen, ob eine Datei erstellt wird.
    Gameplay mit ungeschöntem Rumgestümper, Höhe und Tiefen,
    'ner haarigen FaceCam
    und immer einem offenen Ohr für Feedback

    J.Clockson
  • J.Clockson schrieb:

    Nutze selbst seit ~April Version 21.1.0 (Win10 64bit), weil die stabil läuft und werde die auch weiter nutzen, bis eine neuere Version etwas hat, was ich ganz furchtbar dringend auch nutzen/haben will. (wonach es aktuell nicht aussieht)
    22 hat enorme performancebesserung bei browsersource
    22 hat vor allem den 1000 FPS Bug nicht. (das 1000 fps im Header stehen)

    Updates haben schon ihren Sinn





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • De-M-oN schrieb:

    22 hat enorme performancebesserung bei browsersource
    22 hat vor allem den 1000 FPS Bug nicht. (das 1000 fps im Header stehen)

    Updates haben schon ihren Sinn
    Die Fix-, Update- und Versionshistorie ist mir bekannt. Und wie gesagt, bisher nichts dabei, was mich zum updaten bewegen könnte.
    "Browsersource" ist wohl eher für Twitch'ler/Streamer interessant und einen 1000FPS-Bug hatte ich bisher auch nicht.
    Bei mir stehen da immer nur die gewünschten 60fps.

    "Updates haben schon ihren Sinn" VS "Wenn's nicht kaputt ist, repariere es nicht."
    Gameplay mit ungeschöntem Rumgestümper, Höhe und Tiefen,
    'ner haarigen FaceCam
    und immer einem offenen Ohr für Feedback

    J.Clockson
  • J.Clockson schrieb:

    und einen 1000FPS-Bug hatte ich bisher auch nicht.
    Bei mir stehen da immer nur die gewünschten 60fps.
    Hast du in den Dateiheader geguckt oder wo hast du geguckt?
    Bedenke auch das du im OBS Forum keinerlei support kriegst, wenn du mit veralteter Version rumgurkst ^^

    ich halte von diesem "never change a running system" einfach nicht viel. Als ob die neue Version direkt kaputt ist.





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • Sowohl während der Aufnahme, bei OBS in der Statusleiste, als auch im "Header" (ich nehme an, die Infos, die man so über MediaInfo erhält, sind gemeint) steht 60 fps.

    Und ich meinte auch nur, dass man nicht wegen jedem kleinen Fix direkt zwangsläufig updaten muss. Erst recht nicht, wenn der Fix einen selbst nicht mal betrifft.

    ~Bin auch eigentlich nicht der Themen-Ersteller bzw derjenige mit dem OBS-Problem.
    Gameplay mit ungeschöntem Rumgestümper, Höhe und Tiefen,
    'ner haarigen FaceCam
    und immer einem offenen Ohr für Feedback

    J.Clockson
  • Das wird aber kein Versionsproblem sein, eher ein Bug mit dem Mac.

    Dazu müsste man eher die OBS Entwickler mal fragen und versuchen den Fehler zu finden. Denn das bräuchte dann wahrscheinlich eine neuere Version die das Problem dann behebt. Je nach dem was genau nun das Problem ist.

    J.Clockson schrieb:

    Sowohl während der Aufnahme, bei OBS in der Statusleiste, als auch im "Header" (ich nehme an, die Infos, die man so über MediaInfo erhält, sind gemeint) steht 60 fps.
    Nur letztres is relevant.
    Bei NVEnc stand bei 21 jedenfalls definitiv immer 1000fps drin. Was ein paar suboptimale Effekte mit sich brachte. u.a. auch sehr schlechte Spulbarkeit der Dateien.


    J.Clockson schrieb:

    Und ich meinte auch nur, dass man nicht wegen jedem kleinen Fix direkt zwangsläufig updaten muss. Erst recht nicht, wenn der Fix einen selbst nicht mal betrifft.
    Wenn man Support vom OBS Entwickler will - muss man es aber. Sonst gibt es keinen Support. Und das ist nicht nur bei OBS so, sondern auch bei DXTory und ja sogar bei 'nem Doom Sourceport wie GZDoom so. Erst aktuelle Version. Dann sieht man weiter. Ich kann's auch voll und ganz nachvollziehen.





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • De-M-oN schrieb:

    Das wird aber kein Versionsproblem sein, eher ein Bug mit dem Mac.

    Naja da er eine MKV als Ausgabe haben wollte, kann es schon sein, dass er ein anderes oder nur ähnlich aussehendes Problem hat wie ich.
    Es gibt aber sicherlich viele Stellen im Programmcode die trotz unterschiedlichem Format gleich sind, bzw. gleiche Funktionen nutzen und ohne den OBS Code zu kennen oder der Mega-IT-Fachmann zu sein, vermute ich so etwas.

    DENN... das was er schildert hört sich identisch zu meiner Erfahrung an... mit dem Unterschied, dass ich OBS auf einem Win7 bisher betreibe (Win10 kommt wenn mal hier alles läuft ^^) UND den Spaß mit der nicht abgespeicherten Aufnahme, bzw. ja "hängen" bleiben des "Aufnahme stoppen" Buttons bisher nur bei MP4 hatte. Da sowohl Betriebssystem und Ausgabeformat recht unterschiedlich sind, aber der Bug scheinbar zumindest identisch ist, vermute ich sogar sehr dringend einen Fehler im Programm-Code ansich... wie gesagt nur Vermutung, aber irgendwas funktioniert da generell nicht ganz so wie es sollte.

    Es waren übrigens auch keine komischen Einstellungen die ich vorgenommen hatte ^^ Meine Tests liefen erstmal mit Standard-Einstellungen von OBS um zu sehen was da überhaupt "hinten raus kommt" und danach habe ich die Einstellungen nach deinen Vorgaben (
    De-M-oN) aus diversen Beiträgen getestet ^^

    Dieses OBS Problem, aber auch das was du in anderen Beiträgen geschrieben hattest, haben mich dann auch sofort auf MKV umschwenken lassen. Außerdem gefallen mir deine Konfigurationen sehr gut, von dem was ich bisher verstanden und mir auch selbst angelesen habe, macht das auch echt alles Sinn und das Ergebnis spricht ja dann auch noch für sich... also an der Stelle auf jedenfall auch mal Danke ^^
  • Es scheint bei mir tatsächlich mit dem Keyframe Intervall zusammen zu hängen.
    Ich weiss tatsächlich nicht mal was genau das macht, das könnte Demon vermutlich erklären, aber ich hatte seit der Umstellung von 0 auf 2 keinerlei Probleme mehr.

    Weiss jemand ob es neben dem Apple Hardware Codec noch andere Codecs im Netz gibt, mit denen man am Mac flüssig aufnehmen kann?
  • Und siehst du qualitativ denn nen Unterschied in deinen Videos durch das ändern der Key-Frames?

    Denn...

    The shorter the Interval, the better chance you have of video being of better quality. This is a very subjective subject for many reasons. These cameras use compression. Basically, a "Key Frame" is an entire and complete and total image, that is used as a reference for other frames ("images") that the camera generates.

    Also muss nicht unbedingt der Riesen-Effekt sichtbar sein... man kann es aber vllt sehen, daher die Frage. Denn wenn man das in deinem Fall sieht und es dich stört, wäre es ja auch keine wirklich gute Dauerlösung, oder wie siehst du das?

    EDIT: Auch nur mal so als beiläufige Info in meinem Fall... hab seitdem ich das gleiche Problem hatte sicherlich so um die 30-40 Testaufnahmen gemacht und das durchgehend mit Keyframe auf 0 und hatte keinen einzigen Hänger beim Aufnahme beenden Button. Ich bin mir daher nicht sicher, ob das auch wirklich dauerhaft DIE Lösung für dich/mich ist, oder ob es eben ein Problem ist, das sehr selten auftritt, aber wenn es denn passiert wird die Aufnahme gefressen... sprich... kann vllt sowohl als auch bei Keyframe 0 oder 2 passieren und es hängt von etwas komplett anderem ab und das es nun bei uns beiden mit unterschiedlichen Einstellungen nun aber doch funktioniert ist vllt reine Glückssache... bis es dann wieder passiert ^^

    Falls es mir nochmal passiert die nächsten Wochen, werd ich hier posten. Bitte mach das auch so, dann können wir ja nochmal alle zusammen dran rumknobeln und es vllt dauerhaft lösen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Taurus84 ()