Automatisch Videos hochladen mit Strohis Toolset Für Uploads v0.4.0 [BETA]

  • Habe das Programm grad ausprobiert, das ist ja genial! Ich merke, wir sind beide zu faul für solche banale Klickaufgaben und wollen alles automatisieren :'D


    Ich muss jetzt nur noch testen ob es vom USB-Stick funktioniert bzw. ob der Kanal dann noch mal verbunden werden muss, dann ist das einfach geil. Good job!

    Oh ja! Wehe, ich muss irgendwas manuell machen.

    :D


    Wie das Tool von nem USB-Stick aus läuft, kann ich gar nicht sagen. Also von einem USB-Stick aus immer am selben PC sollte kein Problem sein, aber wenn es dann mehrere PCs werden, weiß ich nicht. Das hatte ich nicht auf der Uhr.


    Probiers aus, entweder Programmabsturz (dann werde ich wohl was programmieren müssen) oder es läuft. Oder was dazwischen.

    :D


    Achte aber auf folgendes: im config-ordner müsste es eine Datei "Accounts.json" (oder so ähnlich) geben. Darin ist der Zugriff auf deinen Account gespeichert. Die sollte daher nicht in fremde Finger kommen.

    ;)


    Ich schau mal, dass ich am Wochenende am Tool weiterarbeite, gibt noch ein paar Dinge, die ich umsetzen wollte. Z. B. Tutorials.


    An medu und auch an @Drexel
    Ich drück die Daumen, dass mein tool euch helfen kann! :3

  • Okay mir fehlt was ein... Ich möchte gerne Emojis in der Videobeschreibung? Jetzt kommen nur ���� dabei raus. Wäre das arg kompliziert zu implementieren? Windows 10 hat ja sogar selber welche in der virtuellen Tastatur, über die ich das einzugeben versuche. Übrigens werden die Emojis angezeigt, wenn ich die Details eines Videos verändere, nicht aber als Template.

    :love:
  • Aber dann laden die doch parallel hoch, oder nicht? Sprich, alle Videos müssen sich die vorhandene Bandbreite teilen und werden später fertig, als wenn nur ein Video hochgeladen wird und dann das nächste, sobald das erste fertig geworden ist. Soll ja angeblich noch gefixed werden. Ich bin dann jetzt tatsächlich nach längerer Zeit mal wieder zu einem Uploadprogramm gewechselt. Nachdem der YouPloader nicht mehr ging, hatte ich die ganze Zeit über den Browser hochgeladen, seit ein paar Tagen bin ich dann mal beim STFU von @strohi. Da komme ich auch einigermaßen mit zurecht, auch wenn ich noch ein paar Komfort-Funktionen vermisse.

    Hi, was für Funktionen wären das denn?
    Ich werde heute am Tool weiterarbeiten und würde mich dann gleich dransetzen.

    ;)


    ---


    @Meduselchen ich werde mir das heute genauer anschauen. Vermutlich hängt es damit zusammen, wie der Uploader die Templates auf der Festplatte speichert.

  • Hauptsächlich, dass die Uploadliste gespeichert wird, auch wenn der Uploader vor Abschließen der kompletten Liste beendet wird. Dann funktioniert <filename.number(1)> bei mir nicht, die Dateien werden ohne Nummer hochgeladen, automatisch wird da leider nichts erkannt. Und was auch noch ganz nett fände, wäre, die aktuelle Upload-Geschwindigkeit anzuzeigen. Habe ich zwar auch in der Taskleiste drin, aber die ist verdeckt, wenn ich nebenbei was auf dem anderen Monitor im Vollbildmodus habe.

  • Hauptsächlich, dass die Uploadliste gespeichert wird, auch wenn der Uploader vor Abschließen der kompletten Liste beendet wird.

    Hab ich auf der Uhr, allerdings wird das leider noch etwas dauern.
    Dafür muss ich etwas größer an der Architektur des Programms rumschrauben und das ist leider nicht ganz trivial. Der Plan ist, es mit dem Update auf 0.4.0 mitzuliefern.


    Und was auch noch ganz nett fände, wäre, die aktuelle Upload-Geschwindigkeit anzuzeigen. Habe ich zwar auch in der Taskleiste drin, aber die ist verdeckt, wenn ich nebenbei was auf dem anderen Monitor im Vollbildmodus habe.

    Das sollte machbar sein. Ich arbeite dran!

    :)


    Dann funktioniert <filename.number(1)> bei mir nicht, die Dateien werden ohne Nummer hochgeladen, automatisch wird da leider nichts erkannt.

    Das ist tatsächlich richtig so.

    :D


    Diese einfache Skript-Funktionalität war etwas, was ich bereits in der ersten veröffentlichten Version umgesetzt hatte. Das Feedback war allerdings, dass das zu kompliziert und nur schwer zu verstehen ist, weshalb ich das ganze relativ bald überarbeitet habe.


    Die einfachen "Krokodilsmäuler" < und > markieren jetzt eine Platzhalterfunktion und die fortgeschrittene und deutlich weiterentwickelte Skriptfunktion wird mit dreifachen "Krokodilsmäulern" <<< und >>> aktiviert.


    Die von dir gewünschte Funktionalität lässt sich mittels <<<FindNumber(filename, 1)>>> nutzen.


  • Okay mir fehlt was ein... Ich möchte gerne Emojis in der Videobeschreibung? Jetzt kommen nur ���� dabei raus. Wäre das arg kompliziert zu implementieren?

    Und was auch noch ganz nett fände, wäre, die aktuelle Upload-Geschwindigkeit anzuzeigen. Habe ich zwar auch in der Taskleiste drin, aber die ist verdeckt, wenn ich nebenbei was auf dem anderen Monitor im Vollbildmodus habe.


    Diese beiden Wünsche sollten im neusten Update (0.3.10) erfüllt worden sein.

    :)


    Gebt ihr mir bitte Feedback, ob es so passt?


    ---


    Peacy, hat <<<FindNumber(filename, 1)>>> funktioniert?

  • Peacy, hat <<<FindNumber(filename, 1)>>> funktioniert?

    Anfangs nicht. Bis ich dann mal durch Zufall rausgefunden habe, dass das scheinbar nicht erkannt wird, wenn die Zahl ganz am Ende des Dateinamens (oder nach einem Unterstrich) steht. Normalerweise haben meine Parts folgendes Format: Dying_20.mkv. Dort wurden die Zahlen auch mit dem neuen Platzhalter nicht erkannt. Als ich dann mal testweise die Zahl an den Anfang ohne Unterstrich geschrieben habe, ging es mit der automatischen Erkennung: T01-TombRaider.mkv.


    Und noch zwei Sachen ist mir aufgefallen: Das "Am Ende automatisch herunterfahren" fährt den PC schon nach Beenden des aktuellen Uploads herunter, nicht erst, nachdem die Liste abgearbeitet ist. Und das automatische Erkennen und Einlesen von Videodateien scheint nicht zu funktionieren, wenn mehr als ein Pfad überwacht werden soll.

  • Ich versuche mich gerade zum erstenmal mit deinem Tool, das schaut alles sehr klasse aus, der Upload an sich klappt auch...


    (Du ahnst, es läuft auf ein "aber" hinaus")aaaaber ich brauche mal etwas Hilfe zum Verständnis...


    Grundsätzliche Einrichtung habe ich wie in deinem Tutorial-Video gemacht, klappt - ich möchte nun das die Videotitel automatisch aus einer TXT ausgelesen werden, dazu nutze ich das:
    <ReadFile(D:\FertigeVideos\Tomb_Raider_Underworld\<filename.findNumber(1)>.txt)>


    (laut Tutorial), muß ich nun daraus:
    <ReadFile(D:\FertigeVideos\Tomb_Raider_Underworld\<<<filename.findNumber(1)>>>.txt)>
    machen?


    Thumbnails werden auch nicht korrekt gezogen (also eigentlich gar nicht)...


    Oder ist diese Vorgehensweise jetzt gänzlich anders? (mit Blick auf einem deiner letzten Postings hier im Thread)?


    Edit:
    Bzgl. der Thumbnails hatte ich einen Tippfehler, das geht.


    Bzgl. der Filenamen habe ich nun dein neues Prinzip genommen und es funktioniert (natürlich). Mich täte aber doch noch interessieren ob das alte Prinzip auch noch funktioniert.

  • Oder ist diese Vorgehensweise jetzt gänzlich anders? (mit Blick auf einem deiner letzten Postings hier im Thread)?

    Japp, deswegen habe ich auch das Tutorial-Video jetzt aus dem Startpost rausgenommen. Mir war gar nicht bewusst, dass es noch verlinkt ist, sorry.

    :D


    Bzgl. der Thumbnails hatte ich einen Tippfehler, das geht.

    Das freut mich.

    :)


    Mich täte aber doch noch interessieren ob das alte Prinzip auch noch funktioniert.

    Ja, allerdings muss es anders aufgerufen werden, in deinem Fall so:
    <<< ReadFile(@"D:\FertigeVideos\Tomb_Raider_Underworld\" + FindNumber(filename, 1) + ".txt") >>>
    Dann würde er für z. B. Tomb_Raider_Underworld_Part_039.mp4 den Inhalt aus D:\FertigeVideos\Tomb_Raider_Underworld\039.txt laden (oder ohne führende Null, falls im Dateinamen und im Namen der Txt-Datei keine steht).
    Dabei handelt es sich dann nicht mehr um eine von mir mehr schlecht als recht hingeskriptete eigene Skriptsprache, sondern um validen C#-Code. Das war der Grund für die Umstellung, denn so ist die Skript-Funktionalität nämlich umfangreicher und trotzdem leichter zu warten.


    ---


    @Peacemaker zockt
    Ich konnte den Fehler mit der Nummer im Dateinamen nachvollziehen und arbeite grade an einem Fix.
    Ich verstehe jetzt auch, wieso ich das Problem nicht hatte. Fix ist auf dem Weg.

    :)


    Das Erkennen von neu im Ordner deponierten Videos müsste mit Version 3.10 eigentlich behoben sein, da muss ich noch mal schauen, falls es nicht geht.


    Das Runterfahren schau ich mir noch mal an. Da ist mir auch schon aufgefallen, dass das manchmal komisch rumzickt..

    :(
  • @strohi : Danke für deine Rückmeldung.


    Ah, okay, alles nur noch in C...

    ;)

    gut, da muß ich mich ggfs. dann nochmal reinfuchsen, ist ewig her. Bzw. du hast mir ja schon die Lösung gegeben, damit kann ich dann (für meine Bedürfnisse) perfekt arbeiten - danke!

  • Jupp, jetzt ist es C#.


  • Das Erkennen von neu im Ordner deponierten Videos müsste mit Version 3.10 eigentlich behoben sein, da muss ich noch mal schauen, falls es nicht geht.

    Oki, teste ich dann mal bei Gelegenheit, wenn ich mal wieder mehrere Projekte zum gleichzeitigen Hochladen habe, ob es mittlerweile funktioniert. Oder ich gebe beim Hochladen halt mal mehrere Ordner an.


    Das Runterfahren schau ich mir noch mal an. Da ist mir auch schon aufgefallen, dass das manchmal komisch rumzickt..

    Jop, also sowohl "Herunterfahren" als auch "Programm schließen" war bei mir jedes Mal nach Ende des aktuellen Uploads, nicht erst, wenn alle Uploads aus der Liste fertig waren.

  • Version 0.3.11 BETA wurde von mir grade veröffentlicht.


    Änderungen:

    • Der von @Peacemaker zockt gefundene Bug, dass das Programm sich schon schließt / den Computer herunterfährt, bevor alle Videos hochgeladen wurden, wurde gefixt. Ich hab das jetzt ne Stunde lang getestet und hoffe wirklich, dass ich nichts übersehen habe.
    • Der ebenfalls von @Peacemaker zockt gefundene Bug, dass Zahlen am Dateiende nicht erkannt werden, sollte nun auch behoben sein.
    • Der von @Emwe gefundene Bug, dass das Programm abstürzt, wenn ein zu überwachender Ordner nicht mehr da ist, wurde gefixt. Das Programm startet dann die Überwachung ohne den Ordner, gibt aber keine Meldung aus, dass der Ordner nicht mehr da ist. Ich hoffe mal, dass das für dich so ok ist.
    • Ein Bug, dass die vom Uploader versandte Mail über den Erfolg des letzten hochgeladenen Videos vor dem Schließen / Runterfahren des PCs nicht geschickt wurde, wurde behoben.
    • Als Feature kam hinzu, dass man das Suchen nach neuen Videos und das Hochladen der gefundenen Videos jetzt getrennt starten und beenden kann. Für das Suchen gibt es einen Button oberhalb der Warteschlange, für das Hochladen gibt es den Button unter der Warteschlange.
    • Außerdem habe ich den Uploader jetzt so umgeschrieben, dass das Fenster beim Starten der Überwachung, wo man für alle Pfade das Veröffentlichungsdatum der Videos eingeben kann, oder ob man ihn z. B. nicht überwachen will, optional ist.


      Ab sofort funktioniert das Starten der automatischen Überwachung so:

      • Wenn man auf den Button "Sofort starten!" klickt, dann startet der Autouploader sofort. Er überwacht dabei alle Pfade und berechnet ausgehend vom Veröffentlichungsdatum des letzten Videos aus dem Pfad das nächste, das nach dem eingestellten Muster drankommen würde.
      • Wenn man die alte Ansicht haben möchte, weil man z. B. einen Pfad dieses mal nicht überwachen will, kann man beim Button rechts auf den kleinen Pfeil klicken und aus dem Menü den erweiterten Upload auswählen. Dann kommt das Fenster und alles funktioniert so, wie bisher.
    • Außerdem wird das Veröffentlichungsdatum, das für das nächste Video vom Uploader eingestellt werden wird, jetzt bei der Veröffentlichungsplanung in den Templates angezeigt und kann dort auch geändert werden.


    Für die nächste Version (0.3.12) plane ich, die Videos über das Programmende hinaus zu merken und ein Archiv einzubauen, wo man alle bisher hochgeladenen Videos sehen kann. Bisher ist es ja so, dass der Uploader bei jedem Start alle Videos der vorigen Session vergessen hat, auch wenn z. B. welche davon noch gar nicht hochgeladen wurden.


    Da das etwas umfangreicher werden wird, suche ich aktuell Leute, die das für mich vor der offiziellen Veröffentlichung testen. Würde sich da jemand für bereiterklären?

    :)


    Und noch ne kurze Frage zur Nutzung:
    Gibt es eigentlich jemanden, der sich per Mail benachrichtigen lässt, wenn ein Video hochgeladen wurde?
    Das Feature hab ich selbst sehr vermisst und habe es deswegen eingebaut, aber mir stellt sich ein bisschen die Frage, ob es überhaupt bekannt und von den Leuten so gewollt ist.

    8|
    • Der von @Peacemaker zockt gefundene Bug, dass das Programm sich schon schließt / den Computer herunterfährt, bevor alle Videos hochgeladen wurden, wurde gefixt. Ich hab das jetzt ne Stunde lang getestet und hoffe wirklich, dass ich nichts übersehen habe.
    • Der ebenfalls von @Peacemaker zockt gefundene Bug, dass Zahlen am Dateiende nicht erkannt werden, sollte nun auch behoben sein.

    Das mit dem Herunterfahren klappt mittlerweile. Das mit den Zahlen am Dateiende muss ich noch testen, mache ich morgen oder so mal, jetzt habe ich erst mal alles hochgeladen, was noch anstand.


    Da das etwas umfangreicher werden wird, suche ich aktuell Leute, die das für mich vor der offiziellen Veröffentlichung testen. Würde sich da jemand für bereiterklären?

    Könnte ich gerne machen.


    Gibt es eigentlich jemanden, der sich per Mail benachrichtigen lässt, wenn ein Video hochgeladen wurde?

    Nö. Ich bin froh, wenn ich so wenig Emails wie möglich bekomme. Daher habe ich auch die ganzen Mails von Youtube abgestellt und lasse mich dann über neue Kommentare per Push-Benachrichtigungen der jeweiligen Apps benachrichtigen.

  • Ich hab mich jetzt auch mal da reingearbeitet. Es geht alles locker und flockig von der Hand. Das einzige was mich etwas stört ist das es derzeit nur einen Kanal unterstützt.
    Ich besitze zwei Channel auf yt, und es wäre super wenn man schnell zwischen diesen beiden switchen könnte. Und das ohne die Verbindung vom ersten zu lösen.


    Aktuell muss ich immer erst die Verbindung vom ersten lösen, den anderen verbinden, den Code eingeben, und dann beim erneuten Wechsel zum ersten Account das Prozedere wiederholen.

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!