Streamen mit OBS: die optimalen Einstellungen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Anzeige
    @Lila Jewel Also ich würde vorschlagen du postest erstmal deine Einstellungen die du im Video Tab getätigt hast, weil sonst ist es sehr schwer dir bei diesem Problem weiterhelfen zu können. Ich vermute mal das da etwas mit den Auflösungen falsch eingestellt ist. Wegen der Ruckler kannst du ja mal über den Task Manager schauen wie die Auslastung deiner internen Grafikkarte ist. Die findest du unter Leistung. Kann sein das die Onboard Grafikkarte bei QuickSync irgendwann überfordert ist und das diese Ruckler auslöst.
  • SpodGamesTV schrieb:

    Also ich würde vorschlagen du postest erstmal deine Einstellungen die du im Video Tab getätigt hast, weil sonst ist es sehr schwer dir bei diesem Problem weiterhelfen zu können.
    Ja klar, die poste ich dann selbstverständlich dazu! :thumbup:

    SpodGamesTV schrieb:

    Ich vermute mal das da etwas mit den Auflösungen falsch eingestellt ist. Wegen der Ruckler kannst du ja mal über den Task Manager schauen wie die Auslastung deiner internen Grafikkarte ist. Die findest du unter Leistung. Kann sein das die Onboard Grafikkarte bei QuickSync irgendwann überfordert ist und das diese Ruckler auslöst.
    Deswegen habe ich ja in den BIOS extra iGPU aktiviert, damit auf die externe GraKa zugegriffen wird. Da dürfte es dann doch eigentlich keine Ruckler geben, oder? :/ Aber ja, es kann an der Auflösung liegen. Ich mache zu Hause mal einen Screenshot von meinen Aufnahme-Einstellungen oder tippe sie ab.
    :thumbsup: Guild-Girl <3 :love:
  • Sodele! Also. Sorry, Doppelpost, aber lässt sich grad nicht vermeiden.

    Hier nun mal die Links zu den erstellten Probeaufnahmen auf Twitch. Einmal mit ShadowPlay auf den niedrigsten EInstellungen, einmal mit ShadowPlay auf den höchsten Einstellungen und einmal mit OBS mit den hier vorgeschlagenen Einstellungen.
    Ich muss gestehen, dass der Stream mit OBS von der Bildqualität her doch besser aussieht, als der Stream mit ShadowPlay. Aber (und zwar großes ABER), ich habe für ShadowPlay auch die absolut niedrigsten EInstellungen getroffen und auch auf den höchsten Einstellungen läuft der Stream hiermit besser, als mit OBS.

    Video Nr. 1 (OBS)
    Einstellungen:
    Audiospur: 1
    Codierer: QuickSync H.264
    Erzwinge Streamingdienst-Codierereinstellingen: kein Haken gesetzt
    Ausgabe umskalieren: kein Haken gesetzt
    Zielnutzung: quality
    Profil: main
    Keyframeintervall (Sekunden, 0=auto): 2
    Async Depth: 4
    Qualitäts Regulierungsmethode: CBR
    Bitrate: 6000

    Video Nr. 2 (ShadowPlay Low Quality)
    Einstellungen:
    Auflösung: spielintern
    Bildfrequenz: 30 FPS
    Bitrate: 10 Mbps

    Video Nr. 3 (ShadowPlay High Quality)
    Einstellungen:
    Auflösung: spielintern
    Bildfrequenz: 60 FPS
    Bitrate: 50 Mbps
    :thumbsup: Guild-Girl <3 :love:
  • Ui da droppen in OBS aber ganz schön die FPS. Das ist nicht ansatzweise flüssig.
    An sich ist die Quali ok von OBS aber es ruckelt.

    1. Hast du in Guild Wars VSync an?
    2. Wie hoch ist die GPU Auslastung wenn Guild Wars läuft (im Task-Manager unter Leistung ersichtlich)
    3. Wenn du OBS und Guild Wars gleichzeitig aktiv hast was steht unten bei den FPS?
    4. Wieviel FPS hast du in OBS eingestellt? 30 oder 60?

    Dazu musst du nämlich wissen wenn in Guild Wars dir die FPS droppen (unter die von VSync) gehen in OBS auch die FPS runter weil dann ist deine GPU am Limit. Die Szene in OBS braucht auch GPU Leistung und nicht grad wenig :/
  • Anzeige
    @Lila Jewel Du könntest mal versuchen bei der Zielnutzung mal auf "main" umzustellen.

    Bei OBS sieht es mir fast so aus als wäre deine interne Grafikeinheit mit dem streamen komplett überfordert wenn gerade viel passiert. Das sieht man vor allem wenn du kurz im Ladevorgang bist und das Bild dann wieder flüssiger wird.

    Ich sehe anhand deines Beitrags das du eine GTX 660 benutzt. Diese Karte hatte ich damals auch gehabt und mit NVENC konnte ich da beispielsweise kein Battlefield 4 streamen da es genauso geruckelt hat.

    Ansonsten wie @Rayxin schon sagt kannst du auch mal deine Auslastung überprüfen.

    Deine CPU ist auch nicht schlecht du kannst mit der schon einigermaßen streamen. Wenn du magst kann ich dir mal meine Einstellungen verraten und du kannst die Bitrate auf deine Anbindung anpassen.
  • Rayxin schrieb:

    Ui da droppen in OBS aber ganz schön die FPS. Das ist nicht ansatzweise flüssig.
    An sich ist die Quali ok von OBS aber es ruckelt.
    Yupp, wie gesagt. Und das geht halt leider gar nicht so. Wie du schon sagst, die Quali ist dufte, aber es ruckelt dermaßen, dass es eigentlich unguckbar ist.

    Rayxin schrieb:

    1. Hast du in Guild Wars VSync an?
    2. Wie hoch ist die GPU Auslastung wenn Guild Wars läuft (im Task-Manager unter Leistung ersichtlich)
    3. Wenn du OBS und Guild Wars gleichzeitig aktiv hast was steht unten bei den FPS?
    4. Wieviel FPS hast du in OBS eingestellt? 30 oder 60?
    Das schaue ich zu Hause noch mal nach. Das weiß ich grad nicht aus dem Kopf.

    SpodGamesTV schrieb:

    @Lila Jewel Du könntest mal versuchen bei der Zielnutzung mal auf "main" umzustellen.
    Ja, das könnte ich mal ausprobieren. Danke!

    SpodGamesTV schrieb:

    Bei OBS sieht es mir fast so aus als wäre deine interne Grafikeinheit mit dem streamen komplett überfordert wenn gerade viel passiert. Das sieht man vor allem wenn du kurz im Ladevorgang bist und das Bild dann wieder flüssiger wird.
    Aber kann das denn sein, dass es mit der internen Grafikeinheit zu tun hat, wenn ich das System in den BIOS auf iGPU umgestellt habe?

    SpodGamesTV schrieb:

    Ich sehe anhand deines Beitrags das du eine GTX 660 benutzt. Diese Karte hatte ich damals auch gehabt und mit NVENC konnte ich da beispielsweise kein Battlefield 4 streamen da es genauso geruckelt hat.
    Ich würde es jetzt nicht beschwören, aber ich würde doch vermuten, dass die Anforderungen von GW2 nicht so hoch sind, wie die von Battlefield 4. Aber das ist nur eine Vermutung. Aber gerade dann wundert es mich eben, dass es bei mir so ruckelt.

    SpodGamesTV schrieb:

    Deine CPU ist auch nicht schlecht du kannst mit der schon einigermaßen streamen. Wenn du magst kann ich dir mal meine Einstellungen verraten und du kannst die Bitrate auf deine Anbindung anpassen.
    Ist auch 'ne Idee, klar. Können wir mal drüber schauen.


    Was natürlich auch eine Möglichkeit ist ist, dass ich einfach die Einstellungen von Guild Wars 2 ein wenig anpassen muss. @Rayxin du hast da ja schon ein paar Tipps gegeben. Vielleicht liegt es ja am Spiel und nicht am System. Da könnte ich mir auch noch mal meine Einstellungen anschauen, bzw. Screenshots von machen, dass ihr euch das mal anschauen könnt.
    :thumbsup: Guild-Girl <3 :love:
  • Lila Jewel schrieb:



    Aber kann das denn sein, dass es mit der internen Grafikeinheit zu tun hat, wenn ich das System in den BIOS auf iGPU umgestellt habe?
    Was natürlich auch eine Möglichkeit ist ist, dass ich einfach die Einstellungen von Guild Wars 2 ein wenig anpassen muss. @Rayxin du hast da ja schon ein paar Tipps gegeben. Vielleicht liegt es ja am Spiel und nicht am System. Da könnte ich mir auch noch mal meine Einstellungen anschauen, bzw. Screenshots von machen, dass ihr euch das mal anschauen könnt.
    Deine Einstellung im BIOS bedeutet nur das du die interne Grafikeinheit aktiviert hast. So gut wie jede aktuelle Intel CPU hat eine eigene interne Grafikeinheit und die ist wie eine eigene Grafikkarte selbst. Sie ist aber nur für Desktopbetrieb ausgelegt falls du keine seperate Grafikkarte im PC eingebaut hast.

    Kann gut möglich sein das @Rayxin beispielsweise eine bessere CPU mit einer besseren internen Grafikeinheit verwendet als du und das aus diesem Grund deine Einheit überlastet ist und seine nicht.

    Das lässt sich aber nur herausfinden wenn du mal die Auslastung der internen Grafikeinheit während dem Streamen überprüfst.

    Ansonsten meine Streams laufen über die CPU und sind speziell auf meine angepasst. Aber deine CPU sollte das mit feintuning auch handhaben können.
  • SpodGamesTV schrieb:

    Deine Einstellung im BIOS bedeutet nur das du die interne Grafikeinheit aktiviert hast. So gut wie jede aktuelle Intel CPU hat eine eigene interne Grafikeinheit und die ist wie eine eigene Grafikkarte selbst. Sie ist aber nur für Desktopbetrieb ausgelegt falls du keine seperate Grafikkarte im PC eingebaut hast.
    So wie ich das verstanden habe, müsste es doch genau umgekehrt sein: dadurch, dass ich iGPU jetzt in den BIOS aktiviert habe, greift das System nun eben genau nicht mehr auf die interne Grafikeinheit, sondern auf die externe Grafikkarte von NVidia zu?! Stehe ich auf dem Schlauch? Habe ich da was falsch verstanden? Muss ich iGPU jetzt wieder deaktivieren? 8| :S

    SpodGamesTV schrieb:

    Das lässt sich aber nur herausfinden wenn du mal die Auslastung der internen Grafikeinheit während dem Streamen überprüfst.
    Und wie genau mache ich das? :huh:

    SpodGamesTV schrieb:

    Ansonsten meine Streams laufen über die CPU und sind speziell auf meine angepasst. Aber deine CPU sollte das mit feintuning auch handhaben können.
    Okay, und was genau bedeutet das jetzt und wie mache ich das? :/
    :thumbsup: Guild-Girl <3 :love:
  • Lila Jewel schrieb:

    So wie ich das verstanden habe, müsste es doch genau umgekehrt sein: dadurch, dass ich iGPU jetzt in den BIOS aktiviert habe, greift das System nun eben genau nicht mehr auf die interne Grafikeinheit, sondern auf die externe Grafikkarte von NVidia zu?! Stehe ich auf dem Schlauch? Habe ich da was falsch verstanden? Muss ich iGPU jetzt wieder deaktivieren? 8| :S

    SpodGamesTV schrieb:

    Das lässt sich aber nur herausfinden wenn du mal die Auslastung der internen Grafikeinheit während dem Streamen überprüfst.
    Und wie genau mache ich das? :huh:

    SpodGamesTV schrieb:

    Ansonsten meine Streams laufen über die CPU und sind speziell auf meine angepasst. Aber deine CPU sollte das mit feintuning auch handhaben können.
    Okay, und was genau bedeutet das jetzt und wie mache ich das?
    iGpu bedeutet das er die Grafikkarte und die interne Einheit verwendet.

    Gebe unten in der Windows Suche ein Task-Manager und klicke auf den Reiter Leistung In einer Liste sollte stehen GPU0 und GPU1.
    Bei mir ist GPU0 die interne Grafikeinheit.

    Nun startest du einfach deinen Stream und beobachtest die Auslastung von GPU0. Wenn die bei 100% ist deutet das auf eine Überlastung hin.

    Wenn du einen Stream über die CPU laufen lassen willst kann ich dir mal meine Einstellungen verraten. Unter den Link schreibe ich die Punkte die du bei dir abändern solltest.

    pic-upload.de/view-35478268/Streaming.png.html

    - Ausgabe umskalieren haken rausmachen
    - Bitrate auf deinen Upload anpassen
    - Puffergröße ist bei mir immer genauso hoch wie die Bitrate.
    - Prozessorauslastung solltest du auf faster wenn nicht eher veryfast umstellen.

    Ansonsten kann alles so bleiben wie es ist.
  • SpodGamesTV schrieb:

    iGpu bedeutet das er die Grafikkarte und die interne Einheit verwendet.
    Okay. Na, das sollte doch aber eigentlich gut sein, oder nicht? 8|

    SpodGamesTV schrieb:

    Gebe unten in der Windows Suche ein Task-Manager und klicke auf den Reiter Leistung In einer Liste sollte stehen GPU0 und GPU1.
    Bei mir ist GPU0 die interne Grafikeinheit.

    Nun startest du einfach deinen Stream und beobachtest die Auslastung von GPU0. Wenn die bei 100% ist deutet das auf eine Überlastung hin.
    Bei mir ist auch GPU0 die Intel-interne Grafikeinheit. Die macht aber gar nichts. Die einzige, bei der was passiert, ist die GPU1. Und die ist so ziemlich am Limit, wenn ich für's streamen das Spiel, den Browser, OBS und den StreamLabs-Bot an habe. X/ An welchen Einstellungen muss ich dann jetzt drehen? Auch an den Spieleinstellungen von GW2?

    SpodGamesTV schrieb:

    - Ausgabe umskalieren haken rausmachen
    Bei "Ausgabe umskalieren" habe ich eh keinen Haken drin.

    SpodGamesTV schrieb:

    - Bitrate auf deinen Upload anpassen
    Öööööh... hier bräuchte ich Noob eine genauere Erläuterung. :S

    SpodGamesTV schrieb:

    - Puffergröße ist bei mir immer genauso hoch wie die Bitrate.
    - Prozessorauslastung solltest du auf faster wenn nicht eher veryfast umstellen.
    Check! :thumbup:

    Rayxin schrieb:

    1. Hast du in Guild Wars VSync an?
    2. Wie hoch ist die GPU Auslastung wenn Guild Wars läuft (im Task-Manager unter Leistung ersichtlich)
    3. Wenn du OBS und Guild Wars gleichzeitig aktiv hast was steht unten bei den FPS?
    4. Wieviel FPS hast du in OBS eingestellt? 30 oder 60?
    1. Ja, Vertikale Synchronisierung ist eingeschaltet. Warum? Soll die besser aus?
    2. Wenn ich rumstehe in den 70ern. Wenn richtig was geht, also im Kampf z.B., kommt die GPU1 an ihr Limit. Nie 100%, aber in den 90ern. :/
    3. Die FPS bei GW2+OBS schwanken zwischen 32 und 48. Eher in den hohen 30ern, niedrigen 40ern.
    4. Bei OBS habe ich bei "Video" unter "übliche FPS Werte" 30 eingestellt.


    P.S.: Mit den von @SpodGamesTV vorgeschlagenen Änderungen liegt die GPU1-Auslastung beim streamen zwar jetzt "nur noch" bei Ende 70%, Anfang 80%, aber der Stream ruckelt gefühlt noch schlimmer, als vorher. ;(
    :thumbsup: Guild-Girl <3 :love:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Lila Jewel ()

  • Die iGPU ist im Normalfall deutlich schlechter, als deine dedizierte Grafikkarte, daher kann ich mir nicht vorstellen, dass das Encoding über die iGPU sonderlich toll sein wird. Bei deiner Hardware muss ich leider auch sagen, dass ich weder Grafikkarte noch Prozessor für sonderlich encodinggeeignet halte. Nur vier Kerne ohne Hyperthreading ist für x264-Encoding über den Prozessor alles andere als optimal und deine GTX 660 hat ja mittlerweile auch schon einige Jahre auf dem Buckel, daher bezweifle ich, dass sich da gute Ergebnisse mit erzielen lassen.

    Aber wie ja einige schon geschrieben haben, H264 ist da bei dir wahrscheinlich die sinnvollste Lösung. Die Shadowplay-Aufnahmen laufen zwar flüssig, allerdings hast du da bei Bewegung (gerade auf Low) ziemlichen Pixelbrei im Bild. Allerdings immer noch besser als stockendes Bild. Daher würde ich auf kurz oder lang mal über eine neue Grafikkarte nachdenken. So schlimm sieht es mit den Preisen da mittlerweile nicht mehr aus. Dann sollte bei einem Stream über die Grafikkarte auch ein deutlich besseres Bild drin sein.
    AKTUELLE PROJEKTE
    0 Uhr: indiziertes Spiel
    12 Uhr: StarCraft II - Wings of Liberty
    15 Uhr: Deus Ex - Invisible War [BLIND]
    18 Uhr: Beyond Good & Evil [BLIND]

    Folge der Ziege
  • Peacemaker zockt schrieb:

    Die iGPU ist im Normalfall deutlich schlechter, als deine dedizierte Grafikkarte, daher kann ich mir nicht vorstellen, dass das Encoding über die iGPU sonderlich toll sein wird. Bei deiner Hardware muss ich leider auch sagen, dass ich weder Grafikkarte noch Prozessor für sonderlich encodinggeeignet halte. Nur vier Kerne ohne Hyperthreading ist für x264-Encoding über den Prozessor alles andere als optimal und deine GTX 660 hat ja mittlerweile auch schon einige Jahre auf dem Buckel, daher bezweifle ich, dass sich da gute Ergebnisse mit erzielen lassen.

    Aber wie ja einige schon geschrieben haben, H264 ist da bei dir wahrscheinlich die sinnvollste Lösung. Die Shadowplay-Aufnahmen laufen zwar flüssig, allerdings hast du da bei Bewegung (gerade auf Low) ziemlichen Pixelbrei im Bild. Allerdings immer noch besser als stockendes Bild. Daher würde ich auf kurz oder lang mal über eine neue Grafikkarte nachdenken. So schlimm sieht es mit den Preisen da mittlerweile nicht mehr aus. Dann sollte bei einem Stream über die Grafikkarte auch ein deutlich besseres Bild drin sein.
    Der Intel QuickSync ist effizienter als der Nvenc. Nur weil eine Onboard ist muss es nicht immer schlechter sein ^^

    iGPU bedeutet "Integrated Grpahics Processor Unit". Heißt onboard Grafikkarte. Nur im äußersten Notfall verwenden oder wie in dem Fall hier als Renderer für OBS

    Zum THema Auslastung bei einer GTX660 den Settings und OBS wundert es mich gar nicht das es ruckelt. Würde sogar behaupten das deine Graka es generell nicht schafft das Spiel stabil auf 60FPS zu halten mit den Settings. Meine Frau musste schon mit einer 960 die Settings auf Mid/High stellen um stabile 60FPS zu bekommen.

    SMAA zerrt extrem an der Leistung. Ist die Kantenglättung. Stell die aus oder auf Low.
    Schatten ist auch sehr beliebt dafür extrem an der perfomance zu fressen. Low oder Mid testen

    P.s. Sehe grade du hast kein OBS an während der Screens und hast grad mal 33FPS. Das ist für OBS zu niedrig. Es sei denn du stellst OBS auf 30 FPS ein (Einstellungen--->Video)
    Hat 3 Vorteile
    1. OBS zieht nicht soviel performance
    2. Die Bildquali steigt auf Twitch da mehr Bitrate zur Verfügung steht.
    3. Du hast eine höhere Tolerenzgrenze bei OBS bevor der Stream ruckelt.
    OBS fängt an zu ruckeln bzw der Stream wenn die Ingame FPS unter der in OBS eingestellten FPS droppen.
    Nachteil an der ganzen Sache ist 60FPS Fanatiker werden deinen Stream nie anschauen.
  • Muss mich da meinen Vorrednern anschließen. Ich dachte das man mit dem I5 das noch handlen könnte da mein I7 6700K ebenfalls nur 4 Kerne hat und es trotzdem sehr gut funktioniert. Liegt wahrscheinlich an der besseren Leistung pro Kern die im Vergleich zu einem normalen I5 besser ist. Das einzige was da hilft ist viel rumprobieren.
    Ich hatte früher einen AMD FX 8320 Prozessor zum streamen gehabt und da hats auch nicht gut funktioniert da die CPU mit dem spielen meist schon an der Leistungsgrenze war.

    Ich habe das dann so geregelt. Notebook genommen mit genug Leistung und mit einer Game Capture das Signal des PCs abgegriffen und über das Notebook gestreamt.
  • Na, das sind ja Neuigkeiten. ;( Das heißt, ich kann Streamen in vernünftiger Qualität im Grunde vergessen, solange ich keine bessere Grafikkarte habe? Na, geil. Das ist jetzt leider nichts, was ich mir mal eben so zwischendurch leisten kann. Abgesehen davon, so alt wie der PC mit all seinen Komponenten inzwischen ist (wurde Anfang 2014 in Betrieb genommen) würde ich lieber noch ein bisschen warten und versuchen so viel wie möglich zu sparen, um mir dann nächstes Jahr oder so ein vernünftiges High-End-Setup zusammenzustellen, mit besserem Prozessor, besserer Grafikkarte, größerer Festplatte und allem Pipapo. Die ein oder andere Komponente kann ich mir vielleicht zu Weihnachten oder zum Geburtstag wünschen. Hmm, na toll. Ich werde auf jeden Fall noch mal ein bisschen rumfrickeln und an den Einstellungen schrauben. Aber nach dem, was ihr geschrieben habt, habe ich ehrlich gesagt wenig Hoffnung, dass das noch viel bringt. Dann muss ich, wenn, dann wohl erst mal 'ne Zeit lang mit ShadowPlay und ohne mein schönes Overlay streamen. :(
    :thumbsup: Guild-Girl <3 :love:
  • @Lila Jewel Sry für die schlechten Nachrichten. Aber da wir bis jetzt alle der von OBS genutzten Codierer ausprobiert haben kann der Grund auch an der Hardware liegen. Vorallem da du ja Einstellungen nutzt die bei anderen problemlos funktionieren. Da du dich in den vorherigen Threads immer über sehr hohe Auslastungen beklagt hast kann das schon ein Grund sein. Das Shadowplay weniger Ressourcen für das Aufnehmen und Streamen als OBS verbraucht ist allgemein bekannt. Dafür kann man bei Nividia leider nicht so viel personalisieren was wahrscheinlich auch einer der Gründe ist warum es weniger Ressourcen verbraucht als OBS.

    Wenn du umbedingt streamen willst kann ich dir auch die Methode mit einer GameCapture ans Herz legen. Jedoch brauchst du dafür noch einen zweiten Rechner. Damit kannst du aber streamen ohne dein Gaming System zu belasten.