OBS & TMPGEnc - Mikroruckeln in der fertigen Aufnahme

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS & TMPGEnc - Mikroruckeln in der fertigen Aufnahme

    Anzeige
    Hallo zusammen,

    erst kürzlich musste ich meine Aufnahme-Methode ändern, da das alte Aufnahmeprogramm plötzlich nur noch rumzickt.
    Ich verwende nun OBS mit den folgenden Einstellungen:

    i.imgur.com/T3aplEp.png

    Zum Rendern benutze ich TMPGEnc mit den folgenden Werten:

    i.imgur.com/xlO7S3O.png


    Während des Spielens und der Aufnahme läuft alles butterweich. Im fertig gerenderten Video merkt man Insbesondere bei Kamera-Schwenks aber ein Mikroruckeln während der gesamten Bewegung. Ich frage mich, was das verursacht und ob das jemand von euch auch schon bemerkt hat. Vielleicht hat jemand eine Idee, wie das Problem zu beheben ist?


    Bei der Aufnahme mit Dxtory & MagicYUV-Codec (was ich vorher verwendete) sowie anschließendem Rendern mit meGUI, gab es diese Probleme überhaupt nicht.

    Vielen Dank für eure Unterstützung!
  • Die MediaInfo der Aufnahmedatei:

    Quellcode

    1. General
    2. Unique ID : 58580687588417809039517186433723657466 (0x2C123AE3D4DCFD24C68084DF299BECFA)
    3. Complete name : J:\testaufnahme.mkv
    4. Format : Matroska
    5. Format version : Version 4 / Version 2
    6. File size : 231 MiB
    7. Duration : 37 s 517 ms
    8. Overall bit rate mode : Variable
    9. Overall bit rate : 51.6 Mb/s
    10. Writing application : Lavf57.84.100
    11. Writing library : Lavf57.84.100
    12. ErrorDetectionType : Per level 1
    13. Video
    14. ID : 1
    15. Format : AVC
    16. Format/Info : Advanced Video Codec
    17. Format profile : High@L4.2
    18. Format settings : 2 Ref Frames
    19. Format settings, CABAC : No
    20. Format settings, RefFrames : 2 frames
    21. Codec ID : V_MPEG4/ISO/AVC
    22. Duration : 37 s 517 ms
    23. Bit rate mode : Variable
    24. Maximum bit rate : 40.0 Mb/s
    25. Width : 1 920 pixels
    26. Height : 1 080 pixels
    27. Display aspect ratio : 16:9
    28. Frame rate mode : Constant
    29. Frame rate : 60.000 FPS
    30. Color space : YUV
    31. Chroma subsampling : 4:2:0
    32. Bit depth : 8 bits
    33. Scan type : Progressive
    34. Default : Yes
    35. Forced : No
    36. Color range : Limited
    37. Matrix coefficients : BT.709
    38. Audio #1
    39. ID : 2
    40. Format : AAC
    41. Format/Info : Advanced Audio Codec
    42. Format profile : LC
    43. Codec ID : A_AAC-2
    44. Duration : 37 s 483 ms
    45. Channel(s) : 2 channels
    46. Channel positions : Front: L R
    47. Sampling rate : 48.0 kHz
    48. Frame rate : 46.875 FPS (1024 SPF)
    49. Compression mode : Lossy
    50. Title : Track1
    51. Default : Yes
    52. Forced : No
    53. Audio #2
    54. ID : 3
    55. Format : AAC
    56. Format/Info : Advanced Audio Codec
    57. Format profile : LC
    58. Codec ID : A_AAC-2
    59. Duration : 37 s 483 ms
    60. Channel(s) : 2 channels
    61. Channel positions : Front: L R
    62. Sampling rate : 48.0 kHz
    63. Frame rate : 46.875 FPS (1024 SPF)
    64. Compression mode : Lossy
    65. Title : Track2
    66. Default : Yes
    67. Forced : No
    Alles anzeigen
  • bframes bei OBS auf 0. Profil main
    Da die OBS Dateien schwer spulbar sind ggf keyframe auf 1.
    Guck auch OBS log ob er über was meckert. Denn da steht ja wo es hängt. Wenns die szene sein sollte hat GPU Leistung gefehlt und dann fps limiter nutzen oder halt vsync.
    Wo hakts denn? Auch im MPC-HC schon?
    Bei tmpgenc unbedingt in der dateiinfo die fps von 1000 auf 60 ändern (headermurks von OBS)





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • Anzeige
    Aus dem OBS-Log:

    Quellcode

    1. 13:15:01.431: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
    2. 13:15:01.439: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
    3. 13:15:01.487: [AMF] AMF Test failed due to one or more errors.
    4. 13:15:01.487: Failed to initialize module 'enc-amf.dll'
    5. 13:15:01.548: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
    6. 13:15:01.554: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': The specified procedure could not be found.
    7. 13:15:01.554: (127)
    8. 13:15:01.554: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
    9. 13:15:01.564: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
    Deutet das auf Probleme hin?

    edit: Die Aufnahmedatei spielt in MPC-HC ohne ruckeln ab. Also muss es irgendwo beim Rendern passieren?

    edit2: Korrigiere, die Aufnahmedatei ruckelt in MPC-HC ebenfalls. Aber mein Eindruck ist, nicht so ausgeprägt wie nach dem Rendern.
  • De-M-oN schrieb:

    bframes bei OBS auf 0. Profil main
    Da die OBS Dateien schwer spulbar sind ggf keyframe auf 1.
    Erledigt.

    De-M-oN schrieb:

    Guck auch OBS log ob er über was meckert. Denn da steht ja wo es hängt. Wenns die szene sein sollte hat GPU Leistung gefehlt und dann fps limiter nutzen oder halt vsync.
    Keine Fehlerhaften Einträge außer den oben geschrieben, die man wohl aber sämtlich ignorieren darf.

    De-M-oN schrieb:

    Bei tmpgenc unbedingt in der dateiinfo die fps von 1000 auf 60 ändern (headermurks von OBS)
    Erledigt. Ist mir gar nicht aufgefallen.

    Leider haben diese Dinge nicht zu einer Verbesserung geführt. Noch mehr Ideen?
  • Ausgaberenderer hast aber EVR-CP?
    Und:
    [IMG:https://abload.de/img/unbenannt622ius23.png]

    Ansonsten wäre noch eine OBS Log hilfreich in der dein Problem passiert ist.





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7
  • Das stand tatsächlich auf DXVA. Habe es umgestellt.

    Der Haken für vp9 lässt sich bei mir nicht aktivieren (ausgegraut).

    [IMG:https://i.imgur.com/hpZJFeN.png]

    De-M-oN schrieb:

    Ausgaberenderer hast aber EVR-CP?
    Was ist das? Wo sehe ich das?
    edit: Gefunden und aktiviert.

    Hier ein OBS-Log einer Testaufnahme:

    Brainfuck-Quellcode

    1. 13:15:00.576: CPU Name: Intel(R) Core(TM) i7-6900K CPU @ 3.20GHz
    2. 13:15:00.576: CPU Speed: 3198MHz
    3. 13:15:00.576: Physical Cores: 8, Logical Cores: 16
    4. 13:15:00.576: Physical Memory: 32678MB Total, 28154MB Free
    5. 13:15:00.576: Windows Version: 10.0 Build 17134 (revision: 1; 64-bit)
    6. 13:15:00.576: Running as administrator: false
    7. 13:15:00.576: Aero is Enabled (Aero is always on for windows 8 and above)
    8. 13:15:00.576: Windows 10 Gaming Features:
    9. 13:15:00.576: Game Bar: Off
    10. 13:15:00.576: Game DVR: Off
    11. 13:15:00.576: Game DVR Background Recording: Off
    12. 13:15:00.576: Game Mode: Off
    13. 13:15:00.578: Sec. Software Status:
    14. 13:15:00.578: Avira Antivirus: enabled (AV)
    15. 13:15:00.578: Windows Defender Antivirus: disabled (AV)
    16. 13:15:00.579: Windows-Firewall: enabled (FW)
    17. 13:15:00.579: Avira Antivirus: enabled (ASW)
    18. 13:15:00.579: Windows Defender Antivirus: disabled (ASW)
    19. 13:15:00.579: Portable mode: false
    20. 13:15:00.669: OBS 21.1.0 (64bit, windows)
    21. 13:15:00.669: ---------------------------------
    22. 13:15:00.669: ---------------------------------
    23. 13:15:00.669: audio settings reset:
    24. 13:15:00.669: samples per sec: 48000
    25. 13:15:00.669: speakers: 2
    26. 13:15:00.675: ---------------------------------
    27. 13:15:00.675: Initializing D3D11...
    28. 13:15:00.675: Available Video Adapters:
    29. 13:15:00.676: Adapter 1: NVIDIA GeForce GTX 1080
    30. 13:15:00.676: Dedicated VRAM: 4176478208
    31. 13:15:00.676: Shared VRAM: 4248217600
    32. 13:15:00.676: output 1: pos={0, 0}, size={2560, 1440}, attached=true
    33. 13:15:00.676: output 2: pos={2560, 180}, size={1680, 1050}, attached=true
    34. 13:15:00.678: Loading up D3D11 on adapter NVIDIA GeForce GTX 1080 (0)
    35. 13:15:00.730: D3D11 loaded successfully, feature level used: 45056
    36. 13:15:01.415: ---------------------------------
    37. 13:15:01.415: video settings reset:
    38. 13:15:01.415: base resolution: 1920x1080
    39. 13:15:01.415: output resolution: 1920x1080
    40. 13:15:01.415: downscale filter: Lanczos
    41. 13:15:01.415: fps: 60/1
    42. 13:15:01.415: format: NV12
    43. 13:15:01.415: YUV mode: 709/Partial
    44. 13:15:01.416: Audio monitoring device:
    45. 13:15:01.416: name: Standard
    46. 13:15:01.416: id: default
    47. 13:15:01.417: ---------------------------------
    48. 13:15:01.431: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
    49. 13:15:01.439: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
    50. 13:15:01.487: [AMF] AMF Test failed due to one or more errors.
    51. 13:15:01.487: Failed to initialize module 'enc-amf.dll'
    52. 13:15:01.548: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
    53. 13:15:01.554: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': The specified procedure could not be found.
    54. 13:15:01.554: (127)
    55. 13:15:01.554: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
    56. 13:15:01.564: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
    57. 13:15:01.577: [browser_source: 'Version: 1.31.0']
    58. 13:15:01.609: NVENC supported
    59. 13:15:01.771: VLC found, VLC video source enabled
    60. 13:15:01.789: No blackmagic support
    61. 13:15:01.813: ---------------------------------
    62. 13:15:01.813: Loaded Modules:
    63. 13:15:01.813: win-wasapi.dll
    64. 13:15:01.813: win-mf.dll
    65. 13:15:01.813: win-dshow.dll
    66. 13:15:01.813: win-decklink.dll
    67. 13:15:01.813: win-capture.dll
    68. 13:15:01.813: vlc-video.dll
    69. 13:15:01.813: text-freetype2.dll
    70. 13:15:01.813: rtmp-services.dll
    71. 13:15:01.813: obs-x264.dll
    72. 13:15:01.813: obs-vst.dll
    73. 13:15:01.813: obs-transitions.dll
    74. 13:15:01.813: obs-text.dll
    75. 13:15:01.813: obs-qsv11.dll
    76. 13:15:01.813: obs-outputs.dll
    77. 13:15:01.813: obs-filters.dll
    78. 13:15:01.813: obs-ffmpeg.dll
    79. 13:15:01.813: obs-browser.dll
    80. 13:15:01.813: image-source.dll
    81. 13:15:01.813: frontend-tools.dll
    82. 13:15:01.813: enc-amf.dll
    83. 13:15:01.813: coreaudio-encoder.dll
    84. 13:15:01.813: ---------------------------------
    85. 13:15:01.813: ==== Startup complete ===============================================
    86. 13:15:01.814: Service '' not found
    87. 13:15:01.817: All scene data cleared
    88. 13:15:01.817: ------------------------------------------------
    89. 13:15:01.950: WASAPI: Device 'Lautsprecher (Sound Blaster ZxR)' initialized
    90. 13:15:01.969: WASAPI: Device 'Shure SM7B (Focusrite USB Audio)' initialized
    91. 13:15:01.969: source 'Mic/Aux' enabled push-to-mute
    92. 13:15:01.971: [window-capture: 'RimWorld'] update settings:
    93. 13:15:01.971: executable: RimWorldWin.exe
    94. 13:15:01.974: Switched to scene 'Szene'
    95. 13:15:01.974: ------------------------------------------------
    96. 13:15:01.974: Loaded scenes:
    97. 13:15:01.974: - scene 'Szene':
    98. 13:15:01.974: - source: 'Bildschirmaufnahme' (monitor_capture)
    99. 13:15:01.974: - source: 'RimWorld' (window_capture)
    100. 13:15:01.974: ------------------------------------------------
    101. 13:15:02.038: adding 42 milliseconds of audio buffering, total audio buffering is now 42 milliseconds
    102. 13:15:57.195: Starting recording due to hotkey
    103. 13:15:57.196: ---------------------------------
    104. 13:15:57.196: [NVENC encoder: 'recording_h264'] settings:
    105. 13:15:57.196: rate_control: CQP
    106. 13:15:57.196: bitrate: 0
    107. 13:15:57.196: cqp: 16
    108. 13:15:57.196: keyint: 250
    109. 13:15:57.196: preset: hp
    110. 13:15:57.196: profile: high
    111. 13:15:57.196: level: auto
    112. 13:15:57.196: width: 1920
    113. 13:15:57.196: height: 1080
    114. 13:15:57.196: 2-pass: false
    115. 13:15:57.196: b-frames: 2
    116. 13:15:57.196: GPU: 0
    117. 13:15:57.196:
    118. 13:15:57.478: ---------------------------------
    119. 13:15:57.478: [FFmpeg aac encoder: 'Track1'] bitrate: 320, channels: 2, channel_layout: 3
    120. 13:15:57.478:
    121. 13:15:57.479: ---------------------------------
    122. 13:15:57.479: [FFmpeg aac encoder: 'Track2'] bitrate: 320, channels: 2, channel_layout: 3
    123. 13:15:57.479:
    124. 13:15:57.488: ==== Recording Start ===============================================
    125. 13:15:57.488: [ffmpeg muxer: 'adv_file_output'] Writing file 'J:/2018-05-05 13-15-57.mkv'...
    126. 13:16:34.956: Stopping recording due to hotkey
    127. 13:16:35.231: [ffmpeg muxer: 'adv_file_output'] Output of file 'J:/2018-05-05 13-15-57.mkv' stopped
    128. 13:16:35.231: Output 'adv_file_output': stopping
    129. 13:16:35.231: Output 'adv_file_output': Total frames output: 2252
    130. 13:16:35.231: Output 'adv_file_output': Total drawn frames: 2264
    131. 13:16:35.231: ==== Recording Stop ================================================
    132. 13:21:55.249: ==== Shutting down ==================================================
    133. 13:21:55.255: Switched to scene '(null)'
    134. 13:21:55.255: WASAPI: Device 'Lautsprecher (Sound Blaster ZxR)' Terminated
    135. 13:21:55.317: WASAPI: Device 'Shure SM7B (Focusrite USB Audio)' Terminated
    136. 13:21:55.327: All scene data cleared
    137. 13:21:55.327: ------------------------------------------------
    138. 13:21:55.382: Freeing OBS context data
    139. 13:21:55.403: [Scripting] Total detached callbacks: 0
    140. 13:21:55.408: == Profiler Results =============================
    141. 13:21:55.408: run_program_init: 2435.08 ms
    142. 13:21:55.408: ┣OBSApp::AppInit: 12.286 ms
    143. 13:21:55.408: ┃ ┗OBSApp::InitLocale: 1.707 ms
    144. 13:21:55.408: ┗OBSApp::OBSInit: 2406.07 ms
    145. 13:21:55.408: ┣obs_startup: 3.422 ms
    146. 13:21:55.408: ┗OBSBasic::OBSInit: 1346.08 ms
    147. 13:21:55.408: ┣OBSBasic::InitBasicConfig: 0.435 ms
    148. 13:21:55.408: ┣OBSBasic::ResetAudio: 0.137 ms
    149. 13:21:55.408: ┣OBSBasic::ResetVideo: 746.935 ms
    150. 13:21:55.408: ┣OBSBasic::InitOBSCallbacks: 0.005 ms
    151. 13:21:55.408: ┣OBSBasic::InitHotkeys: 0.047 ms
    152. 13:21:55.408: ┣obs_load_all_modules: 396.804 ms
    153. 13:21:55.408: ┃ ┣obs_init_module(coreaudio-encoder.dll): 0.701 ms
    154. 13:21:55.408: ┃ ┣obs_init_module(enc-amf.dll): 37.506 ms
    155. 13:21:55.408: ┃ ┣obs_init_module(frontend-tools.dll): 3.32 ms
    156. 13:21:55.408: ┃ ┣obs_init_module(image-source.dll): 0.005 ms
    157. 13:21:55.408: ┃ ┣obs_init_module(obs-browser.dll): 0.071 ms
    158. 13:21:55.408: ┃ ┣obs_init_module(obs-ffmpeg.dll): 8.813 ms
    159. 13:21:55.408: ┃ ┃ ┗nvenc_check: 8.766 ms
    160. 13:21:55.408: ┃ ┣obs_init_module(obs-filters.dll): 0.021 ms
    161. 13:21:55.408: ┃ ┣obs_init_module(obs-outputs.dll): 0.006 ms
    162. 13:21:55.408: ┃ ┣obs_init_module(obs-qsv11.dll): 60.164 ms
    163. 13:21:55.408: ┃ ┣obs_init_module(obs-text.dll): 0.228 ms
    164. 13:21:55.408: ┃ ┣obs_init_module(obs-transitions.dll): 0.005 ms
    165. 13:21:55.408: ┃ ┣obs_init_module(obs-vst.dll): 0.001 ms
    166. 13:21:55.408: ┃ ┣obs_init_module(obs-x264.dll): 0.001 ms
    167. 13:21:55.408: ┃ ┣obs_init_module(rtmp-services.dll): 0.018 ms
    168. 13:21:55.408: ┃ ┣obs_init_module(text-freetype2.dll): 0.131 ms
    169. 13:21:55.408: ┃ ┣obs_init_module(vlc-video.dll): 21.742 ms
    170. 13:21:55.408: ┃ ┣obs_init_module(win-capture.dll): 0.158 ms
    171. 13:21:55.408: ┃ ┣obs_init_module(win-decklink.dll): 2.696 ms
    172. 13:21:55.408: ┃ ┣obs_init_module(win-dshow.dll): 1.206 ms
    173. 13:21:55.408: ┃ ┣obs_init_module(win-mf.dll): 0 ms
    174. 13:21:55.408: ┃ ┣obs_init_module(win-wasapi.dll): 0.005 ms
    175. 13:21:55.408: ┃ ┗reset_win32_symbol_paths: 0.071 ms
    176. 13:21:55.408: ┣OBSBasic::ResetOutputs: 0.343 ms
    177. 13:21:55.408: ┣OBSBasic::CreateHotkeys: 0.18 ms
    178. 13:21:55.408: ┣OBSBasic::InitService: 1.132 ms
    179. 13:21:55.408: ┣OBSBasic::InitPrimitives: 0.218 ms
    180. 13:21:55.408: ┗OBSBasic::Load: 158.935 ms
    181. 13:21:55.409: obs_hotkey_thread(25 ms): min=0.002 ms, median=0.005 ms, max=1.002 ms, 99th percentile=0.143 ms, 100% below 25 ms
    182. 13:21:55.409: audio_thread(Audio): min=0 ms, median=0.047 ms, max=13.183 ms, 99th percentile=7.555 ms
    183. 13:21:55.409: ┗receive_audio: min=0.003 ms, median=1.832 ms, max=10.531 ms, 99th percentile=2.86 ms, 0.180411 calls per parent call
    184. 13:21:55.409: ┣buffer_audio: min=0 ms, median=0.001 ms, max=0.012 ms, 99th percentile=0.002 ms
    185. 13:21:55.409: ┗do_encode: min=0.012 ms, median=1.83 ms, max=10.528 ms, 99th percentile=2.858 ms
    186. 13:21:55.409: ┣encode(Track2): min=0.02 ms, median=1.78 ms, max=2.664 ms, 99th percentile=1.973 ms, 0.500141 calls per parent call
    187. 13:21:55.409: ┗encode(Track1): min=0.01 ms, median=1.991 ms, max=2.929 ms, 99th percentile=2.466 ms, 0.499859 calls per parent call
    188. 13:21:55.409: obs_graphics_thread(16.6667 ms): min=0.227 ms, median=1.595 ms, max=21.931 ms, 99th percentile=2.986 ms, 99.9879% below 16.667 ms
    189. 13:21:55.409: ┣tick_sources: min=0.001 ms, median=0.838 ms, max=21.103 ms, 99th percentile=2.268 ms
    190. 13:21:55.409: ┣output_frame: min=0.225 ms, median=0.655 ms, max=1.739 ms, 99th percentile=0.881 ms
    191. 13:21:55.409: ┃ ┣gs_context(video->graphics): min=0.072 ms, median=0.143 ms, max=1.252 ms, 99th percentile=0.23 ms
    192. 13:21:55.409: ┃ ┃ ┣render_video: min=0.018 ms, median=0.04 ms, max=0.22 ms, 99th percentile=0.115 ms
    193. 13:21:55.409: ┃ ┃ ┃ ┣render_main_texture: min=0.002 ms, median=0.005 ms, max=0.069 ms, 99th percentile=0.023 ms
    194. 13:21:55.409: ┃ ┃ ┃ ┣render_output_texture: min=0.004 ms, median=0.011 ms, max=0.203 ms, 99th percentile=0.029 ms
    195. 13:21:55.409: ┃ ┃ ┃ ┣render_convert_texture: min=0.001 ms, median=0.007 ms, max=0.044 ms, 99th percentile=0.024 ms
    196. 13:21:55.409: ┃ ┃ ┃ ┗stage_output_texture: min=0 ms, median=0.007 ms, max=0.18 ms, 99th percentile=0.088 ms
    197. 13:21:55.409: ┃ ┃ ┣download_frame: min=0 ms, median=0.034 ms, max=0.303 ms, 99th percentile=0.119 ms
    198. 13:21:55.409: ┃ ┃ ┗gs_flush: min=0.02 ms, median=0.05 ms, max=1.205 ms, 99th percentile=0.141 ms
    199. 13:21:55.409: ┃ ┗output_video_data: min=0.319 ms, median=0.504 ms, max=1.395 ms, 99th percentile=0.694 ms
    200. 13:21:55.409: ┗render_displays: min=0 ms, median=0.068 ms, max=1.73 ms, 99th percentile=0.126 ms
    201. 13:21:55.409: video_thread(video): min=0 ms, median=0.001 ms, max=10.256 ms, 99th percentile=1.195 ms
    202. 13:21:55.409: ┗receive_video: min=0 ms, median=1.092 ms, max=10.254 ms, 99th percentile=1.499 ms, 0.091169 calls per parent call
    203. 13:21:55.409: ┗do_encode: min=0.914 ms, median=1.092 ms, max=10.254 ms, 99th percentile=1.499 ms
    204. 13:21:55.409: ┗encode(recording_h264): min=0.914 ms, median=1.061 ms, max=3.019 ms, 99th percentile=1.291 ms
    205. 13:21:55.409: =================================================
    206. 13:21:55.409: == Profiler Time Between Calls ==================
    207. 13:21:55.409: obs_hotkey_thread(25 ms): min=24.299 ms, median=25.58 ms, max=293.65 ms, 47.7792% within ±2% of 25 ms (0.00616029% lower, 52.2146% higher)
    208. 13:21:55.409: obs_graphics_thread(16.6667 ms): min=11.395 ms, median=16.667 ms, max=21.938 ms, 99.9758% within ±2% of 16.667 ms (0.0120792% lower, 0.0120792% higher)
    209. 13:21:55.409: =================================================
    210. 13:21:55.464: Number of memory leaks: 1
    Alles anzeigen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DrWolfsherz ()

  • Ich glaube, dass das Problem nun behoben ist.

    Nach der Aufnahme einer neuen Testaufnahme, ist das ruckeln nun nicht mehr vorhanden.
    Zusätzlich zu allen Tipps hier (Vielen Dank!!), habe ich auch noch die Prozesspriorität von OBS um eine Stufe erhöht.
    Weder in der Roh-Aufnahme noch im fertig gerenderten Video sind nun noch Ruckler zu bemerken.

    So viele kleine Einstellungen an so vielen Stellen, das war gar nicht so einfach. Nochmal vielen Dank!

    Und das alles nur, weil Dxtory bei mir aus irgendeinem Grund seit dem 1803 Windows Update kein DX12 mehr mag.
  • DrWolfsherz schrieb:

    Zum Rendern benutze ich TMPGEnc mit den folgenden Werten:
    Thema scheint zwar durch zu sein - aber ich habe eine Frage bzgl. dieses TMPGEnc preset (NVENC):
    (Habe das gepostete Preset von @De-M-oN auch mal angeguckt - aber da scheint 10bit aus zu sein?)

    Würde es nicht fürs banding und die Dateigröße dienlich sein ein 10 bit encode mit NVENC zu machen ?
    Würde das merklich mehr Zeit in Anspruch nehmen ?
  • Frisst mir zu viel mehr Codierzeit. Und die Dateigrößenersparnis wiegt das bei mir nicht auf.
    Dem Banding isses dienlich, aber Youtube änderts ja eh auf 8 bit um. 10bit gibts bei Youtube ja nur in Zusammenhang mit ihren HDR Videos..





    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | DooM 2: Project Brutality | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt 4 | WRC 7