Von MSI Afterburner zu OBS Studio: Erbitte Hilfe bei Aufnahmeproblemen :(

Bitte hilf mit, das Forum zu verbessern und nimm an dieser sehr kurzen Umfrage teil: https://forms.gle/UNcxKJktwoUMEF7D7
  • Eine kurze Leidensgeschichte.
    Der Umstieg von MSI Afterburner zum Open Broadcaster Software Studio ist nichts, was ich freiwillig mache. Mir scheint eher, dass ich dazu gezwungen bin. Im Moment bin ich deswegen wohl grade auf Frustrationslevel 9/10 angekommen, was besser ist als gestern Abend: da habe ich wohl die Skala gesprengt.
    Ich habe die letzten Wochen - ach was sage ich: Monate! - damit verbracht mir Wissen anzueignen, um meinen YouTube-Kanal zu starten. Ich bin eigentlich blutiger Anfänger was sowas betrifft und habe mich vorher nie mit der Aufnahme von Videos oder ihrer Bearbeitung befasst. Auch von Audio habe ich keine Ahnung. Aber mit Hilfe dieser tollen Community hier ist es mir - mit viel investierter Zeit - gelungen das ansatzweise zu lernen und mit MSI Afterburner & dem MagicYUV Lossless Codec aufzunehmen sowie dann mit Adobe Premiere Elements für mich zufriedenstellende Videos zu machen.
    Meine erste richtige LetsPlay-Folge (von Civilization VI) habe ich dann vorgestern aufgenommen. Es hat super viel Spaß gemacht, ich war mit allem zufrieden, gut gelaunt - und habe dann gestern bei der Bearbeitung gemerkt: der Mauszeiger wurde nicht aufgenommen.


    MSI Afterburner -Das Problem
    Recherchen hier im Forum und im Netz haben einhellig ergeben: Der MSIA nimmt keine Hardware Cursor auf. Civilization VI unterstützt derzeit keine Software Cursor. Keine Ahnung,was das überhaupt ist, aber… Fazit: Ich muss ein anderes Aufnahmeprogramm nutzen, wochenlange Arbeit zum Verständnis und Optimierung meiner Aufnahmetechnik mit dem MSIA sind vollständig für die Katz gewesen.

    ;(


    Wenn doch noch jemand eine Lösung dafür weiß, nur her damit: Aber meine bisherige Recherche hat mich diese Hoffnung eigentlich aufgeben lassen.


    Tutorial zu OBSStudio
    Nachdem ich dem heftigen Drang, meine Hardware zum Fenster rauszuwerfen schließlich erfolgreich widerstanden hatte, habe ich mich also auf die Suche nach Alternativen begeben und bin bei OBSS gelandet, das ich mir vor dem MSIA schon mal angeschaut hatte.
    Einige YouTube-Video-Guides später und insbesondere nach Lektüre dieses Tutorials (https://www.letsplayforum.de/i…ie-Aufnahme-Sammelthread/)von Kayten, habe ich erste Lossless-Aufnahme-Versuche mit der neuen Software gemacht. Um mal was positives zu sagen: Das Programm gefällt mir eigentlich sehr gut. Die Bedienung ist deutlich intuitiver und übersichtlicher als die des MSIA. Meine Video-Einstellungen habe ich vollständig aus Kaytens Guide übernommen, denn vieles davon sagt mir mal wieder gar nichts. Ich habe Variante 2 (x264) gewählt. Die Audio-Einstellungen habe ich teilweise verändert, denn ich will meine Stimme vorerst mal auch weiterhin mit Audacity aufnehmen, nicht mit OBSS.


    Problem bei derAufnahme mit OBSS
    Nun habe ich aber festgestellt, dass ich - auch wenn Kaytens Guide das für Variante 2 als Ziel beschreibt - wohl kein Lossless bekommen habe. Denn
    1. fehlt einiges in der Aufnahme (die Auflösung ist zwar gestochen scharf, aber es wirkt als würden einzelne Frames fehlen. Es ruckelt zwar nicht direkt, aber es ist auch nicht flüssig. Die Animationen wirken/sind unvollständig.)
    2. Die Dateigröße spricht meinen bisherigen MSIA-Aufnahmen Hohn: MSIA-Dateigröße bei 2min Aufnahme: ca. 8 GB. OBSS-Dateigröße bei 2min Aufnahme: ca. 350 MB.

    ^^


    Für weitere Vergleichsdaten siehe hier die Screens von MediaInfo für beide Dateien meiner Probeaufnahmen:
    http://www.directupload.net/file/d/4561/mim5p32g_png.htm


    Also mache ich wohl irgendwas falsch.

    • Mein erster Verdacht waren zu geringe Framezahlen, weil es eben wirkt, als würden welche fehlen. Die Frames sind aber bei beiden Aufnahmen bei 50FPS.
    • Dann dachte ich, meine Festplatte oder CPU könnten aus welchen Gründen auch immer überlastet sein. Sind sie aber nicht: CPU geht laut Taskmanager nie über 70%, die Festplatte nicht mal über 2%. Ich habe ein wenig mit den Einstellungen zur Prozessorauslastungs-Voreinstellung herumgespielt (weil das eine der wenigen Einstellungen ist, bei der ich verstanden habe, was sie tut) aber bei keiner Einstellung gab es bei CPU oder Festplatte Probleme.
    • Und damit war ich mit meiner Weisheit dann auch schon am Ende und bitte nun Euch um Rat. Irgendwas killt die Bitrate bei meinen OBS-Aufnahmen, aber ich weiß nicht was. Sie liegt bei ca. 24 Mb/s im Vergleich zu satten 700-irgendwas Mb/s bei der Afterburner-Aufnahme.

    Wie gesagt habe ich versucht, die Einstellungen aus Kaytens Guide zu übernehmen, aber hier nochmal meine Einstellungen als Screens.
    Irgendwo muss ich ja was falsch gemacht haben?


    Video: http://www.directupload.net/file/d/4561/d6siga7r_png.htm
    Ausgabe - Aufnehmen:http://www.directupload.net/file/d/4561/bkh7pw4k_png.htm
    Erweitert: http://www.directupload.net/file/d/4561/ghdleou5_png.htm
    Audio: http://www.directupload.net/file/d/4561/oc6sjb46_png.htm
    Ausgabe - Audio: http://www.directupload.net/file/d/4561/hf4o4n93_png.htm
    ErweiterteAudioeinstellungen: http://www.directupload.net/file/d/4561/awh4z8w3_png.htm


    Wahrscheinlich hab ich einfach irgendwo nen dummen Fehler, der alles zerstört?
    Oder vllt. hat es damit zu tun,dass ich OBSS 0.16.6 verwende und der Guide noch für 0.16.2 geschrieben wurde?


    Ich hoffe, einer von euch kann mir weiterhelfen!

    ?(


    Rick

  • Erst mal gibt es einen Daumen hoch für deinen ultra-ausführlichen Fehlerbeschreibungstext.

    :D

    Sonst muss man den Leuten immer alles aus der Nase ziehen, du lieferst uns schon alles mögliche mit. Das finde ich toll!


    Was dein Problem angeht: Wenn du die Mediainfo der OBS-Aufnahmedatei auf Ansicht -> Text umstellst und den Text hier reinkopierst, dürfte vermutlich die variable Framerate drinstehen, die du mit dem VFR-Haken erlaubt hast. Und die verhindert, dass die Frames wirklich immer konstant sein müssen - also würde ich den Haken rausnehmen und es dann noch mal versuchen.


    Allgemein würde ich aber denken, dass du mit OBS bei Civilization VI nicht so wirklich glücklich wirst - das Spiel ist unfassbar CPU-intensiv und nur weil dein Taskmanager 70% anzeigt, heißt das noch lange nicht, dass deine CPU nicht überfordert ist mit der Berechnung des Spiels plus der Live-Kodierung der Frames. Von daher würde ich mich an den Gedanken gewöhnen, dass du vielleicht noch ein anderes Aufnahmeprogramm brauchst - ich würde Dxtory empfehlen, das gibt bei mir die bestmögliche Performance.

  • Erst mal gibt es einen Daumen hoch für deinen ultra-ausführlichen Fehlerbeschreibungstext.

    :D

    Sonst muss man den Leuten immer alles aus der Nase ziehen, du lieferst uns schon alles mögliche mit. Das finde ich toll!

    Wird hiermit nochmals unterstrichen.

    ^^


    Ich habe Variante 2 (x264) gewählt.

    Auch wenn ich bisher keinen Nachweis dafür (bekommen) habe, wurde ich darauf hingewiesen für x264 unter Erweitert das Farbformat auf NV12 zu belassen. Wird dein Problem zwar nicht lösen und Auswirkungen (welcher Art auch immer) im einstelligen Prozentbereich haben - wenn überhaupt -, aber erwähnt habe ich es hiermit.

    ^^


    Ansonsten noch ergänzend zu dem was Julien schrieb:

    1. fehlt einiges in der Aufnahme (die Auflösung ist zwar gestochen scharf, aber es wirkt als würden einzelne Frames fehlen.

    Eine der Schwächen von OBS Studio aus meiner Sicht. Auch der Grund, weshalb ich Dxtory nutze. Das Deaktivieren der Vorschau samt Neustarten von OBS soll da angeblich etwas Abhilfe schaffen, getestet habe ich es allerdings nicht.


    CPU geht laut Taskmanager nie über 70%

    Sollte dir das zu viel sein, könntest du Variante 1 mit UtVideo probieren. Da du deine zweite Audiospur eh mit Audacity aufnimmst - was ich zwar nicht empfehle -, ist der Mehraufwand für die UtVideo-Variante doch sehr gering, da du nur die Einstellungen der ersten OBS Instanz übernehmen müsstest. Zusätzlich hättest du noch den Vorteil von verlustfreiem Audiomaterial, was bei Variante 2 nicht gegeben ist.


  • Zitat

    Erst mal gibt es einen Daumen hoch für deinen ultra-ausführlichen Fehlerbeschreibungstext.

    Sonst muss man den Leuten immer alles aus der Nase ziehen, du lieferst uns schon alles mögliche mit. Das finde ich toll!

    Danke für das Lob zum Text. Sagen wir mal, es ist nicht das erste mal, dass ich hier ne Frage stelle und man hat mir auch erklärt, wie ich am besten Infos mitliefere, die beim Antworten helfen. Daher mach ich das. Außerdem bin ich immer wieder begeistert, wie einem hier geholfen wird, daher will ich euch das Ganze natürlich auch möglichst einfach machen, wenn ihr schon eure Zeit für mich aufwendet!

    :)


    Zitat

    Was dein Problem angeht: Wenn du die Mediainfo der OBS-Aufnahmedatei auf Ansicht -> Text umstellst und den Text hier reinkopierst, dürfte vermutlich die variable Framerate drinstehen, die du mit dem VFR-Haken erlaubt hast. Und die verhindert, dass die Frames wirklich immer konstant sein müssen - also würde ich den Haken rausnehmen und es dann noch mal versuchen.


    Media-Info:


    Stimmt... das mit der Variablen Framerate hatte ich mal aktiviert, um zu schauen, ob sich was ändert. Hatte ich vergessen zu erwähnen und wohl auch vergessen wieder rauszunehmen. Allerdings war es sowohl mit als auch ohne dasselbe Ergebnis.


    Trotzdem werde ich es zusammen mit den Vorschlägen der anderen nochmal versuchen und den Haken wieder rausnehmen.


    Zitat

    Allgemein würde ich aber denken, dass du mit OBS bei Civilization VI nicht so wirklich glücklich wirst - das Spiel ist unfassbar CPU-intensiv und nur weil dein Taskmanager 70% anzeigt, heißt das noch lange nicht, dass deine CPU nicht überfordert ist mit der Berechnung des Spiels plus der Live-Kodierung der Frames. Von daher würde ich mich an den Gedanken gewöhnen, dass du vielleicht noch ein anderes Aufnahmeprogramm brauchst - ich würde Dxtory empfehlen, das gibt bei mir die bestmögliche Performance.


    *seufz* Ich hatte so gehofft, ihr sagt mir sowas wie "Klar. Mach da den Haken raus und setz WertX auf 5, dann läufts!". War wohl nichts.

    ^^


    Dxtory... Hat jemand nen Tipp für nen guten Guide/Tutorial oder so?


    Ausgabe - Haken bei VFR raus (Variable Frame Rate)
    Erweitert - Farbformat auf NV12


    sonst scheint es OK sofern du keine zwei audio spuren willst.


    Ein OBS Logfile wäre noch hilfreich.

    Werde ich mal versuchen, danke.
    Wie bekomme/erzeuge ich dieses Logfile?

  • Sollte dir das zu viel sein, könntest du Variante 1 mit UtVideo probieren. Da du deine zweite Audiospur eh mit Audacity aufnimmst - was ich zwar nicht empfehle -, ist der Mehraufwand für die UtVideo-Variante doch sehr gering, da du nur die Einstellungen der ersten OBS Instanz übernehmen müsstest. Zusätzlich hättest du noch den Vorteil von verlustfreiem Audiomaterial, was bei Variante 2 nicht gegeben ist.

    Da ihr zwei hier, Julien und selbst du, der du das Tutorial für OBS geschrieben hast, OBS aus Performance-Gründen nicht nutzt, werde ich meine Versuche hier dann wohl auch wieder einstellen, sollte diese zweite Probeaufnahme wieder ein schlechtes Ergebnis liefern. (was ich ja ehrlich gesagt befürchte)


    Aber trotzdem nachgefragt:
    Wenn ich denn mit OBSS mein Micro gleich mitaufnehme, landet das dann in einer zweiten, extra Datei? Oder wird es in den Container mit reingepackt? Denn wenn Zweiteres der Fall sein sollte... wie bearbeite ich diese Audiospur dann nach?


    Ansonsten noch ergänzend zu dem was Julien schrieb:
    Eine der Schwächen von OBS Studio aus meiner Sicht. Auch der Grund, weshalb ich Dxtory nutze. Das Deaktivieren der Vorschau samt Neustarten von OBS soll da angeblich etwas Abhilfe schaffen, getestet habe ich es allerdings nicht.

    Werde ich meinem nächsten Aufnahmeversuch hinzufügen. Mal schauen, was passiert,


    Aber mal ne andere Frage, wenn das was ich hier beschreibe, das Problem bei OBS ist, wie kann das dann jemals "lossless" Aufnahmen liefern, wie du in deinem Tutorial geschrieben hast? Die Dateigrößenunterschiede zwischen meinen Aufnahmen aus MSIA & OBSS oben zeigen ja dann wohl, dass das KEIN lossless ist, was da rauskommt. Oder habe ich dich entweder hier oder im Tutorial irgendwie falsch verstanden? Oder habe ich ganz falsch verstanden, was lossless bedeutet?

    :D
  • Die MediaInfo zeigt eindeutig, dass du verlustfreies Material bekommst ("qp=0" bei den Kodierungseinstellungen).


    Wie bekomme/erzeuge ich dieses Logfile?

    Es wird bei jedem Start von OBS Studio eine neue Log-Datei erstellt. Zu finden ist diese wie im Tutorial angegeben unter "Hilfe". Natürlich sollte auch ein Aufnahmeversuch in der Log-datei zu finden sein, sonst bringt diese herzlich wenig.


    Dxtory... Hat jemand nen Tipp für nen guten Guide/Tutorial oder so?

    Ich verweise mal hierauf, auch wenn ich mal wieder was überarbeiten müsste, gerade was die Advanced-Settings betrifft: Dxtory - Einstellungen & Sammelthread



    Edit, da ich den neuen Beitrag noch nicht gesehen hatte:


    Oder wird es in den Container mit reingepackt? Denn wenn Zweiteres der Fall sein sollte... wie bearbeite ich diese Audiospur dann nach?

    Eine zweite Audiospur kommt bei OBS, MSI AB und Dxtory mit in den selben Container und muss entweder erst extrahiert werden, beispielsweise mit SagaraS Scriptmaker (GUI), Dxtory beigeliefertem Tool, was über Rechtsklick auf die jeweilige Datei erreicht werden kann oder dein Bearbeitungsprogramm versteht das von Haus aus, was eher selten der Fall ist.


    Aber mal ne andere Frage, wenn das was ich hier beschreibe, das Problem bei OBS ist, wie kann das dann jemals "lossless" Aufnahmen liefern, wie du in deinem Tutorial geschrieben hast? Die Dateigrößenunterschiede zwischen meinen Aufnahmen aus MSIA & OBSS oben zeigen ja dann wohl, dass das KEIN lossless ist, was da rauskommt.

    x264 liebt Standbilder. Die lassen sich nämlich prima komprimieren, da sie (fast) identisch zum Vorgängerbild sind. MagicYUV und UtVideo machen sowas nicht, die betrachten jeden Frame einzeln, ohne Vorgänger und Nachfolger. Und Civilization dürfte viele quasi Standbilder haben.


    und selbst du, der du das Tutorial für OBS geschrieben hast

    Irgendwer muss ein Tutorial schreiben!

    ^^

    Wir hatten hier im Forum einfach monatelang keins. Ich bin mir sicher, dass @Schauerland das mindestens genau so gut, wenn nicht gar besser könnte. Er verwendet OBS Studio meines Wissens nach hauptsächlich.

  • NV12 wird von den Entwicklern empfohlen und ist nicht umsonst standardmäßig eingestellt.
    https://obsproject.com/forum/t…er-better-for-x264.55488/


    x264 nutzt intern auch nv12; da ich aber keine Lust habe Sourcodes zu durchsuchen, da sonst nach Beweisen geschriehen wird lasse ich das mal.


    für utvideo muss es jedoch auf I420 gestellt werden da der codec das nur kann.


    ich nutze OBS studio seit über 'nem Jahr ich finde es nicht unperformat, ganz im gegenteil.
    Nur wenn deine Grafikkarte 100% Auslastung hat kommt es zu lags in der preview bzw dem scene render (da die Szene von der Grafikkarte gerendert wird - das gecapturte image geht nämlich nicht direkt an den encoder sondern wird auf einer szene gerendert, da man dort auch noch andere dinge wie fressencam, text, bilder oder sonst was draufpacken kann)
    Das Deaktivieren bringt dann ein wenig was, ganz weg geht es aber nicht da halt trotzdem gerendert wird.


    zwei Spuren hast du im container idr MP4. Premiere hat damit keine Probleme habe direkt zwei spuren drin. vegas sollte das auch können.
    extrahieren kannst du die spuren auch mit yamb
    http://www.videohelp.com/software/YAMB


    oder mp4box (konsolen tool) worauf yamb basiert - ich für meinne fall mache solche Sachen immer mit konsole, mp4box und ffmpeg

    :)


    oder du lädst sie in Audacity mit ffmpeg plugin und kannst sie wieder als wav oder sonst was speichern.

  • Hm interessant... ich habe eine weitere Testaufnahme gemacht und die von Schauerland angemerkten Änderungen umgesetzt, also:

    Ausgabe - Haken bei VFR raus (Variable Frame Rate)
    Erweitert - Farbformat auf NV12

    Trotz der Anpassungen keine - für mich - sichtbaren Veränderungen im File.
    Problem besteht weiter.


    Außerdem habe ich mal meine GraKa via MSIA im Auge behalten: Laut dessen Anzeige "GPU usage" war die GPU nie mehr als zu 35% ausgelastet. Das ist doch der relevante Wert, oder?


    Logfile habe ich ebenfalls gefunden.
    Danke für die Info, wo ich es finde

    :)


    Viel versteh ich von dem Kram da drin nicht, aber das hier fand ich interessant:

    Zitat

    14:34:26.296: Output 'adv_file_output': Number of skipped frames due to encoding lag: 160 (4.5%)
    14:34:26.296: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 3 (0.1%)

    Knappe 5% der Frames gehen wegen "lags" verloren.
    Kann das das Problem sein? Oder ist es normal, dass einige verloren gehen?


    Vollständiges Logfile:


    Jetzt versuch ich mal noch eine Aufnahme mit deaktivierter Vorschau. Mal schauen, ob das was bringt.


    Auch danke für die restlichen Erläuterungen zu Audiospuren!
    Vllt versuch ich das dann doch mal, wenn die Basics funktionieren.^^

  • Deine CPU ist zu schwach


    Number of skipped frames due to encoding lag: 160 (4.5%)


    mit ner GTX 1060 kannst du via nvenc auch problemlos lossless aufnehmen.


    stellst auf nvenc und dann profile standard oder high performance ein (HP = größere datei ansonsten beides lossless). Dann sollte es besser sein.

  • Versuch mit deaktivierter Vorschau lässt die verlorenen Frames wegen "lag" aus den Logs verschwinden, aber die Aufnahme ist noch immer nicht so flüssig, wie das Originalspiel.


    Log:



    Aha? Und was ist dieser nvenc?
    Also ich nehme an unter "Codierer" von x264 auf NVENC H.264 umstellen...
    aber warum hat das mit meiner GTX 1060 zu tun? Ist die dafür irgendwie besonders gut geeignet?
    Ist NVENC ein besserer oder schlechterer Codec als der x264?


    Sry, hab halt gar keine Ahnung, aber ich versuch immer zu verstehen, warum ich bestimmte Dinge tun soll. Die Hoffnung ist, dass sich das mit dem "keine Ahnung haben" dann über die Zeit verbessert. ^^'


    Ich probier's direkt mal aus und gebe Meldung über das Ergebnis.

  • Viel versteh ich von dem Kram da drin nicht, aber das hier fand ich interessant:


    Knappe 5% der Frames gehen wegen "lags" verloren.Kann das das Problem sein? Oder ist es normal, dass einige verloren gehen?

    Das ist der für uns auch interessanteste Teil. Meiner Erfahrung nach ist es in OBS Studio mehr oder minder normal, dass da welche verloren gehen. Bei längeren Aufnahmen fällt das weniger ins Gewicht, da gerade beim Start der Aufnahme gerne mal was verworfen wird.
    Die erste Zeile deutet auf die CPU hin, die zweite auf die GPU.


    Jetzt versuch ich mal noch eine Aufnahme mit deaktivierter Vorschau. Mal schauen, ob das was bringt.

    Du wirst sowieso vieles testen müssen, OBS mit x264, OBS mit UtVideo, OBS mit NvEnc, Dxtory mit MagicYUV, etc.
    Eins davon wird für dich am besten funktionieren, was nicht bedeutet, dass es für alle Fälle das richtige Mittel ist. Das Programm meiner Wahl ist Dxtory, trotzdem war es schon nötig mal MSI AB oder OBS Studio zu nutzen. Es ist also immer hilfreich mindestens zwei Aufnahmeprogramme parat zu haben.


    NV12 wird von den Entwicklern empfohlen und ist nicht umsonst standardmäßig eingestellt.

    "Das musst du so nutzen weil Grafikkarte" ist nun mal keine Begründung mit der ich mich begnüge. Das hat für mich die Aussagekraft des Wahrheitsgehalts eines Perpetuum Mobiles auf YouTube.
    Ich hätte gerne einen praxisnahen Test der zeigt, dass die Nutzung von NV12 tatsächlich einen spürbaren oder zumindest messbaren Vorteil bietet. Wüsste ich, wie sich das am besten umsetzen ließe, würde ich mich selbst daran setzen.
    Wer sich bei x264 aus Performancegründen bereits mit i420 und NV12 befassen muss, dem wird der (falls überhaupt existente) Performancevorteil nicht weiterhelfen und hat aus meiner Sicht gänzlich andere Probleme. Gehört bisher aus meiner Sicht in die Kategorie "nett zu wissen, aber in der Praxis unwichtig".

    Trotz der Anpassungen keine - für mich - sichtbaren Veränderungen im File.

    Wie bereits geschrieben, NV12 wird die Auslastung deines PCs in keinster Weise merklich beeinflussen. Hast du wirkliche Performanceprobleme, musst du an anderen Stellen Regler drehen.


    Edit:

    Also ich nehme an unter "Codierer" von x264 auf NVENC H.264 umstellen...
    aber warum hat das mit meiner GTX 1060 zu tun? Ist die dafür irgendwie besonders gut geeignet?
    Ist NVENC ein besserer oder schlechterer Codec als der x264?

    x264 ist der Encoder und produziert H.264 (Codec) Material. NVENC H.264 ist auch ein Encoder und produziert ebenfalls H.264 Material, mit dem Unterschied, dass NVENC auf der GPU läuft und x264 auf der CPU und wenn deine CPU mit der Last nicht klar kommt, warum nicht die Last auf die GPU verlagern?
    Seit der GTX900er Reihe können Nvidia Grafikkarten lossless H.264 Material hervorbringen.

  • @Kayten glaub was du willst, ich glaube den Entwicklern - die werden sich sicherlich mehr damit befasst haben als jeder von uns. Vermutlich kann ich dir eh jeden Link der Welt präsentieren, den würdest du nicht anerkennen.



    Aha? Und was ist dieser nvenc?
    Also ich nehme an unter "Codierer" von x264 auf NVENC H.264 umstellen...
    aber warum hat das mit meiner GTX 1060 zu tun? Ist die dafür irgendwie besonders gut geeignet?
    Ist NVENC ein besserer oder schlechterer Codec als der x264?

    Naja deine Grafikkarte kann halt auch sehr performant h264 encodieren und gerade die 10xx sind nochmal ne ecke besser als die 9xx
    dadurch wird deine lahme cpu entlastet und da lossless = lossless ist hast du keinen qualitätsverlust bei viel besserer Leistung.


    x264 ist einfach nur der Encodername, produziert aber H.264 (video standard) genau wie NVENC

  • Naja deine Grafikkarte kann halt auch sehr performant h264 encodieren und gerade die 10xx sind nochmal ne ecke besser als die 9xx
    dadurch wird deine lahme cpu entlastet und da lossless = lossless ist hast du keinen qualitätsverlust bei viel besserer Leistung.

    Was ich nur bemerkenswert finde, das Afterburner mir 1 Ghz weniger VRAM Takt anzeigt, sowie NVEnc von Drittsoftware benutzt wird. Bei Shadowplay passiert das nicht.


  • Vermutlich kann ich dir eh jeden Link der Welt präsentieren, den würdest du nicht anerkennen.

    Was ich eigentlich amüsant finde: Du argumentierst hier ähnlich wie De-M-oN woanders.

    Die Mehrheit (und zwar die Absolute) sieht es nicht. Punkt aus. Isso.

    Er redet vom besseren Bild (technischer Fakt) und du davon, dass es eh keiner sieht.
    Nun der umgekehrte Fall: Du beziehst dich auf den technischen Fakt und ich deute auf die Irrelevanz in der Praxis hin.


    Oh the irony.

  • Er redet vom besseren Bild (technischer Fakt) und du davon, dass es eh keiner sieht.
    Nun der umgekehrte Fall: Du beziehst dich auf den technischen Fakt und ich deute auf die Irrelevanz in der Praxis hin.


    Oh the irony.

    Du fragtest nach dem Grund warum die Entwickler es empfehlen und einer Quelle.
    Beides habe ich geliefert. Mir ist ganz egal was du bei dir einstellst ^-^. Es war ja auch nur meine Empfehlung an den TS und du wolltest den Grund wissen. Dass 1% den Braten nicht fett machen weiß ich auch.
    Umgekehrt bietet das Einstellen von I420 keinen Mehrwert oder?


    Genauso ist es nicht "falsch" vfr einzustellen wie der ts es gemacht hat - über meine Empfehlung den Haken raus zu nehmen regt sich jedoch niemand auf.

  • Um mal wieder on-topic zu kommen.
    Ich würde noch den coreaudio encoder (dll) installieren.
    Am einfachsten geht das indem du einfach iTunes installierst. Der ist weitaus performanter (mehr als 1% :)) als der von ffmpeg
    und wird *trommelwirbel* von den Entwicklern empfohlen.


    Sieht man ach im Log dass der nicht installiert ist. OBS findet die dll dann von alleine und läd sie.

  • Die erste Zeile deutet auf die CPU hin, die zweite auf die GPU.

    x264 ist der Encoder und produziert H.264 (Codec) Material. NVENC H.264 ist auch ein Encoder und produziert ebenfalls H.264 Material, mit dem Unterschied, dass NVENC auf der GPU läuft und x264 auf der CPU und wenn deine CPU mit der Last nicht klar kommt, warum nicht die Last auf die GPU verlagern?
    Seit der GTX900er Reihe können Nvidia Grafikkarten lossless H.264 Material hervorbringen.

    Naja deine Grafikkarte kann halt auch sehr performant h264 encodieren und gerade die 10xx sind nochmal ne ecke besser als die 9xx
    dadurch wird deine lahme cpu entlastet und da lossless = lossless ist hast du keinen qualitätsverlust bei viel besserer Leistung.


    x264 ist einfach nur der Encodername, produziert aber H.264 (video standard) genau wie NVENC


    Yay! Das sind tolle Infos. Vielen Dank! So verstehe ich, wo der Vorteil liegt!


    Ich denke, dann werde ich in jedem Fall beim NVENC bleiben. DENN meine Testaufnahmen hab ich bisher am Anfang von Spielen gemacht... wenn da die CPU schon das Wackeln anfängt, dann wird's im weiteren Spielverlauf wohl noch "interessanter", wenn die Karte erst mal mit Städten und Einheiten gepflastert ist^^
    Wenn da die GraKa dann das Rendern übernimmt, kann sich die CPU aufs Game konzentrieren.


    Neue Aufnahme mit NVENC habe ich gemacht. Es ist besser.
    Nicht so gut wie die Aufnahmen mit dem Afterburner, aber ich denke mal ok.


    Das sind die Einstellungen, die ich verwendet hab, den Rest habe ich gleich gelassen:
    http://www.directupload.net/file/d/4561/4qomzvt4_png.htm


    Sollte ich da noch was anpassen? Profil? Main? High? Was auch immer das macht? "high" klingt gut^^


    Edit:
    Media Info:


    Logfile:


    Edit: Hab den letzten Test mit NVENC mal auf YouTube hochgeladen.
    Was meint ihr?
    Ist noch nicht ganz so, wie es final wäre, denn dann würde ich es mit Adobe Premiere Elements noch etwas hochskalieren, um den besseren YouTube_Encoder zu bekommen. Das wurde mir hier mal an anderer Stelle beigebracht.

    :)


    Aber so als Eindruck mal:


    YouTube ist übrigens der Meinung, das wäre verwackelt... hm...

    Zitat von Youtube

    "Wir haben festgestellt, dass dein Video eventuell verwackelt ist. Sollen wir es stabilisieren?


    Edit2: Gibt noch andere Dinge, die ihr gesagt hattet, auf die ich noch eingehen will. Aber jetzt muss ich erst mal ne Weile vom PC weg. Danke jedenfalls nochmal bis hier hin. Bin gespannt, was ihr zur Aufnahme sagt.

    :D

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!