Shotcut: Gratis-Videoschnittprogramm

Ich brauche deine Hilfe, um den Fortbestand des LetsPlayForums zu sichern: Mehr Informationen findest du hier!
  • Nein, wahrscheinlich machst du nichts falsch. Shotcut berechnet live die aktuellen Passagen, die du abspielen möchtest und das belastet CPU und vor allem auch das RAM. Du kannst dem entgegen wirken, indem du die Stelle, die du gerade bearbeiten willst, erstmal ruckelig abspielst, um es danach flüssig abspielen zu können. Das ist zwar etwas lästig, funktioniert aber gut, gerade bei sehr großen Dateien.

  • ShotCut nutzt doch ausschließlich FFmpeg oder? Dann kannst du meines Wissens nach lediglich probieren die interne FFmpeg Version durch eine neuere zu ersetzen, falls das möglich ist, denn erst in einer neuen wurde ein MagicYUV Decoder hinzugefügt. Vielleicht reicht es ja auch ShotCut selbst zu aktualisieren.

  • ShotCut nutzt doch ausschließlich FFmpeg oder? Dann kannst du meines Wissens nach lediglich probieren die interne FFmpeg Version durch eine neuere zu ersetzen, falls das möglich ist

    Ist möglich.

    Da gibt's drei Möglichkeiten:

    • Entweder du nimmst mit UtVideo auf, bis ShotCut seine FFmpeg-Version aktualisiert.
    • Oder du patcht ShotCut und nimmst eine aktuelle FFmpeg-Version. Es müsste genügen, wenn du dir aktuelle Builds hier besorgst. Du benötigst die 64Bit Shared. Das lädst dir dann runter und kopierst die entpackten Dateien ins ShotCut-Verzeichnis. Müsste dann ein paar Dateien überschreiben und dann funktionieren. Oder auch nicht.
    • Oder du belässt den Whitescreen und freust dich, dass auf YouTube zur Abwechslung keine hässlichen Kompressionsartefakte sichtbar sind.
  • Ich hatte vorgestern bei einem Video das Problem, dass immer wenn ich eine Überschneidung eingebaut habe Shotcut abgestürzt ist sobald es an diesem Punkt beim abspielen war. Und des Exportieren hat auch nicht funktionieren, also musste ich alle Übergänge umbauen zu Hardcuts.


    Kennt jemand das Problem bzw hat eine Lösung dafür?


    gruß
    derPilly

  • Ich hatte das Problem auch vor ein paar Tagen.
    Lösung war einfach den Übergangspart in eine separate Videospur zu schieben.


    Allerdings trat bei mir der Fehler kurz danach nochmal auf und da funktionierte diese Methode nicht. Stattdessen mußte ich die beiden Videoteile in eine 2.Videospur kopieren, den Übergang erstellen und dann den Rest löschen.
    Dabei mußt du aber auf die Schnitte in der ursprünglichen Spur achten.

  • Ich bin zu Shotcut gewechselt. Da schneidet es sich sehr bequem.

    Shotcut kommt bei mir ausm Stottern nicht raus. In der Quelle-Vorschau läuft alles super flüssig, wenn ich die Timeline abspiele Stottern des Todes. Ich kann nicht mal vernünftig überprüfen oder das Video synchron ist.


    P.S. synchronisieren geht mal gar nicht? Ich ziehe den Ton dem Bild passend hin, ziehe das Ende/Anfang von Auidio "lang" bzw. kurz. Aber statt einfach die Spur zu verlängern/verkürzen, verschiebt Shotcut die Spur wieder falsch

    ;(
  • Verstehe ich dich richtig, dass du die Tonspur mit dem Bild synchronisiert hast und dann beim anpassen der Länge die Spur verrutscht?


    Zu deinem 1. Problem: Ich kann dir nur sagen, was ich derpilly schon gesagt habe:



    Hi,


    ich habe das Problem, wenn ich mehrere Video und Audiospuren habe, dass ich es in der Vorschau kaum laufen lassen kann, da es extrem hängt.
    Mache ich was flasch?

    Nein, wahrscheinlich machst du nichts falsch. Shotcut berechnet live die aktuellen Passagen, die du abspielen möchtest und das belastet CPU und vor allem auch das RAM. Du kannst dem entgegen wirken, indem du die Stelle, die du gerade bearbeiten willst, erstmal ruckelig abspielst, um es danach flüssig abspielen zu können. Das ist zwar etwas lästig, funktioniert aber gut, gerade bei sehr großen Dateien.

    Das mit dem Passage doppelt abspielen habe ich auch gemerkt.
    Hatte nur gehofft, dass es leichter funktioniert bzw Einstellungssache ist

    ;-)


    Danke für deine schnelle Antwort @Gjormun

    ^^

    ^^


    Das Einzige was du noch machen kannst, wäre eine Spur, die du nicht brauchst, stumm zu stellen bzw. hide zu drücken, damit sie nicht abgespielt wird.

    Das ist doch mal ein Tipp. Das werde ich mal testen. Danke dir!!


    Zu der Sache mit der Tonspur:
    Generell ist das anpassen der Länge der Tonspur unnötig, auch wenn es die Übersicht vielleicht verbessert.

    ;)


    Ich habe es gerade bei mir in einem fertig geschnittenen Video ausprobiert und es funktionierte ohne Probleme egal ob mit oder ohne Ripple-Funktion. Wichtig ist nur das man den grünen/roten Balken sieht und den Doppelpfeil.


    Allerdings gibt es 2 Einschränkungen:
    1. Du kann eine Tonspur nicht über ihre Ursprungsgröße strecken. Es wird also keine Stille hinzugefügt!
    2. Am Beginn des Videos mußt du die Einrasten-Funktion deaktivieren, um die Spur bewegen zu können.

  • Du kannst auch in der Timeline eine Audiospur aufmachen und das Video dort reinziehen. Unter Eigenschaften -> Audio kannst du die einzelnen Tracks anwählen.
    Also in deinem Fall eine Videospur + 2 Audiospuren. Wie gut die Performance von Shotcut ist müßtest du ausprobieren.


    Das Extrahieren der Spuren hat natürlich den Vorteil, dass es viel bessere Bearbeitungsmöglichkeiten außerhalb von Shotcut gibt.

  • Hallo! Brauche mal wieder Hilfe

    :D


    Habe alles so eingestellt beim exportieren wie es im VIdeo angegeben ist. Wenn ich die Datei dann als mp4 exportierne will, ist irgendwie nur die Tonspur zu hören, aber kein Bild da. Weder mit Media Player, Itunes oder VLC. Und bei Youtube schlägt die Verarbeitung einer auf 30 sekundne gekürzten Testversion fehlt. Es ist als mp4 Format abgespeichert und mit Codec libx264 kodiert. Was ist da los?

    :(


    Innerhalb des Programms seh ich den Film so wie er sein soll, Video und Audio.


    EDIT: Auch das abspeichern als .avi hat nichts geändert

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!